diff options
author | Dalon Westergreen <dwesterg@gmail.com> | 2019-12-04 10:44:11 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-04 10:57:34 -0800 |
commit | 18735f33d7ecd026ced77dce12fc8c106887c843 (patch) | |
tree | 85649e073a83f4857c88d95bba5a0f85b66e2ef0 | |
parent | 062ccdd41007aff3e0bbed1461bf9288da06acee (diff) | |
download | meta-altera-18735f33d7ecd026ced77dce12fc8c106887c843.tar.gz |
kernel: sync supported kernels with master
Thud should only have supported kernel versions.
Signed-off-by: Dalon Westergreen <dwesterg@gmail.com>
-rw-r--r-- | recipes-kernel/linux/linux-altera-configs.inc | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera-ltsi-rt_4.14-73.bb | 17 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera-ltsi-rt_4.14.126.bb | 13 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera-ltsi_4.14.130.bb | 13 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera-ltsi_4.14.73.bb | 17 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera_5.0.bb | 8 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera_5.1.bb | 13 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera_5.2.bb | 13 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-altera_5.3.bb | 13 |
9 files changed, 69 insertions, 42 deletions
diff --git a/recipes-kernel/linux/linux-altera-configs.inc b/recipes-kernel/linux/linux-altera-configs.inc index d97217c..3e4fd8b 100644 --- a/recipes-kernel/linux/linux-altera-configs.inc +++ b/recipes-kernel/linux/linux-altera-configs.inc | |||
@@ -1,7 +1,3 @@ | |||
1 | 1 | ||
2 | KBUILD_DEFCONFIG ?= "socfpga_defconfig" | 2 | KBUILD_DEFCONFIG ?= "socfpga_defconfig" |
3 | KBUILD_DEFCONFIG_stratix10swvp ?= "defconfig" | ||
4 | KBUILD_DEFCONFIG_stratix10 ?= "defconfig" | ||
5 | KBUILD_DEFCONFIG_10m50 ?= "10m50_defconfig" | ||
6 | |||
7 | KCONFIG_MODE ?= "--alldefconfig" | 3 | KCONFIG_MODE ?= "--alldefconfig" |
diff --git a/recipes-kernel/linux/linux-altera-ltsi-rt_4.14-73.bb b/recipes-kernel/linux/linux-altera-ltsi-rt_4.14-73.bb deleted file mode 100644 index 7635030..0000000 --- a/recipes-kernel/linux/linux-altera-ltsi-rt_4.14-73.bb +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | LINUX_VERSION = "4.14.73" | ||
2 | LINUX_VERSION_SUFFIX = "-ltsi-rt" | ||
3 | |||
4 | SRCREV = "d28435f2010b6fa334bd6abe709f7cd890ccc22c" | ||
5 | |||
6 | include linux-altera.inc | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
9 | |||
10 | #DE0 dts name changed in later kernels | ||
11 | KERNEL_DEVICETREE_remove_cyclone5 = "socfpga_cyclone5_de0_nano_soc.dtb" | ||
12 | KERNEL_DEVICETREE_append_cyclone5 = "socfpga_cyclone5_de0_sockit.dtb" | ||
13 | |||
14 | SRC_URI_append_cyclone5 = " file://config_lbdaf.cfg " | ||
15 | SRC_URI_append_arria5 = " file://config_lbdaf.cfg " | ||
16 | SRC_URI_append_arria10 = " file://config_lbdaf.cfg " | ||
17 | |||
diff --git a/recipes-kernel/linux/linux-altera-ltsi-rt_4.14.126.bb b/recipes-kernel/linux/linux-altera-ltsi-rt_4.14.126.bb new file mode 100644 index 0000000..9bada4a --- /dev/null +++ b/recipes-kernel/linux/linux-altera-ltsi-rt_4.14.126.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LINUX_VERSION = "4.14.126" | ||
2 | LINUX_VERSION_SUFFIX = "-ltsi-rt" | ||
3 | |||
4 | SRCREV = "652711a08dbe255d0aa3c2dd7231d6c6bfc61817" | ||
5 | |||
6 | include linux-altera.inc | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
9 | |||
10 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " | ||
11 | SRC_URI_append_arria5 = " file://lbdaf.scc " | ||
12 | SRC_URI_append_arria10 = " file://lbdaf.scc " | ||
13 | |||
diff --git a/recipes-kernel/linux/linux-altera-ltsi_4.14.130.bb b/recipes-kernel/linux/linux-altera-ltsi_4.14.130.bb new file mode 100644 index 0000000..22efe0a --- /dev/null +++ b/recipes-kernel/linux/linux-altera-ltsi_4.14.130.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LINUX_VERSION = "4.14.130" | ||
2 | LINUX_VERSION_SUFFIX = "-ltsi" | ||
3 | |||
4 | SRCREV = "cae629555019eb0d3f63d9e8e639a982e994e80f" | ||
5 | |||
6 | include linux-altera.inc | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
9 | |||
10 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " | ||
11 | SRC_URI_append_arria5 = " file://lbdaf.scc " | ||
12 | SRC_URI_append_arria10 = " file://lbdaf.scc " | ||
13 | |||
diff --git a/recipes-kernel/linux/linux-altera-ltsi_4.14.73.bb b/recipes-kernel/linux/linux-altera-ltsi_4.14.73.bb deleted file mode 100644 index bb013a9..0000000 --- a/recipes-kernel/linux/linux-altera-ltsi_4.14.73.bb +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | LINUX_VERSION = "4.14.73" | ||
2 | LINUX_VERSION_SUFFIX = "-ltsi" | ||
3 | |||
4 | SRCREV = "d6b8a5d4b162e7b67f73fc1cd69d8c69c895d787" | ||
5 | |||
6 | include linux-altera.inc | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
9 | |||
10 | #DE0 dts name changed in later kernels | ||
11 | KERNEL_DEVICETREE_remove_cyclone5 = "socfpga_cyclone5_de0_nano_soc.dtb" | ||
12 | KERNEL_DEVICETREE_append_cyclone5 = "socfpga_cyclone5_de0_sockit.dtb" | ||
13 | |||
14 | SRC_URI_append_cyclone5 = " file://config_lbdaf.cfg " | ||
15 | SRC_URI_append_arria5 = " file://config_lbdaf.cfg " | ||
16 | SRC_URI_append_arria10 = " file://config_lbdaf.cfg " | ||
17 | |||
diff --git a/recipes-kernel/linux/linux-altera_5.0.bb b/recipes-kernel/linux/linux-altera_5.0.bb index abc8d28..b95de49 100644 --- a/recipes-kernel/linux/linux-altera_5.0.bb +++ b/recipes-kernel/linux/linux-altera_5.0.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | LINUX_VERSION = "5.0" | 1 | LINUX_VERSION = "5.0" |
2 | 2 | ||
3 | SRCREV = "0ac4bbee4a6aa918e8e9bf2552770517cf6472fc" | 3 | SRCREV = "bc95527ed36b1b08bf699abbf1a67e5ecca1c5f8" |
4 | 4 | ||
5 | include linux-altera.inc | 5 | include linux-altera.inc |
6 | 6 | ||
@@ -8,6 +8,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | |||
8 | 8 | ||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | 9 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" |
10 | 10 | ||
11 | SRC_URI_append_cyclone5 = " file://config_lbdaf.cfg " | 11 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " |
12 | SRC_URI_append_arria5 = " file://config_lbdaf.cfg " | 12 | SRC_URI_append_arria5 = " file://lbdaf.scc " |
13 | SRC_URI_append_arria10 = " file://config_lbdaf.cfg " | 13 | SRC_URI_append_arria10 = " file://lbdaf.scc " |
diff --git a/recipes-kernel/linux/linux-altera_5.1.bb b/recipes-kernel/linux/linux-altera_5.1.bb new file mode 100644 index 0000000..3a4b08a --- /dev/null +++ b/recipes-kernel/linux/linux-altera_5.1.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LINUX_VERSION = "5.1" | ||
2 | |||
3 | SRCREV = "5c21be71d13b64bc4cce9b1bd8411d41d15b1a6a" | ||
4 | |||
5 | include linux-altera.inc | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
8 | |||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
10 | |||
11 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " | ||
12 | SRC_URI_append_arria5 = " file://lbdaf.scc " | ||
13 | SRC_URI_append_arria10 = " file://lbdaf.scc " | ||
diff --git a/recipes-kernel/linux/linux-altera_5.2.bb b/recipes-kernel/linux/linux-altera_5.2.bb new file mode 100644 index 0000000..254dc89 --- /dev/null +++ b/recipes-kernel/linux/linux-altera_5.2.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LINUX_VERSION = "5.2" | ||
2 | |||
3 | SRCREV = "969da0f16f5b914bd1e53e8c5051ef9df4f561f2" | ||
4 | |||
5 | include linux-altera.inc | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
8 | |||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
10 | |||
11 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " | ||
12 | SRC_URI_append_arria5 = " file://lbdaf.scc " | ||
13 | SRC_URI_append_arria10 = " file://lbdaf.scc " | ||
diff --git a/recipes-kernel/linux/linux-altera_5.3.bb b/recipes-kernel/linux/linux-altera_5.3.bb new file mode 100644 index 0000000..5adcee1 --- /dev/null +++ b/recipes-kernel/linux/linux-altera_5.3.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | LINUX_VERSION = "5.3" | ||
2 | |||
3 | SRCREV = "ac41821dcd29b0425004ac710e22ad84af94b0e1" | ||
4 | |||
5 | include linux-altera.inc | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
8 | |||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/config:" | ||
10 | |||
11 | SRC_URI_append_cyclone5 = " file://lbdaf.scc " | ||
12 | SRC_URI_append_arria5 = " file://lbdaf.scc " | ||
13 | SRC_URI_append_arria10 = " file://lbdaf.scc " | ||