diff options
-rw-r--r-- | recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb | 34 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb | 23 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb | 21 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb | 12 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb | 23 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb | 20 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2017.09.bb | 18 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2018.03.bb | 14 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2018.05.bb | 14 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2019.01.bb | 14 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb | 28 |
11 files changed, 0 insertions, 221 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb deleted file mode 100644 index 19ea6c6..0000000 --- a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | SUMMARY = "U-Boot bootloader environment image creation tool" | ||
2 | |||
3 | HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" | ||
4 | SECTION = "bootloaders" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
8 | |||
9 | PV_append = "+git${SRCPV}" | ||
10 | |||
11 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master" | ||
12 | SRC_URI += "file://0001-Fix-native-build-by-using-env-variables.patch" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | # This revision corresponds to the tag "v2016.11" | ||
17 | # We use the revision in order to avoid having to fetch it from the | ||
18 | # repo during parse | ||
19 | SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71" | ||
20 | |||
21 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' | ||
22 | |||
23 | do_compile () { | ||
24 | oe_runmake sandbox_defconfig | ||
25 | oe_runmake cross_tools NO_SDL=1 | ||
26 | } | ||
27 | |||
28 | do_install () { | ||
29 | install -d ${D}${bindir} | ||
30 | install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage | ||
31 | ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage | ||
32 | } | ||
33 | |||
34 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb deleted file mode 100644 index 449f6c3..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
2 | PR="r1" | ||
3 | |||
4 | SRCREV = "95ab599e1ad7840e08be0aa567eea3fca357572f" | ||
5 | |||
6 | UBOOT_BRANCH ?= "socfpga_${PV}" | ||
7 | UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git" | ||
8 | UBOOT_PROT ?= "https" | ||
9 | |||
10 | SRC_URI = "\ | ||
11 | ${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH} \ | ||
12 | file://fix-build-error-under-gcc6.patch \ | ||
13 | " | ||
14 | |||
15 | LICENSE = "GPLv2+" | ||
16 | LIC_FILES_CHKSUM = "file://README;md5=176c127db28f1a9e8d88f682a2a34963" | ||
17 | |||
18 | DEPENDS += "dtc-native" | ||
19 | |||
20 | UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_config" | ||
21 | |||
22 | SPL_BINARY_cyclone5 = "spl/u-boot-spl.bin" | ||
23 | SPL_BINARY_arria5 = "spl/u-boot-spl.bin" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb deleted file mode 100644 index 3b9b885..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
2 | PR="r1" | ||
3 | # This revision corresponds to the SoCEDS 16.1 release | ||
4 | SRCREV = "ab2181dd766157a74b309d12e0b61c4f3cdc8564" | ||
5 | |||
6 | UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup" | ||
7 | UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git" | ||
8 | UBOOT_PROT ?= "https" | ||
9 | |||
10 | SRC_URI = "\ | ||
11 | ${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH} \ | ||
12 | file://fix-build-error-under-gcc6.patch \ | ||
13 | " | ||
14 | |||
15 | LICENSE = "GPLv2+" | ||
16 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" | ||
17 | |||
18 | DEPENDS += "dtc-native" | ||
19 | |||
20 | UBOOT_BINARY = "u-boot-dtb.bin" | ||
21 | |||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb deleted file mode 100644 index 68a529d..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
6 | |||
7 | # This revision corresponds to the tag "v2016.05" | ||
8 | # We use the revision in order to avoid having to fetch it from the | ||
9 | # repo during parse | ||
10 | SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed" | ||
11 | PR = "r1" | ||
12 | DEPENDS += "dtc-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb deleted file mode 100644 index 1337c8a..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require u-boot-socfpga-env.inc | ||
3 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
4 | |||
5 | FILESEXTRAPATHS =. "${THISDIR}/files/v2016.11:" | ||
6 | |||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
9 | |||
10 | # This revision corresponds to the tag "v2016.11" | ||
11 | # We use the revision in order to avoid having to fetch it from the | ||
12 | # repo during parse | ||
13 | SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71" | ||
14 | |||
15 | PR = "r1" | ||
16 | |||
17 | SRC_URI_append = "\ | ||
18 | file://de0-nano-soc.env \ | ||
19 | file://cyclone5-socdk.env \ | ||
20 | " | ||
21 | |||
22 | DEPENDS += "dtc-native bc-native" | ||
23 | DEPENDS += "u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb deleted file mode 100644 index c41b468..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require u-boot-socfpga-env.inc | ||
3 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
4 | |||
5 | FILESEXTRAPATHS =. "${THISDIR}/files/v2017.07:" | ||
6 | |||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
9 | |||
10 | # This revision corresponds to the tag "v2017.07" | ||
11 | # We use the revision in order to avoid having to fetch it from the | ||
12 | # repo during parse | ||
13 | SRCREV = "d85ca029f257b53a96da6c2fb421e78a003a9943" | ||
14 | |||
15 | SRC_URI_append = "\ | ||
16 | file://de0-nano-soc.env \ | ||
17 | file://cyclone5-socdk.env \ | ||
18 | " | ||
19 | |||
20 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2017.09.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2017.09.bb deleted file mode 100644 index 389020a..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2017.09.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | FILESEXTRAPATHS =. "${THISDIR}/files/v2017.09:" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
8 | |||
9 | SRCREV = "c98ac3487e413c71e5d36322ef3324b21c6f60f9" | ||
10 | |||
11 | # Stratix10 is not mainlined yet | ||
12 | SRCREV_stratix10 = "53ce6e587a478bf613b1af42b49b5beba2dd2f3a" | ||
13 | SRC_URI_stratix10 = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2017.09;prot=https" | ||
14 | |||
15 | SRC_URI_append = "\ | ||
16 | " | ||
17 | |||
18 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2018.03.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2018.03.bb deleted file mode 100644 index 9e0d937..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2018.03.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | FILESEXTRAPATHS =. "${THISDIR}/files/v2018.03:" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
8 | |||
9 | SRCREV = "f95ab1fb6e37f0601f397091bb011edf7a98b890" | ||
10 | |||
11 | SRC_URI_append = "\ | ||
12 | " | ||
13 | |||
14 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2018.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2018.05.bb deleted file mode 100644 index b0358f1..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2018.05.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | FILESEXTRAPATHS =. "${THISDIR}/files/v2018.05:" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
8 | |||
9 | SRCREV = "890e79f2b1c26c5ba1a86d179706348aec7feef7" | ||
10 | |||
11 | SRC_URI_append = "\ | ||
12 | " | ||
13 | |||
14 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.01.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.01.bb deleted file mode 100644 index d3c80e7..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.01.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" | ||
6 | |||
7 | FILESEXTRAPATHS =. "${THISDIR}/files/v2019.01:" | ||
8 | |||
9 | SRCREV = "d3689267f92c5956e09cc7d1baa4700141662bff" | ||
10 | |||
11 | SRC_URI_append = "\ | ||
12 | " | ||
13 | |||
14 | DEPENDS += "dtc-native bc-native bison-native u-boot-mkimage-native" | ||
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb deleted file mode 100644 index 0fd1ff0..0000000 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.07.bb +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | require u-boot-socfpga-common.inc | ||
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | |||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" | ||
6 | |||
7 | FILESEXTRAPATHS =. "${THISDIR}/files/v2019.07:" | ||
8 | |||
9 | SRCREV = "e5aee22e4be75e75a854ab64503fc80598bc2004" | ||
10 | |||
11 | SRC_URI_append = "\ | ||
12 | file://0001-ARM-socfpga-stratix10-Enable-PSCI-system-reset.patch \ | ||
13 | file://0002-ARM-socfpga-stratix10-Enable-PSCI-CPU_ON.patch \ | ||
14 | file://0003-ARM-socfpga-stratix10-Enable-PSCI-support-for-Strati.patch \ | ||
15 | file://0004-ARM-socfpga-stratix10-Enable-SMC-PSCI-calls-from-sla.patch \ | ||
16 | file://0005-ARM-socfpga-stratix10-Add-SOCFPGA-bridges-reset-supp.patch \ | ||
17 | file://0006-ARM-socfpga-stratix10-Add-Stratix10-FPGA-configurati.patch \ | ||
18 | file://0007-mmc-dwmmc-Enable-small-delay-before-returning-error.patch \ | ||
19 | file://0008-ARM-socfpga-stratix10-Enable-DMA330-DMA-controller.patch \ | ||
20 | file://0009-ARM-socfpga-Stratix10-Fix-el3_exception_vectors-relo.patch \ | ||
21 | file://0010-ARM-socfpga-Stratix10-Disable-CONFIG_PSCI_RESET.patch \ | ||
22 | file://0011-Makefile-Add-target-to-generate-hex-output-for-combi.patch \ | ||
23 | file://0012-ARM-socfpga-stratix10-Remove-CONFIG_OF_EMBED.patch \ | ||
24 | file://0013-ARM-socfpga-update-CONFIG_SPL_FS_LOAD_PAYLOAD_NAME-t.patch \ | ||
25 | file://0014-fpga-arria10-Fix-error-in-fpga-pin-configuration.patch \ | ||
26 | " | ||
27 | |||
28 | DEPENDS += "dtc-native bc-native bison-native u-boot-mkimage-native" | ||