diff options
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga-common.inc | 15 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb | 6 |
4 files changed, 20 insertions, 13 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga-common.inc b/recipes-bsp/u-boot/u-boot-socfpga-common.inc index def29fa..80b4752 100644 --- a/recipes-bsp/u-boot/u-boot-socfpga-common.inc +++ b/recipes-bsp/u-boot/u-boot-socfpga-common.inc | |||
@@ -1,17 +1,30 @@ | |||
1 | HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" | 1 | HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" |
2 | SECTION = "bootloaders" | 2 | SECTION = "bootloaders" |
3 | DEPENDS += "flex-native bison-native" | 3 | DEPENDS += "flex-native bison-native dtc-native bc-native u-boot-mkimage-native" |
4 | 4 | ||
5 | LICENSE = "GPLv2+" | 5 | LICENSE = "GPLv2+" |
6 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" | 6 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" |
7 | PE = "1" | 7 | PE = "1" |
8 | 8 | ||
9 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
10 | |||
11 | UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git" | ||
12 | UBOOT_PROT ?= "https" | ||
13 | |||
14 | UBOOT_VERSION_PREFIX ?= "socfpga_" | ||
15 | UBOOT_VERSION ?= "v2019.10" | ||
16 | UBOOT_BRANCH ?= "${UBOOT_VERSION_PREFIX}${UBOOT_VERSION}" | ||
17 | |||
18 | SRCREV ?= "${AUTOREV}" | ||
9 | PV_append = "+git${SRCPV}" | 19 | PV_append = "+git${SRCPV}" |
10 | 20 | ||
11 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |
22 | B = "${WORKDIR}/build" | ||
12 | 23 | ||
13 | RPROVIDES_${PN} += "u-boot" | 24 | RPROVIDES_${PN} += "u-boot" |
14 | 25 | ||
26 | SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}" | ||
27 | |||
15 | UBOOT_CONFIG[agilex-socdk] = "socfpga_agilex_defconfig" | 28 | UBOOT_CONFIG[agilex-socdk] = "socfpga_agilex_defconfig" |
16 | UBOOT_CONFIG[agilex-socdk-qspi] = "socfpga_agilex_qspi_defconfig" | 29 | UBOOT_CONFIG[agilex-socdk-qspi] = "socfpga_agilex_qspi_defconfig" |
17 | UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig" | 30 | UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig" |
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb index 790eca1..01f3fa4 100644 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb +++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb | |||
@@ -1,7 +1,5 @@ | |||
1 | require u-boot-socfpga-common.inc | 1 | require u-boot-socfpga-common.inc |
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | 2 | ||
4 | SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.04" | 3 | UBOOT_VERSION = "v2019.04" |
5 | SRCREV = "6296fdb7da9e205bc34416f38631715fb6d74e71" | ||
6 | 4 | ||
7 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | 5 | SRCREV = "6296fdb7da9e205bc34416f38631715fb6d74e71" |
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb index a42659a..7b8af58 100644 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb +++ b/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb | |||
@@ -1,7 +1,5 @@ | |||
1 | require u-boot-socfpga-common.inc | 1 | require u-boot-socfpga-common.inc |
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | 2 | ||
4 | SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.10" | 3 | UBOOT_VERSION = "v2019.10" |
5 | SRCREV = "34638cc921269665e43340a50552302bd358f793" | ||
6 | 4 | ||
7 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | 5 | SRCREV = "34638cc921269665e43340a50552302bd358f793" |
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb index 5e3d99b..fac30e4 100644 --- a/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb | |||
@@ -1,7 +1,5 @@ | |||
1 | require u-boot-socfpga-common.inc | 1 | require u-boot-socfpga-common.inc |
2 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | ||
3 | 2 | ||
4 | SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2020.04" | 3 | UBOOT_VERSION = "v2020.04" |
5 | SRCREV = "2cbc36afbb31bee6e245291c51c283dbde0e3b89" | ||
6 | 4 | ||
7 | DEPENDS += "dtc-native bc-native u-boot-mkimage-native" | 5 | SRCREV = "2cbc36afbb31bee6e245291c51c283dbde0e3b89" |