diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-03-07 15:52:32 +0200 |
---|---|---|
committer | Risto Avila <risto.avila@theqtcompany.com> | 2016-03-08 07:29:34 +0000 |
commit | 6136e6009970859fc02477cdd37fb29a2031566f (patch) | |
tree | d9e111fe72ed1703541b48dd8a3298d5a294db03 | |
parent | 7eba608a92ee934440a5468ed81237bbae90f12a (diff) | |
download | meta-boot2qt-6136e6009970859fc02477cdd37fb29a2031566f.tar.gz |
RPi2: add support for touch display
The RPi touch display need the rpi-tf5604 devicetree to enable touch.
Add it to the kernel build and enabled it in the config.txt.
Update meta-raspberrypi to latest revision for the PiTFT support.
Change-Id: Ibc5ba51c844bc17b541d8021a755f141a5ff2a0c
Reviewed-by: Risto Avila <risto.avila@theqtcompany.com>
-rw-r--r-- | conf/bblayers.conf.rpi.sample | 1 | ||||
-rw-r--r-- | conf/distro/include/raspberrypi2.conf | 4 | ||||
-rw-r--r-- | meta-raspberrypi-extras/conf/layer.conf | 32 | ||||
-rw-r--r-- | meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend | 27 | ||||
-rw-r--r-- | scripts/manifest.xml | 2 |
5 files changed, 65 insertions, 1 deletions
diff --git a/conf/bblayers.conf.rpi.sample b/conf/bblayers.conf.rpi.sample index 6b12ac5..3be5ea3 100644 --- a/conf/bblayers.conf.rpi.sample +++ b/conf/bblayers.conf.rpi.sample | |||
@@ -37,6 +37,7 @@ BBLAYERS ?= " \ | |||
37 | ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ | 37 | ${BSPDIR}/sources/meta-openembedded/meta-initramfs \ |
38 | ${BSPDIR}/sources/meta-openembedded/meta-ruby \ | 38 | ${BSPDIR}/sources/meta-openembedded/meta-ruby \ |
39 | ${BSPDIR}/sources/meta-b2qt \ | 39 | ${BSPDIR}/sources/meta-b2qt \ |
40 | ${BSPDIR}/sources/meta-b2qt/meta-raspberrypi-extras \ | ||
40 | ${BSPDIR}/sources/meta-mingw \ | 41 | ${BSPDIR}/sources/meta-mingw \ |
41 | ${BSPDIR}/sources/meta-qt5 \ | 42 | ${BSPDIR}/sources/meta-qt5 \ |
42 | " | 43 | " |
diff --git a/conf/distro/include/raspberrypi2.conf b/conf/distro/include/raspberrypi2.conf index 7e4c057..040ea9b 100644 --- a/conf/distro/include/raspberrypi2.conf +++ b/conf/distro/include/raspberrypi2.conf | |||
@@ -46,3 +46,7 @@ module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1" | |||
46 | GPU_MEM = "256" | 46 | GPU_MEM = "256" |
47 | # video camera support | 47 | # video camera support |
48 | VIDEO_CAMERA = "1" | 48 | VIDEO_CAMERA = "1" |
49 | RPI_FT5604 = "1" | ||
50 | |||
51 | KERNEL_DEVICETREE += "overlays/rpi-ft5406-overlay.dtb" | ||
52 | MACHINE_FEATURES += "pitft" | ||
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf new file mode 100644 index 0000000..641e0f6 --- /dev/null +++ b/meta-raspberrypi-extras/conf/layer.conf | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | # We have a conf and classes directory, append to BBPATH | ||
23 | BBPATH .= ":${LAYERDIR}" | ||
24 | |||
25 | # We have a recipes directory, add to BBFILES | ||
26 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ | ||
27 | ${LAYERDIR}/recipes*/*/*.bbappend \ | ||
28 | " | ||
29 | |||
30 | BBFILE_COLLECTIONS += "b2qt_rpi" | ||
31 | BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/" | ||
32 | BBFILE_PRIORITY_b2qt_rpi = "20" | ||
diff --git a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend new file mode 100644 index 0000000..b711ab5 --- /dev/null +++ b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend | |||
@@ -0,0 +1,27 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | do_deploy_append() { | ||
23 | if [ "${RPI_FT5604}" = "1" ]; then | ||
24 | echo "# Enable rpi-ft5604 touch" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt | ||
25 | echo "dtoverlay=rpi-ft5406" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt | ||
26 | fi | ||
27 | } | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 71686c1..7299efa 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -45,7 +45,7 @@ | |||
45 | groups="notdefault,ti,bbb"/> | 45 | groups="notdefault,ti,bbb"/> |
46 | <project name="meta-raspberrypi" | 46 | <project name="meta-raspberrypi" |
47 | remote="yocto" | 47 | remote="yocto" |
48 | revision="6314f668fa14473463bb777ffaf778333fea16eb" | 48 | revision="a42a1706de91ed03ae8798c7f9e70c30cebcf7de" |
49 | path="sources/meta-raspberrypi" | 49 | path="sources/meta-raspberrypi" |
50 | groups="notdefault,rpi"/> | 50 | groups="notdefault,rpi"/> |
51 | <project name="meta-fsl-arm-extra" | 51 | <project name="meta-fsl-arm-extra" |