summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-08-07 10:00:56 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-08-08 06:45:52 +0000
commit9dbb2a6fd2c779a0bc7a73abe7dcf0918c613695 (patch)
tree35b338f7ec4a9ea6a1c9b53d1ae5d379906cc133
parent4c869b8bc3372976a29e731edb9cd2b316ad47f9 (diff)
downloadmeta-boot2qt-9dbb2a6fd2c779a0bc7a73abe7dcf0918c613695.tar.gz
qmlpreview: remove recipe
Component is now part of qtdeclarative module. Change-Id: I07ebc6a7127c72d888871851974b2a309b64a632 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb2
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb44
2 files changed, 1 insertions, 45 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index ba20618..89121a1 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -81,5 +81,5 @@ RDEPENDS_${PN} += " \
81 " 81 "
82 82
83RDEPENDS_${PN} += "\ 83RDEPENDS_${PN} += "\
84 ${@ "qtquicktimeline qmlpreview" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \ 84 ${@ "qtquicktimeline" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \
85 " 85 "
diff --git a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb b/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
deleted file mode 100644
index d22e1d0..0000000
--- a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QML Live Preview debug service"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
36
37SRCREV = "6ae4a9da17e53bbb7c1729c24f58141a33bbcb9b"
38BRANCH = "master"
39
40SRC_URI = " \
41 git://codereview.qt-project.org/qt/tqtc-qmlpreview;branch=${BRANCH};protocol=ssh \
42 "
43
44DEPENDS = "qtbase qtdeclarative"