diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-16 14:48:41 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-16 14:48:41 +0300 |
commit | fb22822ea452bd990b09d0dc96607dd88c915ee2 (patch) | |
tree | b668654ca6eaee679057bc4ea0c14c888a6f9ae7 | |
parent | 718ef6e06d732543f0d9c991683fc38793489461 (diff) | |
parent | 1bb77ba7ef3677b39d5ebdcb69ac456cdd50c0f3 (diff) | |
download | meta-boot2qt-fb22822ea452bd990b09d0dc96607dd88c915ee2.tar.gz |
Merge remote-tracking branch 'origin/morty' into pyro
* origin/morty:
meta-qt5: update to 5.9.3
apalis-imx6: modify u-boot to provide support for ixora v1.0
apalis-imx6: add support for the new capasitive touch display
toradex: update to 2.7b4 release
Conflicts:
scripts/manifest.xml
Change-Id: Iaeca481a289d0bf431d2b71e03c2b3453f227021
-rw-r--r-- | conf/bblayers.conf.toradex.sample | 1 | ||||
-rw-r--r-- | conf/distro/include/apalis-imx6.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/colibri-imx6.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/colibri-imx7.conf | 2 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch | 63 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch (renamed from meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch) | 32 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch | 37 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | 5 | ||||
-rw-r--r-- | meta-toradex-extras/conf/layer.conf | 40 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch | 31 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend | 32 | ||||
-rw-r--r-- | scripts/manifest.xml | 4 |
12 files changed, 224 insertions, 29 deletions
diff --git a/conf/bblayers.conf.toradex.sample b/conf/bblayers.conf.toradex.sample index e7cedd7..a8f4f43 100644 --- a/conf/bblayers.conf.toradex.sample +++ b/conf/bblayers.conf.toradex.sample | |||
@@ -49,6 +49,7 @@ BBLAYERS ?= " \ | |||
49 | ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ | 49 | ${BSPDIR}/sources/meta-openembedded/meta-multimedia \ |
50 | ${BSPDIR}/sources/meta-boot2qt \ | 50 | ${BSPDIR}/sources/meta-boot2qt \ |
51 | ${BSPDIR}/sources/meta-boot2qt/meta-fsl-extras \ | 51 | ${BSPDIR}/sources/meta-boot2qt/meta-fsl-extras \ |
52 | ${BSPDIR}/sources/meta-boot2qt/meta-toradex-extras \ | ||
52 | ${BSPDIR}/sources/meta-mingw \ | 53 | ${BSPDIR}/sources/meta-mingw \ |
53 | ${BSPDIR}/sources/meta-qt5 \ | 54 | ${BSPDIR}/sources/meta-qt5 \ |
54 | " | 55 | " |
diff --git a/conf/distro/include/apalis-imx6.conf b/conf/distro/include/apalis-imx6.conf index 294894d..bdb57d8 100644 --- a/conf/distro/include/apalis-imx6.conf +++ b/conf/distro/include/apalis-imx6.conf | |||
@@ -31,6 +31,8 @@ include conf/distro/include/toradex.inc | |||
31 | 31 | ||
32 | DEPLOY_CONF_NAME = "Toradex Apalis iMX6" | 32 | DEPLOY_CONF_NAME = "Toradex Apalis iMX6" |
33 | 33 | ||
34 | IMAGE_FSTYPES += "teziimg" | ||
35 | |||
34 | BOOT_SCRIPTS += " \ | 36 | BOOT_SCRIPTS += " \ |
35 | u-boot-${MACHINE}.imx-spl:${MACHINEDIR}/u-boot.imx-spl \ | 37 | u-boot-${MACHINE}.imx-spl:${MACHINEDIR}/u-boot.imx-spl \ |
36 | SPL-${MACHINE}-spl:${MACHINEDIR}/SPL \ | 38 | SPL-${MACHINE}-spl:${MACHINEDIR}/SPL \ |
@@ -39,4 +41,4 @@ BOOT_SCRIPTS += " \ | |||
39 | SERIAL_CONSOLES = "115200;ttymxc0 \ | 41 | SERIAL_CONSOLES = "115200;ttymxc0 \ |
40 | 115200;ttymxc1" | 42 | 115200;ttymxc1" |
41 | 43 | ||
42 | KERNEL_MODULE_AUTOLOAD += "fusion_F0710A" | 44 | KERNEL_MODULE_AUTOLOAD += "atmel_mxt_ts" |
diff --git a/conf/distro/include/colibri-imx6.conf b/conf/distro/include/colibri-imx6.conf index 7cccfcc..814676b 100644 --- a/conf/distro/include/colibri-imx6.conf +++ b/conf/distro/include/colibri-imx6.conf | |||
@@ -31,6 +31,8 @@ include conf/distro/include/toradex.inc | |||
31 | 31 | ||
32 | DEPLOY_CONF_NAME = "Toradex Colibri iMX6" | 32 | DEPLOY_CONF_NAME = "Toradex Colibri iMX6" |
33 | 33 | ||
34 | IMAGE_FSTYPES += "teziimg" | ||
35 | |||
34 | BOOT_SCRIPTS += " \ | 36 | BOOT_SCRIPTS += " \ |
35 | u-boot-${MACHINE}.imx-spl:${MACHINEDIR}/u-boot.imx-spl \ | 37 | u-boot-${MACHINE}.imx-spl:${MACHINEDIR}/u-boot.imx-spl \ |
36 | SPL-${MACHINE}-spl:${MACHINEDIR}/SPL \ | 38 | SPL-${MACHINE}-spl:${MACHINEDIR}/SPL \ |
diff --git a/conf/distro/include/colibri-imx7.conf b/conf/distro/include/colibri-imx7.conf index 2c3b32a..6e80e00 100644 --- a/conf/distro/include/colibri-imx7.conf +++ b/conf/distro/include/colibri-imx7.conf | |||
@@ -31,6 +31,8 @@ include conf/distro/include/toradex.inc | |||
31 | 31 | ||
32 | DEPLOY_CONF_NAME = "Toradex Colibri iMX7" | 32 | DEPLOY_CONF_NAME = "Toradex Colibri iMX7" |
33 | 33 | ||
34 | IMAGE_FSTYPES += "teziimg" | ||
35 | |||
34 | BOOT_SCRIPTS += " \ | 36 | BOOT_SCRIPTS += " \ |
35 | u-boot-nand.imx:${MACHINEDIR}/u-boot-nand.imx \ | 37 | u-boot-nand.imx:${MACHINEDIR}/u-boot-nand.imx \ |
36 | " | 38 | " |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch index bf7861e..f6dc0cc 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | From 003b18993fe1c5b1e64a44a3b831c63afb0e9a94 Mon Sep 17 00:00:00 2001 | 1 | From f86bb70bd270967082cb8132eb68c3c3dea4a7a7 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@qt.io> | 2 | From: Samuli Piippo <samuli.piippo@qt.io> |
3 | Date: Mon, 15 May 2017 15:31:36 +0300 | 3 | Date: Mon, 15 May 2017 15:31:36 +0300 |
4 | Subject: [PATCH] Make sdboot default on all boards | 4 | Subject: [PATCH 1/2] Make sdboot default on all boards |
5 | 5 | ||
6 | ... and remove console=tty1 from kernel args | ||
6 | --- | 7 | --- |
7 | include/configs/apalis_imx6.h | 3 ++- | 8 | include/configs/apalis_imx6.h | 5 +++-- |
8 | include/configs/colibri_imx6.h | 3 ++- | 9 | include/configs/colibri_imx6.h | 5 +++-- |
9 | include/configs/colibri_imx7.h | 2 +- | 10 | include/configs/colibri_imx7.h | 4 ++-- |
10 | include/configs/colibri_vf.h | 2 +- | 11 | include/configs/colibri_vf.h | 4 ++-- |
11 | 4 files changed, 6 insertions(+), 4 deletions(-) | 12 | 4 files changed, 10 insertions(+), 8 deletions(-) |
12 | 13 | ||
13 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | 14 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h |
14 | index 8dce5af..4f2f689 100644 | 15 | index 76cbdf2..9b42af9 100644 |
15 | --- a/include/configs/apalis_imx6.h | 16 | --- a/include/configs/apalis_imx6.h |
16 | +++ b/include/configs/apalis_imx6.h | 17 | +++ b/include/configs/apalis_imx6.h |
17 | @@ -256,7 +256,8 @@ | 18 | @@ -257,7 +257,8 @@ |
18 | #endif | 19 | #endif |
19 | #define CONFIG_EXTRA_ENV_SETTINGS \ | 20 | #define CONFIG_EXTRA_ENV_SETTINGS \ |
20 | BOOTENV \ | 21 | BOOTENV \ |
@@ -24,11 +25,20 @@ index 8dce5af..4f2f689 100644 | |||
24 | "run distro_bootcmd ; " \ | 25 | "run distro_bootcmd ; " \ |
25 | "usb start ;" \ | 26 | "usb start ;" \ |
26 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | 27 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ |
28 | @@ -280,7 +281,7 @@ | ||
29 | " ${loadaddr} flash_blk.img && " \ | ||
30 | "source ${loadaddr}\0" \ | ||
31 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
32 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
33 | + "consoleblank=0 no_console_suspend=1 " \ | ||
34 | "console=${console},${baudrate}n8\0 " \ | ||
35 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
36 | "setusbupdate=usb start && setenv interface usb; setenv drive 0; " \ | ||
27 | diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h | 37 | diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h |
28 | index af49bcc..f6c6e9a 100644 | 38 | index ab561f3..cbaeece 100644 |
29 | --- a/include/configs/colibri_imx6.h | 39 | --- a/include/configs/colibri_imx6.h |
30 | +++ b/include/configs/colibri_imx6.h | 40 | +++ b/include/configs/colibri_imx6.h |
31 | @@ -231,7 +231,8 @@ | 41 | @@ -232,7 +232,8 @@ |
32 | #define FDT_FILE "imx6dl-colibri-eval-v3.dtb" | 42 | #define FDT_FILE "imx6dl-colibri-eval-v3.dtb" |
33 | #define CONFIG_EXTRA_ENV_SETTINGS \ | 43 | #define CONFIG_EXTRA_ENV_SETTINGS \ |
34 | BOOTENV \ | 44 | BOOTENV \ |
@@ -38,8 +48,17 @@ index af49bcc..f6c6e9a 100644 | |||
38 | "run distro_bootcmd ; " \ | 48 | "run distro_bootcmd ; " \ |
39 | "usb start ;" \ | 49 | "usb start ;" \ |
40 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | 50 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ |
51 | @@ -253,7 +254,7 @@ | ||
52 | "${interface} ${drive}:1 ${loadaddr} flash_blk.img && " \ | ||
53 | "source ${loadaddr}\0" \ | ||
54 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | ||
55 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
56 | + "consoleblank=0 no_console_suspend=1 " \ | ||
57 | "console=${console},${baudrate}n8\0 " \ | ||
58 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
59 | "setusbupdate=usb start && setenv interface usb; setenv drive 0; " \ | ||
41 | diff --git a/include/configs/colibri_imx7.h b/include/configs/colibri_imx7.h | 60 | diff --git a/include/configs/colibri_imx7.h b/include/configs/colibri_imx7.h |
42 | index 1709032..01a8f43 100644 | 61 | index 2d6cee3..6773296 100644 |
43 | --- a/include/configs/colibri_imx7.h | 62 | --- a/include/configs/colibri_imx7.h |
44 | +++ b/include/configs/colibri_imx7.h | 63 | +++ b/include/configs/colibri_imx7.h |
45 | @@ -104,7 +104,7 @@ | 64 | @@ -104,7 +104,7 @@ |
@@ -51,8 +70,17 @@ index 1709032..01a8f43 100644 | |||
51 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" | 70 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" |
52 | 71 | ||
53 | #define BOOTENV_RUN_NET_USB_START "" | 72 | #define BOOTENV_RUN_NET_USB_START "" |
73 | @@ -138,7 +138,7 @@ | ||
74 | "fatload ${interface} 0:1 ${loadaddr} " \ | ||
75 | "${board}/flash_blk.img && source ${loadaddr}\0" \ | ||
76 | "setup=setenv setupargs " \ | ||
77 | - "console=tty1 console=${console}" \ | ||
78 | + "console=${console}" \ | ||
79 | ",${baudrate}n8 ${memargs} consoleblank=0\0" \ | ||
80 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
81 | "setusbupdate=usb start && setenv interface usb && " \ | ||
54 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h | 82 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h |
55 | index 6770f62..73a316a 100644 | 83 | index 7fea78b..5bc3e3d 100644 |
56 | --- a/include/configs/colibri_vf.h | 84 | --- a/include/configs/colibri_vf.h |
57 | +++ b/include/configs/colibri_vf.h | 85 | +++ b/include/configs/colibri_vf.h |
58 | @@ -155,7 +155,7 @@ | 86 | @@ -155,7 +155,7 @@ |
@@ -64,3 +92,12 @@ index 6770f62..73a316a 100644 | |||
64 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" | 92 | "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;" |
65 | 93 | ||
66 | #define BOOTENV_RUN_NET_USB_START "" | 94 | #define BOOTENV_RUN_NET_USB_START "" |
95 | @@ -190,7 +190,7 @@ | ||
96 | "fatload ${interface} 0:1 ${loadaddr} " \ | ||
97 | "${board}/flash_blk.img && source ${loadaddr}\0" \ | ||
98 | "setup=setenv setupargs " \ | ||
99 | - "console=tty1 console=${console}" \ | ||
100 | + "console=${console}" \ | ||
101 | ",${baudrate}n8 ${memargs} consoleblank=0 ${mtdparts}\0" \ | ||
102 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | ||
103 | "setusbupdate=usb start && setenv interface usb && " \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch index 2fcadc0..469009b 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch | |||
@@ -1,32 +1,42 @@ | |||
1 | From 5dc634b67f3b1890c5f166694ba9b81dd0a5a871 Mon Sep 17 00:00:00 2001 | 1 | From 138f477c5a1990429d35ffadc8f5cea5b1e9f945 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@qt.io> | 2 | From: Samuli Piippo <samuli.piippo@qt.io> |
3 | Date: Fri, 19 May 2017 12:41:38 +0300 | 3 | Date: Fri, 19 May 2017 12:41:38 +0300 |
4 | Subject: [PATCH] apalis-imx6: enable Fusion10 display if found during boot | 4 | Subject: [PATCH 2/2] apalis-imx6: test for Capacitive Touch Display 7" |
5 | Parallel | ||
5 | 6 | ||
6 | Test i2c bus if Fusion10 display is present during boot. | 7 | Test i2c bus if Capacitive Touch Display 7" Parallel display is present |
7 | If found, enable it as the primary display in kernel args. | 8 | during boot. If found, enable it as the primary display in kernel args. |
8 | 9 | ||
9 | Also remove console from tty1, as it overlays with Qt. | 10 | Set imx6q-apalis-ixora-v1.1.dtb as the default dtb, as it provides |
11 | support for the atmel_mxt_ts touch controller. | ||
10 | --- | 12 | --- |
11 | include/configs/apalis_imx6.h | 9 +++++++-- | 13 | include/configs/apalis_imx6.h | 9 +++++++-- |
12 | 1 file changed, 7 insertions(+), 2 deletions(-) | 14 | 1 file changed, 7 insertions(+), 2 deletions(-) |
13 | 15 | ||
14 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | 16 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h |
15 | index 4f2f689..de18b43 100644 | 17 | index 9b42af9..121eaa7 100644 |
16 | --- a/include/configs/apalis_imx6.h | 18 | --- a/include/configs/apalis_imx6.h |
17 | +++ b/include/configs/apalis_imx6.h | 19 | +++ b/include/configs/apalis_imx6.h |
18 | @@ -279,9 +279,14 @@ | 20 | @@ -250,7 +250,7 @@ |
21 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
22 | |||
23 | #ifndef CONFIG_TDX_APALIS_IMX6_V1_0 | ||
24 | -#define FDT_FILE "imx6q-apalis-eval.dtb" | ||
25 | +#define FDT_FILE "imx6q-apalis-ixora-v1.1.dtb" | ||
26 | #define FDT_FILE_V1_0 "imx6q-apalis_v1_0-eval.dtb" | ||
27 | #else | ||
28 | #define FDT_FILE "imx6q-apalis_v1_0-eval.dtb" | ||
29 | @@ -280,9 +280,14 @@ | ||
19 | "|| setenv drive 2; mmc rescan; load ${interface} ${drive}:1" \ | 30 | "|| setenv drive 2; mmc rescan; load ${interface} ${drive}:1" \ |
20 | " ${loadaddr} flash_blk.img && " \ | 31 | " ${loadaddr} flash_blk.img && " \ |
21 | "source ${loadaddr}\0" \ | 32 | "source ${loadaddr}\0" \ |
22 | - "setup=setenv setupargs fec_mac=${ethaddr} " \ | 33 | - "setup=setenv setupargs fec_mac=${ethaddr} " \ |
23 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | ||
24 | + "setup=run setupvideo; setenv setupargs fec_mac=${ethaddr} " \ | 34 | + "setup=run setupvideo; setenv setupargs fec_mac=${ethaddr} " \ |
25 | + "consoleblank=0 no_console_suspend=1 " \ | 35 | "consoleblank=0 no_console_suspend=1 " \ |
26 | "console=${console},${baudrate}n8\0 " \ | 36 | "console=${console},${baudrate}n8\0 " \ |
27 | + "setupvideo=i2c dev 0; if i2c probe 50; " \ | 37 | + "setupvideo=i2c dev 0; if i2c probe 4A; " \ |
28 | + "then setenv vidargs mxc_hdmi.only_cea=1 " \ | 38 | + "then setenv vidargs mxc_hdmi.only_cea=1 " \ |
29 | + "video=mxcfb0:dev=lcd,FusionF10A,if=RGB24 " \ | 39 | + "video=mxcfb0:dev=lcd,FusionF07A,if=RGB24 " \ |
30 | + "video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off " \ | 40 | + "video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off " \ |
31 | + "fbmem=32M; fi\0" \ | 41 | + "fbmem=32M; fi\0" \ |
32 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ | 42 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \ |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch new file mode 100644 index 0000000..1bf7c27 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 1f3926a8e90a7e582d28b845e812d0642a4dc5ce Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Thu, 12 Oct 2017 11:02:54 +0300 | ||
4 | Subject: [PATCH 3/3] apalis-imx6: Ixora v1.0 support | ||
5 | |||
6 | Add sddrive variable that can be changed to boot from different mmc card | ||
7 | slot when using different versions of ixora carrier board. | ||
8 | Default to drive 1, which is correct for Ixora v1.1. | ||
9 | --- | ||
10 | include/configs/apalis_imx6.h | 9 +++++---- | ||
11 | 1 file changed, 5 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | ||
14 | index 121eaa7..77a8874 100644 | ||
15 | --- a/include/configs/apalis_imx6.h | ||
16 | +++ b/include/configs/apalis_imx6.h | ||
17 | @@ -227,15 +227,16 @@ | ||
18 | "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
19 | |||
20 | #define SD_BOOTCMD \ | ||
21 | - "sdargs=ip=off root=/dev/mmcblk1p2 ro rootfstype=ext4 " \ | ||
22 | + "sddrive=1\0" \ | ||
23 | + "sdsetup=setenv sdargs ip=off root=/dev/mmcblk${sddrive}p2 ro rootfstype=ext4 " \ | ||
24 | "rootwait\0" \ | ||
25 | - "sdboot=run setup; " \ | ||
26 | + "sdboot=run setup; run sdsetup; " \ | ||
27 | "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \ | ||
28 | "${vidargs}; echo Booting from SD card; " \ | ||
29 | - "run sddtbload; load mmc 1:1 ${kernel_addr_r} " \ | ||
30 | + "run sddtbload; load mmc ${sddrive}:1 ${kernel_addr_r} " \ | ||
31 | "${boot_file} && run fdt_fixup && " \ | ||
32 | "bootm ${kernel_addr_r} ${dtbparam}\0" \ | ||
33 | - "sddtbload=setenv dtbparam; load mmc 1:1 ${fdt_addr_r} " \ | ||
34 | + "sddtbload=setenv dtbparam; load mmc ${sddrive}:1 ${fdt_addr_r} " \ | ||
35 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
36 | |||
37 | #define USB_BOOTCMD \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend index 39fc9cc..3d288f1 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -30,6 +30,7 @@ | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Make-sdboot-default-on-all-boards.patch \ | 32 | file://0001-Make-sdboot-default-on-all-boards.patch \ |
33 | file://0001-apalis-imx6-enable-Fusion10-display-if-found-during-.patch \ | 33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ |
34 | file://0003-apalis-imx6-Ixora-v1.0-support.patch \ | ||
34 | " | 35 | " |
35 | DEPENDS += "dtc-native" | 36 | DEPENDS += "dtc-native" |
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf new file mode 100644 index 0000000..e39649f --- /dev/null +++ b/meta-toradex-extras/conf/layer.conf | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # We have a conf and classes directory, append to BBPATH | ||
31 | BBPATH .= ":${LAYERDIR}" | ||
32 | |||
33 | # We have a recipes directory, add to BBFILES | ||
34 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ | ||
35 | ${LAYERDIR}/recipes*/*/*.bbappend \ | ||
36 | " | ||
37 | |||
38 | BBFILE_COLLECTIONS += "b2qt_toradex" | ||
39 | BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/" | ||
40 | BBFILE_PRIORITY_b2qt_toradex = "20" | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch new file mode 100644 index 0000000..1535234 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 37a2e407172b37a880d04c5a7721aeff498854ad Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Fri, 6 Oct 2017 15:54:35 +0300 | ||
4 | Subject: [PATCH] Enable atmel mxt multitouch controller for ixora v1.1 dtb | ||
5 | |||
6 | Need to disable fusion touch to get the new atmel mxt multitouch | ||
7 | controller to work. | ||
8 | --- | ||
9 | arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | ||
13 | index 354bf80d..1181502 100644 | ||
14 | --- a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | ||
15 | +++ b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | ||
16 | @@ -166,7 +166,6 @@ | ||
17 | reg = <0x4a>; | ||
18 | interrupt-parent = <&gpio6>; | ||
19 | interrupts = <10 IRQ_TYPE_EDGE_FALLING>; | ||
20 | - status = "disabled"; | ||
21 | }; | ||
22 | |||
23 | pcap@10 { | ||
24 | @@ -176,6 +175,7 @@ | ||
25 | gpios = <&gpio6 10 0 /* MXM3 11, Pen down interrupt */ | ||
26 | &gpio6 9 0 /* MXM3 13, Reset */ | ||
27 | >; | ||
28 | + status = "disabled"; | ||
29 | }; | ||
30 | |||
31 | /* M41T0M6 real time clock on carrier board */ | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend new file mode 100644 index 0000000..eadfa15 --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += "file://0001-Enable-atmel-mxt-multitouch-controller.patch" | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index f935e1a..e8e050b 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -73,12 +73,12 @@ | |||
73 | groups="notdefault,external,renesas-gen3"/> | 73 | groups="notdefault,external,renesas-gen3"/> |
74 | <project name="meta-toradex-bsp-common" | 74 | <project name="meta-toradex-bsp-common" |
75 | remote="toradex" | 75 | remote="toradex" |
76 | revision="b128af95613557af8deaea30212e89e6316eab88" | 76 | revision="429d294f9b271433d4d0130530677dc417e6ec6e" |
77 | path="sources/meta-toradex-bsp-common" | 77 | path="sources/meta-toradex-bsp-common" |
78 | groups="notdefault,external,toradex"/> | 78 | groups="notdefault,external,toradex"/> |
79 | <project name="meta-toradex-nxp" | 79 | <project name="meta-toradex-nxp" |
80 | remote="toradex" | 80 | remote="toradex" |
81 | revision="89a17628efef01fd5af202e88d79188df08f636f" | 81 | revision="45c33b79a734d016dddb997c1895b53202286f23" |
82 | path="sources/meta-toradex-nxp" | 82 | path="sources/meta-toradex-nxp" |
83 | groups="notdefault,external,toradex"/> | 83 | groups="notdefault,external,toradex"/> |
84 | 84 | ||