diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-02-17 16:59:11 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-02-18 09:06:41 +0200 |
commit | 4708304a67b074efc30dcc59e45eddf078192975 (patch) | |
tree | 803966e4a5f69c384b57b3e576cd0db707a85c56 | |
parent | 8bf3f5edf5b426146974d6af655846d671119013 (diff) | |
download | meta-boot2qt-4708304a67b074efc30dcc59e45eddf078192975.tar.gz |
Move libgl workaround to libsdl
libsdl tries to pull in mesa, so workaround was added to machines
configs to prevent that. Now remove dependency to libgl from libsdl
that was causing that.
Change-Id: I425aa45cdc32842d573354eaaab7ed67ee5bb7b5
Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r-- | conf/distro/include/am335x-evm.conf | 1 | ||||
-rw-r--r-- | conf/distro/include/beagleboard.conf | 1 | ||||
-rw-r--r-- | conf/distro/include/beaglebone.conf | 1 | ||||
-rw-r--r-- | conf/distro/include/imx53qsb.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/raspberrypi.conf | 1 | ||||
-rw-r--r-- | recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend | 2 | ||||
-rw-r--r-- | recipes/libgles/libgles-omap3_4.05.00.03.bbappend | 2 | ||||
-rw-r--r-- | recipes/libgles/libgles-omap3_4.09.00.01.bbappend | 2 | ||||
-rw-r--r-- | recipes/libgles/libgles-omap3_5.00.00.01.bbappend | 2 | ||||
-rw-r--r-- | recipes/libgles/libgles-omap3_5.01.00.01.bbappend | 2 | ||||
-rw-r--r-- | recipes/libsdl/libsdl_1.2.15.bbappend | 1 | ||||
-rw-r--r-- | recipes/userland/userland_git.bbappend | 23 |
12 files changed, 1 insertions, 39 deletions
diff --git a/conf/distro/include/am335x-evm.conf b/conf/distro/include/am335x-evm.conf index 36f28d0..5799db7 100644 --- a/conf/distro/include/am335x-evm.conf +++ b/conf/distro/include/am335x-evm.conf | |||
@@ -22,7 +22,6 @@ | |||
22 | 22 | ||
23 | IMAGE_FSTYPES = "tar.gz" | 23 | IMAGE_FSTYPES = "tar.gz" |
24 | 24 | ||
25 | PREFERRED_PROVIDER_virtual/libgl = "libgles-omap3" | ||
26 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" | 25 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" |
27 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" | 26 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" |
28 | 27 | ||
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf index a48ad21..dab0c5a 100644 --- a/conf/distro/include/beagleboard.conf +++ b/conf/distro/include/beagleboard.conf | |||
@@ -30,7 +30,6 @@ BOOT_SCRIPTS = "\ | |||
30 | SDCARD_GENERATION_COMMAND = "generate_imx_sdcard" | 30 | SDCARD_GENERATION_COMMAND = "generate_imx_sdcard" |
31 | UBOOT_SUFFIX = "img" | 31 | UBOOT_SUFFIX = "img" |
32 | 32 | ||
33 | PREFERRED_PROVIDER_virtual/libgl = "libgles-omap3" | ||
34 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" | 33 | PREFERRED_VERSION_libgles-omap3 = "4.09.00.01" |
35 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" | 34 | PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01" |
36 | 35 | ||
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf index 243532b..ba13aaa 100644 --- a/conf/distro/include/beaglebone.conf +++ b/conf/distro/include/beaglebone.conf | |||
@@ -17,7 +17,6 @@ | |||
17 | ############################################################################ | 17 | ############################################################################ |
18 | IMAGE_FSTYPES = "tar.gz" | 18 | IMAGE_FSTYPES = "tar.gz" |
19 | 19 | ||
20 | PREFERRED_PROVIDER_virtual/libgl = "libgles-omap3" | ||
21 | PREFERRED_VERSION_libgles-omap3 = "5.01.00.01" | 20 | PREFERRED_VERSION_libgles-omap3 = "5.01.00.01" |
22 | PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01" | 21 | PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01" |
23 | 22 | ||
diff --git a/conf/distro/include/imx53qsb.conf b/conf/distro/include/imx53qsb.conf index 261bc29..d83f6b4 100644 --- a/conf/distro/include/imx53qsb.conf +++ b/conf/distro/include/imx53qsb.conf | |||
@@ -22,8 +22,6 @@ | |||
22 | 22 | ||
23 | IMAGE_FSTYPES = "tar.gz" | 23 | IMAGE_FSTYPES = "tar.gz" |
24 | 24 | ||
25 | PREFERRED_PROVIDER_virtual/libgl = "amd-gpu-x11-bin-mx51" | ||
26 | |||
27 | MACHINE_EXTRA_INSTALL = "\ | 25 | MACHINE_EXTRA_INSTALL = "\ |
28 | amd-gpu-bin-mx51 \ | 26 | amd-gpu-bin-mx51 \ |
29 | " | 27 | " |
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf index 8a72f7e..97513a8 100644 --- a/conf/distro/include/raspberrypi.conf +++ b/conf/distro/include/raspberrypi.conf | |||
@@ -23,7 +23,6 @@ | |||
23 | IMAGE_FSTYPES = "tar.gz ext3 rpi-sdimg" | 23 | IMAGE_FSTYPES = "tar.gz ext3 rpi-sdimg" |
24 | 24 | ||
25 | PREFERRED_PROVIDER_virtual/libgles1 = "userland" | 25 | PREFERRED_PROVIDER_virtual/libgles1 = "userland" |
26 | PREFERRED_PROVIDER_virtual/libgl = "userland" | ||
27 | 26 | ||
28 | MACHINE_EXTRA_INSTALL = "\ | 27 | MACHINE_EXTRA_INSTALL = "\ |
29 | userland \ | 28 | userland \ |
diff --git a/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend b/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend index 9950930..40075c0 100644 --- a/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend +++ b/recipes/amd-gpu-x11-bin-mx51/amd-gpu-x11-bin-mx51_11.09.01.bbappend | |||
@@ -22,5 +22,3 @@ | |||
22 | 22 | ||
23 | # dependency to x11 only when distro features have it | 23 | # dependency to x11 only when distro features have it |
24 | DEPENDS = "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" | 24 | DEPENDS = "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" |
25 | |||
26 | PROVIDES += "virtual/libgl" | ||
diff --git a/recipes/libgles/libgles-omap3_4.05.00.03.bbappend b/recipes/libgles/libgles-omap3_4.05.00.03.bbappend index 2c689f1..73a2408 100644 --- a/recipes/libgles/libgles-omap3_4.05.00.03.bbappend +++ b/recipes/libgles/libgles-omap3_4.05.00.03.bbappend | |||
@@ -27,8 +27,6 @@ TOOLCHAIN_PATH = "${STAGING_DIR_TARGET}" | |||
27 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 27 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
28 | SRC_URI += " file://0001-Add-GLchar-typedef.patch" | 28 | SRC_URI += " file://0001-Add-GLchar-typedef.patch" |
29 | 29 | ||
30 | PROVIDES += "virtual/libgl" | ||
31 | |||
32 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | 30 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" |
33 | 31 | ||
34 | do_install_append() { | 32 | do_install_append() { |
diff --git a/recipes/libgles/libgles-omap3_4.09.00.01.bbappend b/recipes/libgles/libgles-omap3_4.09.00.01.bbappend index 8ab3608..6a37c89 100644 --- a/recipes/libgles/libgles-omap3_4.09.00.01.bbappend +++ b/recipes/libgles/libgles-omap3_4.09.00.01.bbappend | |||
@@ -22,8 +22,6 @@ | |||
22 | 22 | ||
23 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" | 23 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" |
24 | 24 | ||
25 | PROVIDES += "virtual/libgl" | ||
26 | |||
27 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | 25 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" |
28 | 26 | ||
29 | do_install_append() { | 27 | do_install_append() { |
diff --git a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend index efdfeca..5446ffa 100644 --- a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend +++ b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend | |||
@@ -25,8 +25,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" | 25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" |
26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" | 26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" |
27 | 27 | ||
28 | PROVIDES += "virtual/libgl" | ||
29 | |||
30 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | 28 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" |
31 | 29 | ||
32 | do_install_append() { | 30 | do_install_append() { |
diff --git a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend index 7edb38f..82bfdb2 100644 --- a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend +++ b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend | |||
@@ -25,8 +25,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" | 25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" |
26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" | 26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" |
27 | 27 | ||
28 | PROVIDES += "virtual/libgl" | ||
29 | |||
30 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | 28 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" |
31 | 29 | ||
32 | # Inhibit warnings about files being stripped. | 30 | # Inhibit warnings about files being stripped. |
diff --git a/recipes/libsdl/libsdl_1.2.15.bbappend b/recipes/libsdl/libsdl_1.2.15.bbappend new file mode 100644 index 0000000..36424fd --- /dev/null +++ b/recipes/libsdl/libsdl_1.2.15.bbappend | |||
@@ -0,0 +1 @@ | |||
DEPENDS_remove = "virtual/libgl" | |||
diff --git a/recipes/userland/userland_git.bbappend b/recipes/userland/userland_git.bbappend deleted file mode 100644 index c13c3a9..0000000 --- a/recipes/userland/userland_git.bbappend +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" | ||