diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-01-22 12:08:51 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-01-30 13:23:04 +0200 |
commit | 653b6af852fad5b715a11a71a5404505268a6598 (patch) | |
tree | ef4a6d34830b06d397cebbf92541ebde60afb752 | |
parent | f9d3810c97a637bea23b36c71aafcd00b01670d6 (diff) | |
download | meta-boot2qt-653b6af852fad5b715a11a71a5404505268a6598.tar.gz |
Add support for BeagleBone Black
Change-Id: I1f30b93c6e3473a00a0a851f5fceccae90ba2f1b
Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
6 files changed, 179 insertions, 0 deletions
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf new file mode 100644 index 0000000..528b41d --- /dev/null +++ b/conf/distro/include/beaglebone.conf | |||
@@ -0,0 +1,35 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc | ||
4 | ## All rights reserved. | ||
5 | ## For any questions to Digia, please use contact form at http://qt.digia.com | ||
6 | ## | ||
7 | ## This file is part of QtEnterprise Embedded. | ||
8 | ## | ||
9 | ## Licensees holding valid Qt Enterprise licenses may use this file in | ||
10 | ## accordance with the Qt Enterprise License Agreement provided with the | ||
11 | ## Software or, alternatively, in accordance with the terms contained in | ||
12 | ## a written agreement between you and Digia. | ||
13 | ## | ||
14 | ## If you have questions regarding the use of this file, please use | ||
15 | ## contact form at http://qt.digia.com | ||
16 | ## | ||
17 | ############################################################################ | ||
18 | IMAGE_FSTYPES = "tar.gz" | ||
19 | |||
20 | PREFERRED_PROVIDER_virtual/libgl = "libgles-omap3" | ||
21 | PREFERRED_VERSION_libgles-omap3 = "5.01.00.01" | ||
22 | PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01" | ||
23 | |||
24 | MACHINE_EXTRA_INSTALL = "\ | ||
25 | libgles-omap3 \ | ||
26 | libgles-omap3-rawdemos \ | ||
27 | " | ||
28 | |||
29 | MACHINE_EXTRA_INSTALL_SDK = "\ | ||
30 | libgles-omap3-dev \ | ||
31 | " | ||
32 | |||
33 | ADB_PRODUCTID = "0xD002" | ||
34 | |||
35 | DEFAULTTUNE = "armv7ahf-neon" | ||
diff --git a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend new file mode 100644 index 0000000..1398af0 --- /dev/null +++ b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend | |||
@@ -0,0 +1,48 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
24 | |||
25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" | ||
26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" | ||
27 | |||
28 | PROVIDES += "virtual/libgl" | ||
29 | |||
30 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | ||
31 | |||
32 | do_install_append() { | ||
33 | echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini | ||
34 | } | ||
35 | |||
36 | # Inhibit warnings about files being stripped. | ||
37 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
38 | |||
39 | pkg_postinst_${PN}_append() { | ||
40 | ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' ) | ||
41 | echo ${ESREV} > $D${sysconfdir}/powervr-esrev | ||
42 | } | ||
43 | |||
44 | RRECOMMENDS_${PN} = "omap3-sgx-modules" | ||
45 | RRECOMMENDS_${PN}-blitwsegl = "" | ||
46 | RRECOMMENDS_${PN}-flipwsegl = "" | ||
47 | RRECOMMENDS_${PN}-frontwsegl = "" | ||
48 | RRECOMMENDS_${PN}-linuxfbwsegl = "" | ||
diff --git a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend new file mode 100644 index 0000000..17666cb --- /dev/null +++ b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend | |||
@@ -0,0 +1,44 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
24 | |||
25 | BINLOCATION_omap3 = "${S}/gfx_rel_es5.x" | ||
26 | BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x" | ||
27 | |||
28 | PROVIDES += "virtual/libgl" | ||
29 | |||
30 | LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1" | ||
31 | |||
32 | # Inhibit warnings about files being stripped. | ||
33 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
34 | |||
35 | pkg_postinst_${PN}_append() { | ||
36 | ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' ) | ||
37 | echo ${ESREV} > $D${sysconfdir}/powervr-esrev | ||
38 | } | ||
39 | |||
40 | RRECOMMENDS_${PN} = "omap3-sgx-modules" | ||
41 | RRECOMMENDS_${PN}-blitwsegl = "" | ||
42 | RRECOMMENDS_${PN}-flipwsegl = "" | ||
43 | RRECOMMENDS_${PN}-frontwsegl = "" | ||
44 | RRECOMMENDS_${PN}-linuxfbwsegl = "" | ||
diff --git a/recipes/linux/linux-ti-staging_3.12.bbappend b/recipes/linux/linux-ti-staging_3.12.bbappend new file mode 100644 index 0000000..5bc8967 --- /dev/null +++ b/recipes/linux/linux-ti-staging_3.12.bbappend | |||
@@ -0,0 +1 @@ | |||
KERNEL_DEVICETREE_b2qt = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb" | |||
diff --git a/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch b/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch new file mode 100644 index 0000000..25dd9e4 --- /dev/null +++ b/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From bde714b9bfeafe46abc1078c09f6efac0e7b6478 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Wed, 22 Jan 2014 11:30:59 +0200 | ||
4 | Subject: [PATCH] BBB: disable console cursor blinking | ||
5 | |||
6 | --- | ||
7 | include/configs/am335x_evm.h | 2 ++ | ||
8 | 1 file changed, 2 insertions(+) | ||
9 | |||
10 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | ||
11 | index d53f17d..1b3d2a4 100644 | ||
12 | --- a/include/configs/am335x_evm.h | ||
13 | +++ b/include/configs/am335x_evm.h | ||
14 | @@ -59,6 +59,8 @@ | ||
15 | "ramrootfstype=ext2\0" \ | ||
16 | "mmcargs=setenv bootargs console=${console} " \ | ||
17 | "${optargs} " \ | ||
18 | + "consoleblank=0 " \ | ||
19 | + "vt.global_cursor_default=0 " \ | ||
20 | "root=${mmcroot} " \ | ||
21 | "rootfstype=${mmcrootfstype}\0" \ | ||
22 | "spiroot=/dev/mtdblock4 rw\0" \ | ||
23 | -- | ||
24 | 1.8.3.2 | ||
25 | |||
diff --git a/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend b/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend new file mode 100644 index 0000000..8caf0c5 --- /dev/null +++ b/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend | |||
@@ -0,0 +1,26 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
24 | SRC_URI += " \ | ||
25 | file://0001-BBB-disable-console-cursor-blinking.patch \ | ||
26 | " | ||