diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2013-12-17 09:23:44 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-01-30 12:11:38 +0200 |
commit | 706fc1ceecaaefe5e6fd80db15bb3e8a98e3561d (patch) | |
tree | 1e30c495eda1f0600943aacfa680d86b54f198f1 | |
parent | 41ca1a1f916b5af27fff5f51148c35f5510eb265 (diff) | |
download | meta-boot2qt-706fc1ceecaaefe5e6fd80db15bb3e8a98e3561d.tar.gz |
Move to yocto 1.5 dora branch
Remove recipe appends that are fixed upstream and make
changes needed for 1.5 branch.
Tested and verified with nitrogen6x.
Change-Id: I7b8ca04f2f4523fa5113bbe43767e3e90f243cd9
Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r-- | conf/distro/b2qt.conf | 5 | ||||
-rw-r--r-- | recipes/gdb/gdb-cross-canadian_7.5.1.bbappend | 35 | ||||
-rw-r--r-- | recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bbappend | 25 | ||||
-rw-r--r-- | recipes/mesa/mesa_9.1.3.bb | 139 | ||||
-rw-r--r-- | recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb | 2 | ||||
-rw-r--r-- | recipes/openssh/openssh_6.1p1.bbappend | 24 | ||||
-rw-r--r-- | recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch | 17 |
7 files changed, 13 insertions, 234 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf index 6dc189f..6dc96d2 100644 --- a/conf/distro/b2qt.conf +++ b/conf/distro/b2qt.conf | |||
@@ -24,7 +24,7 @@ include conf/distro/poky.conf | |||
24 | 24 | ||
25 | DISTRO = "b2qt" | 25 | DISTRO = "b2qt" |
26 | DISTRO_NAME = "Boot to Qt for Embedded Linux" | 26 | DISTRO_NAME = "Boot to Qt for Embedded Linux" |
27 | DISTRO_VERSION = "1.4" | 27 | DISTRO_VERSION = "1.5" |
28 | SDK_VERSION := "${DISTRO_VERSION}" | 28 | SDK_VERSION := "${DISTRO_VERSION}" |
29 | 29 | ||
30 | MAINTAINER = "B2Qt <B2Qt@digia.com>" | 30 | MAINTAINER = "B2Qt <B2Qt@digia.com>" |
@@ -38,7 +38,8 @@ include conf/distro/include/${MACHINE}.conf | |||
38 | 38 | ||
39 | SYSVINIT_ENABLED_GETTYS = "" | 39 | SYSVINIT_ENABLED_GETTYS = "" |
40 | 40 | ||
41 | DISTRO_FEATURES ?= "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs nfc ${DISTRO_FEATURES_LIBC}" | 41 | DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g nfc" |
42 | POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" | ||
42 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" | 43 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" |
43 | 44 | ||
44 | COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse" | 45 | COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse" |
diff --git a/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend b/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend deleted file mode 100644 index f96bc35..0000000 --- a/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | do_compile_prepend() { | ||
24 | cat > ${WORKDIR}/python << EOF | ||
25 | #! /bin/sh | ||
26 | case "\$2" in | ||
27 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; | ||
28 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; | ||
29 | --exec-prefix) echo "${exec_prefix}" ;; | ||
30 | *) exit 1 ;; | ||
31 | esac | ||
32 | exit 0 | ||
33 | EOF | ||
34 | chmod +x ${WORKDIR}/python | ||
35 | } | ||
diff --git a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bbappend b/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bbappend deleted file mode 100644 index ccbbf8f..0000000 --- a/recipes/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bbappend +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | PROVIDES += "virtual/libgl" | ||
24 | |||
25 | FILES_libegl-mx6-dev += "${includedir}/KHR ${includedir}/EGL" | ||
diff --git a/recipes/mesa/mesa_9.1.3.bb b/recipes/mesa/mesa_9.1.3.bb deleted file mode 100644 index 99c3a38..0000000 --- a/recipes/mesa/mesa_9.1.3.bb +++ /dev/null | |||
@@ -1,139 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | SUMMARY = "A free implementation of the OpenGL API" | ||
24 | DESCRIPTION = "Mesa is an open-source implementation of the OpenGL specification - \ | ||
25 | a system for rendering interactive 3D graphics. \ | ||
26 | A variety of device drivers allows Mesa to be used in many different environments \ | ||
27 | ranging from software emulation to complete hardware acceleration for modern GPUs. \ | ||
28 | Mesa is used as part of the overall Direct Rendering Infrastructure and X.org \ | ||
29 | environment." | ||
30 | |||
31 | HOMEPAGE = "http://mesa3d.org" | ||
32 | BUGTRACKER = "https://bugs.freedesktop.org" | ||
33 | SECTION = "x11" | ||
34 | LICENSE = "MIT" | ||
35 | LIC_FILES_CHKSUM = "file://docs/license.html;md5=42d77d95cba529a3637129be87d6555d" | ||
36 | |||
37 | INC_PR = "r9" | ||
38 | PE = "2" | ||
39 | |||
40 | export WANT_LLVM_RELEASE = "3.2" | ||
41 | |||
42 | DEPENDS = "expat makedepend-native flex-native bison-native llvm${WANT_LLVM_RELEASE}" | ||
43 | |||
44 | PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" | ||
45 | |||
46 | inherit autotools pkgconfig pythonnative | ||
47 | |||
48 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \ | ||
49 | file://EGL-Mutate-NativeDisplayType-depending-on-config.patch \ | ||
50 | file://fix-glsl-cross.patch \ | ||
51 | file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \ | ||
52 | file://0001-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch \ | ||
53 | file://0001-fix-xlib-dependency-from-pipe-loader.patch \ | ||
54 | file://glapi.patch \ | ||
55 | " | ||
56 | |||
57 | SRC_URI[md5sum] = "952ccd03547ed72333b64e1746cf8ada" | ||
58 | SRC_URI[sha256sum] = "8d5dac2202d0355bff5cfd183582ec8167d1d1227b7bb7a669acecbeaa52d766" | ||
59 | |||
60 | S = "${WORKDIR}/Mesa-${PV}" | ||
61 | |||
62 | EXTRA_OECONF = " \ | ||
63 | --enable-opengl \ | ||
64 | --enable-gles2 \ | ||
65 | --enable-egl --with-egl-platforms=fbdev \ | ||
66 | --enable-gallium --enable-gallium-llvm --enable-gallium-egl --with-llvm-shared-libs --with-gallium-drivers="swrast" \ | ||
67 | --enable-shared-glapi \ | ||
68 | --disable-glx \ | ||
69 | --enable-dri --with-dri-drivers="" \ | ||
70 | --disable-gles1 \ | ||
71 | --disable-gles3 \ | ||
72 | --disable-openvg \ | ||
73 | " | ||
74 | |||
75 | # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2) | ||
76 | FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer" | ||
77 | |||
78 | # Multiple virtual/gl providers being built breaks staging | ||
79 | EXCLUDE_FROM_WORLD = "1" | ||
80 | |||
81 | # Remove the mesa dependency on mesa-dev, as mesa is empty | ||
82 | RDEPENDS_${PN}-dev = "" | ||
83 | |||
84 | PACKAGES =+ "libegl-mesa libegl-mesa-dev \ | ||
85 | libglapi libglapi-dev \ | ||
86 | libgles2-mesa libgles2-mesa-dev \ | ||
87 | libegl-gallium \ | ||
88 | " | ||
89 | |||
90 | do_install_append () { | ||
91 | # Drivers never need libtool .la files | ||
92 | rm -f ${D}${libdir}/egl/*.la | ||
93 | rm -f ${D}${libdir}/gallium-pipe/*.la | ||
94 | } | ||
95 | |||
96 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
97 | # they don't get Debian-renamed (which would remove the -mesa suffix), and | ||
98 | # RPROVIDEs/RCONFLICTs on the generic libgl name. | ||
99 | python __anonymous() { | ||
100 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
101 | ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), | ||
102 | ("libgles3",)): | ||
103 | fullp = p[0] + "-mesa" | ||
104 | pkgs = " ".join(p) | ||
105 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
106 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
107 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
108 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
109 | |||
110 | # For -dev, the first element is both the Debian and original name | ||
111 | fullp += "-dev" | ||
112 | pkgs = p[0] + "-dev" | ||
113 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
114 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
115 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
116 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
117 | } | ||
118 | |||
119 | python mesa_populate_packages() { | ||
120 | pipe_drivers_root = os.path.join(d.getVar('libdir', True), "gallium-pipe") | ||
121 | do_split_packages(d, pipe_drivers_root, '^pipe_(.*)\.so$', 'mesa-driver-pipe-%s', 'Mesa %s pipe driver', extra_depends='') | ||
122 | } | ||
123 | |||
124 | PACKAGESPLITFUNCS_prepend = "mesa_populate_packages " | ||
125 | |||
126 | PACKAGES_DYNAMIC += "^mesa-driver-.*" | ||
127 | |||
128 | FILES_libegl-mesa = "${libdir}/libEGL.so.*" | ||
129 | FILES_libgles2-mesa = "${libdir}/libGLESv2.so.*" | ||
130 | FILES_libglapi = "${libdir}/libglapi.so.*" | ||
131 | FILES_libegl-gallium = "${libdir}/egl/egl_gallium.so* ${libdir}/egl/st_GL.so*" | ||
132 | |||
133 | FILES_libegl-mesa-dev = "${libdir}/libEGL.* ${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
134 | FILES_libglapi-dev = "${libdir}/libglapi.*" | ||
135 | FILES_libgles2-mesa-dev = "${libdir}/libGLESv2.* ${includedir}/GLES2 ${libdir}/pkgconfig/glesv2.pc" | ||
136 | |||
137 | FILES_${PN}-dbg += "${libdir}/egl/.debug/* ${libdir}/gallium-pipe/.debug" | ||
138 | |||
139 | |||
diff --git a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb index b37cad8..f9cded9 100644 --- a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb +++ b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb | |||
@@ -24,7 +24,7 @@ DESCRIPTION = "B2Qt on embedded Linux SDK toolchain" | |||
24 | PR = "r0" | 24 | PR = "r0" |
25 | LICENSE = "CLOSED" | 25 | LICENSE = "CLOSED" |
26 | 26 | ||
27 | TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${TRANSLATED_TARGET_ARCH}" | 27 | TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${MACHINE}" |
28 | TOOLCHAIN_TARGET_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-target" | 28 | TOOLCHAIN_TARGET_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-target" |
29 | 29 | ||
30 | require recipes-core/meta/meta-toolchain.bb | 30 | require recipes-core/meta/meta-toolchain.bb |
diff --git a/recipes/openssh/openssh_6.1p1.bbappend b/recipes/openssh/openssh_6.1p1.bbappend deleted file mode 100644 index 7c35cd4..0000000 --- a/recipes/openssh/openssh_6.1p1.bbappend +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | export libexecdir="/usr/libexec" | ||
24 | |||
diff --git a/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch index 3c65a20..9caee44 100644 --- a/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch +++ b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 6b894707404a1aeb3072d4b3bfc486ff9ad37ac4 Mon Sep 17 00:00:00 2001 | 1 | From d01717f74b5c8d62e93d29d03df0c49b67645d32 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@digia.com> | 2 | From: Samuli Piippo <samuli.piippo@digia.com> |
3 | Date: Tue, 9 Jul 2013 15:31:30 +0300 | 3 | Date: Mon, 16 Dec 2013 15:42:45 +0200 |
4 | Subject: [PATCH] nitrogen6x: disable console cursor blinking | 4 | Subject: [PATCH] nitrogen6x: disable console cursor blinking |
5 | 5 | ||
6 | --- | 6 | --- |
@@ -8,17 +8,18 @@ Subject: [PATCH] nitrogen6x: disable console cursor blinking | |||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | 8 | 1 file changed, 1 insertion(+), 1 deletion(-) |
9 | 9 | ||
10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript.txt b/board/boundary/nitrogen6x/6x_bootscript.txt | 10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript.txt b/board/boundary/nitrogen6x/6x_bootscript.txt |
11 | index 1d766ca..80b91ea 100644 | 11 | index 9533713..2985af2 100644 |
12 | --- a/board/boundary/nitrogen6x/6x_bootscript.txt | 12 | --- a/board/boundary/nitrogen6x/6x_bootscript.txt |
13 | +++ b/board/boundary/nitrogen6x/6x_bootscript.txt | 13 | +++ b/board/boundary/nitrogen6x/6x_bootscript.txt |
14 | @@ -53,6 +53,6 @@ done | 14 | @@ -52,7 +52,7 @@ while test "4" -ne $nextcon ; do |
15 | done | ||
15 | 16 | ||
16 | setenv bootargs $bootargs $fbmem | 17 | setenv bootargs $bootargs $fbmem |
18 | -setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait" | ||
19 | +setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 rootwait" | ||
17 | 20 | ||
18 | -setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 ; | 21 | if itest.s x$bootpart == x ; then |
19 | +setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 vt.global_cursor_default=0 ; | 22 | bootpart=1 |
20 | ${fs}load mmc ${disk}:1 10800000 uImage && bootm 10800000 ; echo "Error loading kernel image" | ||
21 | |||
22 | -- | 23 | -- |
23 | 1.7.10.4 | 24 | 1.7.10.4 |
24 | 25 | ||