diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2013-10-24 11:16:57 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2013-10-24 15:41:47 +0300 |
commit | f35bcc5ed220e748241c1e06bcd1ab6a7c99e10d (patch) | |
tree | db496e707258ecef4d6628241cf8de325bde188b | |
parent | 22caf5a9fd6cf00ff2b822c0a84f96b53f4b920f (diff) | |
download | meta-boot2qt-f35bcc5ed220e748241c1e06bcd1ab6a7c99e10d.tar.gz |
Fix sound for emulator
Build driver for AC97 and load it at boot time.
Change-Id: Ia30487a7f3bb315f83bcba48f6ea6c4b0f3f54fa
Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@digia.com>
-rw-r--r-- | conf/distro/include/emulator.conf | 6 | ||||
-rw-r--r-- | recipes/linux/linux-yocto/snd_intel8x0.cfg | 1 | ||||
-rw-r--r-- | recipes/linux/linux-yocto_3.8.bbappend | 5 |
3 files changed, 12 insertions, 0 deletions
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf index dfbda91..ab5fb76 100644 --- a/conf/distro/include/emulator.conf +++ b/conf/distro/include/emulator.conf | |||
@@ -3,6 +3,12 @@ IMAGE_ROOTFS_ALIGNMENT = "1048576" | |||
3 | ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.ext3" | 3 | ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.ext3" |
4 | IMAGE_FSTYPES = "ext3" | 4 | IMAGE_FSTYPES = "ext3" |
5 | 5 | ||
6 | MACHINE_EXTRA_RRECOMMENDS += "\ | ||
7 | kernel-module-snd-intel8x0 \ | ||
8 | " | ||
9 | |||
10 | kernel_autoload_snd-intel8x0 = "snd-intel8x0" | ||
11 | |||
6 | MACHINE_EXTRA_INSTALL = "\ | 12 | MACHINE_EXTRA_INSTALL = "\ |
7 | llvm3.2 \ | 13 | llvm3.2 \ |
8 | libegl-mesa \ | 14 | libegl-mesa \ |
diff --git a/recipes/linux/linux-yocto/snd_intel8x0.cfg b/recipes/linux/linux-yocto/snd_intel8x0.cfg new file mode 100644 index 0000000..6d78f08 --- /dev/null +++ b/recipes/linux/linux-yocto/snd_intel8x0.cfg | |||
@@ -0,0 +1 @@ | |||
CONFIG_SND_INTEL8X0=m | |||
diff --git a/recipes/linux/linux-yocto_3.8.bbappend b/recipes/linux/linux-yocto_3.8.bbappend index def23ea..51c54e4 100644 --- a/recipes/linux/linux-yocto_3.8.bbappend +++ b/recipes/linux/linux-yocto_3.8.bbappend | |||
@@ -1 +1,6 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | SRC_URI += "\ | ||
3 | file://snd_intel8x0.cfg \ | ||
4 | " | ||
5 | |||
1 | COMPATIBLE_MACHINE += "|emulator" | 6 | COMPATIBLE_MACHINE += "|emulator" |