summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-03-04 11:58:10 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-03-13 12:54:29 +0200
commit0975201e0a0e09ec878b210aa461949a3da9c32e (patch)
tree7f2ea59dcd83d6ad2c2a6a2bc26686724990558e
parent4157f4331347813136b6f4276f11ddd917903733 (diff)
downloadmeta-boot2qt-0975201e0a0e09ec878b210aa461949a3da9c32e.tar.gz
use package groups for image content
Move installed packages from image recipe to separate package group recipes Change-Id: I0417953da4bc92438b3201b38b43f6d1784f1f17 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
-rw-r--r--conf/distro/b2qt.conf1
-rw-r--r--recipes/images/b2qt-embedded-image.bb50
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb48
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb42
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb33
5 files changed, 128 insertions, 46 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index cde0b02..baaf998 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -46,3 +46,4 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio"
46COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse" 46COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse"
47COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse" 47COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
48 48
49MACHINE_EXTRA_INSTALL ?= ""
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index a9ec3bf..4b492cd 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -34,50 +34,8 @@ IMAGE_FEATURES += "\
34 34
35inherit core-image 35inherit core-image
36 36
37EXTRA_IMAGEDEPENDS_mx6 += "u-boot-script-boundary"
38
39MACHINE_EXTRA_INSTALL ?= ""
40
41GSTREAMER_EXTRA_INSTALL = "\
42 gst-meta-video \
43 gst-meta-audio \
44 gst-plugins-good \
45 gst-plugins-base-app \
46 gst-plugins-good-videofilter \
47 gst-plugins-good-id3demux \
48 gst-plugins-good-auparse \
49 gst-plugins-good-isomp4 \
50 gst-plugins-ugly-rmdemux \
51 gst-plugins-ugly-asf \
52 gst-plugins-ugly-a52dec \
53 gst-ffmpeg \
54 "
55
56TOOLS_EXTRA_INSTALL = "\
57 adbd \
58 ldd \
59 binutils \
60 binutils-symlinks \
61 "
62
63IMAGE_INSTALL += "\ 37IMAGE_INSTALL += "\
64 kernel-modules \ 38 packagegroup-b2qt-embedded-base \
65 psplash \ 39 packagegroup-b2qt-embedded-tools \
66 openssh-sftp-server \ 40 packagegroup-b2qt-embedded-gstreamer \
67 openssl \ 41 "
68 libpng \
69 jpeg \
70 tiff \
71 libxslt \
72 icu \
73 freetype \
74 fontconfig \
75 liberation-fonts \
76 tslib \
77 tslib-calibrate \
78 alsa-utils-amixer \
79 hunspell \
80 ${GSTREAMER_EXTRA_INSTALL} \
81 ${TOOLS_EXTRA_INSTALL} \
82 ${MACHINE_EXTRA_INSTALL} \
83 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..f518430
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,48 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 kernel-modules \
31 adbd \
32 psplash \
33 openssh-sftp-server \
34 openssl \
35 libpng \
36 jpeg \
37 tiff \
38 libxslt \
39 icu \
40 freetype \
41 fontconfig \
42 liberation-fonts \
43 tslib \
44 tslib-calibrate \
45 alsa-utils-amixer \
46 hunspell \
47 ${MACHINE_EXTRA_INSTALL} \
48 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
new file mode 100644
index 0000000..f6a8a54
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 gst-meta-video \
31 gst-meta-audio \
32 gst-plugins-good \
33 gst-plugins-base-app \
34 gst-plugins-good-videofilter \
35 gst-plugins-good-id3demux \
36 gst-plugins-good-auparse \
37 gst-plugins-good-isomp4 \
38 gst-plugins-ugly-rmdemux \
39 gst-plugins-ugly-asf \
40 gst-plugins-ugly-a52dec \
41 gst-ffmpeg \
42 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
new file mode 100644
index 0000000..61ca211
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Additional tools packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 ldd \
31 binutils \
32 binutils-symlinks \
33 "