summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-03-06 15:34:10 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-03-11 09:00:43 +0200
commitac8f7194f2b5896084a813d298ed486b4f479c91 (patch)
tree7bb2fbc387fb14335f95f6741ed857c4f727c501
parentee2541cf756ddada9bd008b148267e2836d42450 (diff)
downloadmeta-boot2qt-ac8f7194f2b5896084a813d298ed486b4f479c91.tar.gz
mkcard: remove recipe for mkcard
mkcard.sh script is moved to b2qt-build-scripts, so that deployment of images is not dependent on the toolchain. Task-number: QTEE-434 Change-Id: If7a93d4e8065c38a1d7205ce29d11ca8fbf8d2cf Reviewed-by: Rainer Keller <rainer.keller@digia.com>
-rwxr-xr-xrecipes/mkcard/files/mkcard.sh62
-rw-r--r--recipes/mkcard/mkcard_0.5.bb36
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
3 files changed, 0 insertions, 99 deletions
diff --git a/recipes/mkcard/files/mkcard.sh b/recipes/mkcard/files/mkcard.sh
deleted file mode 100755
index e75a176..0000000
--- a/recipes/mkcard/files/mkcard.sh
+++ /dev/null
@@ -1,62 +0,0 @@
1#! /bin/sh
2# mkcard.sh v0.5
3# (c) Copyright 2009 Graeme Gregory <dp@xora.org.uk>
4# Licensed under terms of GPLv2
5#
6# Parts of the procudure base on the work of Denys Dmytriyenko
7# http://wiki.omap.com/index.php/MMC_Boot_Format
8
9export LC_ALL=C
10
11if [ $# -ne 1 ]; then
12 echo "Usage: $0 <drive>"
13 exit 1;
14fi
15
16DRIVE=$1
17
18dd if=/dev/zero of=$DRIVE bs=1024 count=1024
19
20SIZE=`fdisk -l $DRIVE | grep Disk | grep bytes | awk '{print $5}'`
21
22echo DISK SIZE - $SIZE bytes
23
24CYLINDERS=`echo $SIZE/255/63/512 | bc`
25
26echo CYLINDERS - $CYLINDERS
27
28{
29echo ,9,0x0C,*
30echo ,,,-
31} | sfdisk -D -H 255 -S 63 -C $CYLINDERS $DRIVE
32
33sleep 1
34
35# handle various device names.
36# note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1
37# won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572
38
39PARTITION1=${DRIVE}1
40if [ ! -b ${PARTITION1} ]; then
41 PARTITION1=${DRIVE}p1
42fi
43
44PARTITION2=${DRIVE}2
45if [ ! -b ${PARTITION2} ]; then
46 PARTITION2=${DRIVE}p2
47fi
48
49# now make partitions.
50if [ -b ${PARTITION1} ]; then
51 umount ${PARTITION1}
52 mkfs.vfat -F 32 -n "boot" ${PARTITION1}
53else
54 echo "Cant find boot partition in /dev"
55fi
56
57if [ -b ${PARITION2} ]; then
58 umount ${PARTITION2}
59 mke2fs -t ext3 -j -L "rootfs" ${PARTITION2}
60else
61 echo "Cant find rootfs partition in /dev"
62fi
diff --git a/recipes/mkcard/mkcard_0.5.bb b/recipes/mkcard/mkcard_0.5.bb
deleted file mode 100644
index 8d71f81..0000000
--- a/recipes/mkcard/mkcard_0.5.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "mkcard.sh v0.5"
24LICENSE = "GPLv2+"
25LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe"
26SECTION = "devel"
27PR = "0"
28
29SRC_URI = "file://mkcard.sh"
30
31do_install () {
32 install -d ${D}${bindir}/
33 install -m 0755 ${WORKDIR}/mkcard.sh ${D}${bindir}/
34}
35
36BBCLASSEXTEND = "nativesdk"
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index f32bac4..9c92438 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -28,7 +28,6 @@ LICENSE = "CLOSED"
28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb 28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
29 29
30RDEPENDS_${PN} = "\ 30RDEPENDS_${PN} = "\
31 mkcard-nativesdk \
32 python-nativesdk \ 31 python-nativesdk \
33 python-subprocess-nativesdk \ 32 python-subprocess-nativesdk \
34 " 33 "