summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-30 10:33:25 +0300
committerAndy Nichols <andy.nichols@digia.com>2014-09-30 16:42:16 +0300
commit1f60c0ef56414970b8954e81700c356b5ad6cb7b (patch)
tree1ec825efd31c274bfbfa73f3c3694d61a6d25c3b
parent6c7560604612a4a9826c09d05fb6ea266fc4e2fc (diff)
downloadmeta-boot2qt-1f60c0ef56414970b8954e81700c356b5ad6cb7b.tar.gz
Include wayland to SDK host part only on iMX6 devices
Host part of the SDK need to be configured per device as well, otherwise wayland is build for all machines. Change-Id: If5287da32f1f09fef47826576e48060f6a9b642c Reviewed-by: Laszlo Agocs <laszlo.agocs@digia.com> Reviewed-by: Andy Nichols <andy.nichols@digia.com>
-rw-r--r--conf/distro/b2qt.conf2
-rw-r--r--conf/distro/include/imx6qsabresd.conf4
-rw-r--r--conf/distro/include/nitrogen6x.conf4
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb2
4 files changed, 11 insertions, 1 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index 679d768..d940595 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -45,6 +45,8 @@ COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudiopars
45COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse" 45COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
46 46
47MACHINE_EXTRA_INSTALL ?= "" 47MACHINE_EXTRA_INSTALL ?= ""
48MACHINE_EXTRA_INSTALL_SDK ?= ""
49MACHINE_EXTRA_INSTALL_SDK_HOST ?= ""
48 50
49LICENSE_CREATE_PACKAGE = "1" 51LICENSE_CREATE_PACKAGE = "1"
50COPY_LIC_MANIFEST = "1" 52COPY_LIC_MANIFEST = "1"
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf
index 7ee426e..4aae29e 100644
--- a/conf/distro/include/imx6qsabresd.conf
+++ b/conf/distro/include/imx6qsabresd.conf
@@ -55,4 +55,8 @@ MACHINE_EXTRA_INSTALL_SDK = " \
55 libwayland-egl-mx6-dev \ 55 libwayland-egl-mx6-dev \
56 " 56 "
57 57
58MACHINE_EXTRA_INSTALL_SDK_HOST = "\
59 wayland-nativesdk \
60 "
61
58ADB_PRODUCTID = "0x0000" 62ADB_PRODUCTID = "0x0000"
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index 65c7b14..982cf8a 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -58,4 +58,8 @@ MACHINE_EXTRA_INSTALL_SDK = " \
58 libwayland-egl-mx6-dev \ 58 libwayland-egl-mx6-dev \
59 " 59 "
60 60
61MACHINE_EXTRA_INSTALL_SDK_HOST = "\
62 wayland-nativesdk \
63 "
64
61ADB_PRODUCTID = "0x0d02" 65ADB_PRODUCTID = "0x0d02"
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index b29aa36..596fd73 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -34,7 +34,7 @@ RDEPENDS_${PN} = "\
34 python-multiprocessing-nativesdk \ 34 python-multiprocessing-nativesdk \
35 python-shell-nativesdk \ 35 python-shell-nativesdk \
36 python-threading-nativesdk \ 36 python-threading-nativesdk \
37 wayland-nativesdk \ 37 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
38 " 38 "
39 39
40 40