summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraavit <eirik.aavitsland@digia.com>2014-09-26 10:17:00 +0200
committerEirik Aavitsland <eirik.aavitsland@digia.com>2014-11-10 12:11:58 +0200
commit59f1923832b301df6743ed3fa0b92556aa68ffbd (patch)
tree4fb21fc0523696ba2a5ca96638e51afd7feeedb7
parentf309d05bccefc29977d474df734fecbe311f8f7b (diff)
downloadmeta-boot2qt-59f1923832b301df6743ed3fa0b92556aa68ffbd.tar.gz
Add Silica ArchiTech tibidabo board
Builds & runs ok! The current implementation is done with the strategy of using the vendor's defined repo versions for the yocto stack, instead of the common versions defined by b2qt. The intention is to build upon the vendor stack as closely as possible, as that is (hopefully) tested and maintained. Task-number: QTEE-801 Change-Id: Ib93b54178de870b5f288b2fae982ea2b4bb74e50 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rwxr-xr-xb2qt-init-build-env19
-rw-r--r--conf/bblayers.conf.tibidabo.sample44
-rw-r--r--conf/distro/include/tibidabo.conf50
-rw-r--r--meta-architech-extras/conf/layer.conf33
-rw-r--r--meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch17
-rw-r--r--meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend26
-rw-r--r--recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces37
-rw-r--r--recipes/wayland/wayland_1.%.bbappend (renamed from recipes/wayland/wayland_1.4.0.bbappend)0
-rw-r--r--recipes/x264/x264_git.bbappend25
-rw-r--r--scripts/manifest_tibidabo.xml31
-rwxr-xr-xscripts/setup-environment.sh3
11 files changed, 285 insertions, 0 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 1405bf4..8b7dee3 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -88,6 +88,9 @@ get_groups() {
88 imx53qsb|imx6qsabresd|nitrogen6x) 88 imx53qsb|imx6qsabresd|nitrogen6x)
89 PROJECT_GROUPS="fsl" 89 PROJECT_GROUPS="fsl"
90 ;; 90 ;;
91 tibidabo)
92 PROJECT_GROUPS="architech"
93 ;;
91 beagleboard|am335x-evm) 94 beagleboard|am335x-evm)
92 PROJECT_GROUPS="ti" 95 PROJECT_GROUPS="ti"
93 ;; 96 ;;
@@ -124,6 +127,20 @@ mirror() {
124 ${REPO} sync 127 ${REPO} sync
125} 128}
126 129
130patch_poky() {
131 cd sources/poky
132 found=$(git rev-list --grep="bitbake: cooker: add support for using % as a wildcard in bbappend filename" HEAD)
133 if [ -z "$found" ]; then
134 git cherry-pick 381d5920188398bc53b2454843054c8690bca243 > /dev/null
135 fi
136
137 found=$(git rev-list --grep="bitbake: cooker: Fix support for wildcards in bbappend filenames" HEAD)
138 if [ -z "$found" ]; then
139 git cherry-pick f91a3f46a1ee586e330be0868e8fbc4d2e78d361 > /dev/null
140 fi
141 cd -
142}
143
127init() { 144init() {
128 if [ -z "${DEVICE}" ]; then 145 if [ -z "${DEVICE}" ]; then
129 echo "device not defined" 146 echo "device not defined"
@@ -142,6 +159,8 @@ init() {
142 ${REPO} init -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g "${PROJECT_GROUPS}" ${REFERENCE} 159 ${REPO} init -u ${PWD}/.repo/repo -b default -m ${MANIFEST} -g "${PROJECT_GROUPS}" ${REFERENCE}
143 ${REPO} sync 160 ${REPO} sync
144 161
162 patch_poky
163
145 if [ ! -e "sources/meta-b2qt" ]; then 164 if [ ! -e "sources/meta-b2qt" ]; then
146 ln -s ${DIR} sources/meta-b2qt 165 ln -s ${DIR} sources/meta-b2qt
147 fi 166 fi
diff --git a/conf/bblayers.conf.tibidabo.sample b/conf/bblayers.conf.tibidabo.sample
new file mode 100644
index 0000000..9b5dd05
--- /dev/null
+++ b/conf/bblayers.conf.tibidabo.sample
@@ -0,0 +1,44 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
24# changes incompatibly
25LCONF_VERSION = "6"
26
27BBPATH = "${TOPDIR}"
28BBFILES ?= ""
29BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}"
30
31BBLAYERS ?= " \
32 ${BSPDIR}/sources/poky/meta \
33 ${BSPDIR}/sources/poky/meta-yocto \
34 ${BSPDIR}/sources/meta-fsl-arm \
35 ${BSPDIR}/sources/meta-tibidabo \
36 ${BSPDIR}/sources/meta-openembedded/meta-oe \
37 ${BSPDIR}/sources/meta-b2qt \
38 ${BSPDIR}/sources/meta-b2qt/meta-fsl-extras \
39 ${BSPDIR}/sources/meta-b2qt/meta-architech-extras \
40 "
41BBLAYERS_NON_REMOVABLE ?= " \
42 ${BSPDIR}/sources/poky/meta \
43 ${BSPDIR}/sources/poky/meta-yocto \
44 "
diff --git a/conf/distro/include/tibidabo.conf b/conf/distro/include/tibidabo.conf
new file mode 100644
index 0000000..c937f4a
--- /dev/null
+++ b/conf/distro/include/tibidabo.conf
@@ -0,0 +1,50 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23IMAGE_FSTYPES = "tar.gz"
24
25BOOTFS_CONTENT = "\
26 ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
27 bootscript:bootscript \
28 "
29BOOTFS_DEPENDS = "tibidabo-bootscript-sd:do_deploy virtual/kernel:do_deploy"
30
31MACHINE_EXTRA_INSTALL = "\
32 libgal-mx6 \
33 libegl-mx6 \
34 libgles2-mx6 \
35 gst-fsl-plugin \
36 "
37
38MACHINE_EXTRA_INSTALL_SDK = " \
39 libgal-mx6 \
40 libegl-mx6 \
41 libegl-mx6-dev \
42 libgles2-mx6 \
43 libgles2-mx6-dev \
44 "
45
46module_autoload_mxc_v4l2_capture = "mxc_v4l2_capture"
47
48ADB_PRODUCTID = "0x0000"
49
50BBMASK += "|meta-fsl-extras/recipes/u-boot|meta-fsl-extras/recipes/linux/linux-boundary"
diff --git a/meta-architech-extras/conf/layer.conf b/meta-architech-extras/conf/layer.conf
new file mode 100644
index 0000000..1cd742f
--- /dev/null
+++ b/meta-architech-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_architech"
32BBFILE_PATTERN_b2qt_architech := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_architech = "20"
diff --git a/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch
new file mode 100644
index 0000000..6df6cd6
--- /dev/null
+++ b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch
@@ -0,0 +1,17 @@
1From 020c8ffc859d03b26ae50d0b4cf008ec655e26a0 Mon Sep 17 00:00:00 2001
2From: aavit <eirik.aavitsland@theqtcompany.com>
3Date: Mon, 27 Oct 2014 12:41:32 +0100
4Subject: [PATCH] Updated kernel arguments for tibidabo
5
6
7diff --git a/recipes-bsp/bootscript/tibidabo-bootscript-sd-1.0/bootscript.source b/recipes-bsp/bootscript/tibidabo-bootscript-sd-1.0/bootscript.source
8index 1902d81..4247a08 100644
9--- a/bootscript.source
10+++ b/bootscript.source
11@@ -1,5 +1,6 @@
12 setenv bootargs ${bootargs} vmalloc=400M root=/dev/mmcblk0p2 rw,rootwait consoleblank=0 video=mxcfb0:dev=hdmi,1280x720M@60,if=RGB24 video=mxcfb1:dev=lcd,CLAA-WVGA,if=RGB666 fbmem=28M,10M
13 mmc dev 0
14+setenv bootargs ${bootargs} vt.global_cursor_default=0
15 for file_system in fat ext2; do
16 ${file_system}load mmc 0:1 ${loadaddr} /uImage && bootm ${loadaddr}
17 done
diff --git a/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend
new file mode 100644
index 0000000..d07b6a6
--- /dev/null
+++ b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-Updated-kernel-arguments-for-tibidabo.patch \
26 "
diff --git a/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces b/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces
new file mode 100644
index 0000000..cb45575
--- /dev/null
+++ b/recipes/init-ifupdown/init-ifupdown/tibidabo/interfaces
@@ -0,0 +1,37 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19iface eth1 inet dhcp
20
21auto pt0
22iface pt0 inet dhcp
23 hostname `/bin/hostname`
24auto pt1
25iface pt1 inet dhcp
26 hostname `/bin/hostname`
27
28# Ethernet/RNDIS gadget (g_ether)
29# ... or on host side, usbnet and random hwaddr
30iface usb0 inet static
31 address 192.168.7.2
32 netmask 255.255.255.0
33 network 192.168.7.0
34 gateway 192.168.7.1
35
36# Bluetooth networking
37iface bnep0 inet dhcp
diff --git a/recipes/wayland/wayland_1.4.0.bbappend b/recipes/wayland/wayland_1.%.bbappend
index 1c67f60..1c67f60 100644
--- a/recipes/wayland/wayland_1.4.0.bbappend
+++ b/recipes/wayland/wayland_1.%.bbappend
diff --git a/recipes/x264/x264_git.bbappend b/recipes/x264/x264_git.bbappend
new file mode 100644
index 0000000..ccbbbd1
--- /dev/null
+++ b/recipes/x264/x264_git.bbappend
@@ -0,0 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# Workaround: at the sha version defined by tibidabo, the x264 recipe
24# defines a nonexisting SRCREV sha.
25SRCREV_tibidabo = "ffc3ad4945da69f3caa2b40e4eed715a9a8d9526"
diff --git a/scripts/manifest_tibidabo.xml b/scripts/manifest_tibidabo.xml
new file mode 100644
index 0000000..97c18dd
--- /dev/null
+++ b/scripts/manifest_tibidabo.xml
@@ -0,0 +1,31 @@
1<?xml version="1.0" encoding="UTF-8"?>
2<manifest>
3
4 <default sync-j="4" revision="dora"/>
5
6 <remote fetch="git://git.yoctoproject.org" name="yocto"/>
7 <remote fetch="git://git.openembedded.org" name="oe"/>
8 <remote fetch="git://github.com/Freescale" name="freescale"/>
9 <remote fetch="https://github.com/architech-boards/" name="architech"/>
10
11 <project name="poky"
12 remote="yocto"
13 revision="84c2763fa0bf08a83caa2c5ee532b5bef2ff918b"
14 path="sources/poky"/>
15 <project name="meta-openembedded"
16 remote="oe"
17 revision="40e0f371f3eb1628655c484feac0cebf810737b4"
18 path="sources/meta-openembedded"/>
19
20 <project name="meta-fsl-arm"
21 remote="yocto"
22 revision="fb1681666fac9c096314cd01242be4613b7ff140"
23 path="sources/meta-fsl-arm"
24 groups="notdefault,architech"/>
25 <project name="meta-tibidabo"
26 remote="architech"
27 revision="06c6b09e0776507e1230aa98b5ca10d9d3968286"
28 path="sources/meta-tibidabo"
29 groups="notdefault,architech"/>
30
31</manifest>
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index cc15776..16815a8 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -55,6 +55,9 @@ if [ ! -f ${PWD}/${BUILDDIR}/conf/bblayers.conf ]; then
55 imx53qsb|imx6qsabresd|nitrogen6x) 55 imx53qsb|imx6qsabresd|nitrogen6x)
56 LAYERSCONF="bblayers.conf.fsl.sample" 56 LAYERSCONF="bblayers.conf.fsl.sample"
57 ;; 57 ;;
58 tibidabo)
59 LAYERSCONF="bblayers.conf.tibidabo.sample"
60 ;;
58 beagleboard|am335x-evm) 61 beagleboard|am335x-evm)
59 LAYERSCONF="bblayers.conf.ti.sample" 62 LAYERSCONF="bblayers.conf.ti.sample"
60 ;; 63 ;;