diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-10-13 16:18:20 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-10-17 09:54:04 +0300 |
commit | 938e7b50ca198ffb05d8fcb393d5c42f3a1bb3f7 (patch) | |
tree | d583094f6e4902d1251c62f3666fe9be19745278 | |
parent | b8caaf7e86f2417d2abbeb30c71ce4bb1f11883c (diff) | |
download | meta-boot2qt-938e7b50ca198ffb05d8fcb393d5c42f3a1bb3f7.tar.gz |
Add camera support for RPi and SABRE
Include necessary gstreamer plugins to enable camera usage in Qt.
Camera is enabled in RPi boot configuration, and needed kernel modules
are loaded during boot on in RPi and SABRE.
Change-Id: Iaeb17933b7d7dabb30db638db6594ab6aada05a0
Reviewed-by: Yoann Lopes <yoann.lopes@theqtcompany.com>
Reviewed-by: Gatis Paeglis <gatis.paeglis@digia.com>
-rw-r--r-- | conf/distro/include/imx6qsabresd.conf | 4 | ||||
-rw-r--r-- | conf/distro/include/raspberrypi.conf | 4 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb | 8 |
3 files changed, 15 insertions, 1 deletions
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf index 4aae29e..2faf285 100644 --- a/conf/distro/include/imx6qsabresd.conf +++ b/conf/distro/include/imx6qsabresd.conf | |||
@@ -29,7 +29,7 @@ BOOTFS_CONTENT = "\ | |||
29 | ${KERNEL_IMAGETYPE}-imx6q-sabresd-ldo.dtb:imx6q-sabresd-ldo.dtb \ | 29 | ${KERNEL_IMAGETYPE}-imx6q-sabresd-ldo.dtb:imx6q-sabresd-ldo.dtb \ |
30 | u-boot-${MACHINE}.imx:u-boot.imx \ | 30 | u-boot-${MACHINE}.imx:u-boot.imx \ |
31 | " | 31 | " |
32 | BOOTFS_DEPENDS = "u-boot:do_deploy" | 32 | BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" |
33 | 33 | ||
34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" | 34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" |
35 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" | 35 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" |
@@ -59,4 +59,6 @@ MACHINE_EXTRA_INSTALL_SDK_HOST = "\ | |||
59 | wayland-nativesdk \ | 59 | wayland-nativesdk \ |
60 | " | 60 | " |
61 | 61 | ||
62 | module_autoload_mxc_v4l2_capture = "mxc_v4l2_capture" | ||
63 | |||
62 | ADB_PRODUCTID = "0x0000" | 64 | ADB_PRODUCTID = "0x0000" |
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf index 61cebb4..d0a400e 100644 --- a/conf/distro/include/raspberrypi.conf +++ b/conf/distro/include/raspberrypi.conf | |||
@@ -39,6 +39,10 @@ MACHINE_EXTRA_INSTALL_SDK = " \ | |||
39 | " | 39 | " |
40 | 40 | ||
41 | module_autoload_snd-bcm2835 = "snd-bcm2835" | 41 | module_autoload_snd-bcm2835 = "snd-bcm2835" |
42 | module_autoload_bcm2835-v4l2 = "bcm2835-v4l2" | ||
43 | module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1" | ||
42 | 44 | ||
43 | # additional memory for GPU | 45 | # additional memory for GPU |
44 | GPU_MEM = "128" | 46 | GPU_MEM = "128" |
47 | # video camera support | ||
48 | VIDEO_CAMERA = "1" | ||
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb index 6cfb53d..fdfca05 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb | |||
@@ -31,15 +31,23 @@ RDEPENDS_${PN} = "\ | |||
31 | gst-meta-audio \ | 31 | gst-meta-audio \ |
32 | gst-plugins-good \ | 32 | gst-plugins-good \ |
33 | gst-plugins-base-app \ | 33 | gst-plugins-base-app \ |
34 | gst-plugins-base-audiorate \ | ||
35 | gst-plugins-base-videorate \ | ||
36 | gst-plugins-base-encodebin \ | ||
34 | gst-plugins-good-videofilter \ | 37 | gst-plugins-good-videofilter \ |
35 | gst-plugins-good-id3demux \ | 38 | gst-plugins-good-id3demux \ |
36 | gst-plugins-good-auparse \ | 39 | gst-plugins-good-auparse \ |
37 | gst-plugins-good-isomp4 \ | 40 | gst-plugins-good-isomp4 \ |
38 | gst-plugins-good-icydemux \ | 41 | gst-plugins-good-icydemux \ |
42 | gst-plugins-good-video4linux2 \ | ||
43 | gst-plugins-good-multifile \ | ||
44 | gst-plugins-good-videocrop \ | ||
39 | gst-plugins-ugly-rmdemux \ | 45 | gst-plugins-ugly-rmdemux \ |
40 | gst-plugins-ugly-asf \ | 46 | gst-plugins-ugly-asf \ |
41 | gst-plugins-ugly-a52dec \ | 47 | gst-plugins-ugly-a52dec \ |
42 | gst-plugins-bad-mpegdemux \ | 48 | gst-plugins-bad-mpegdemux \ |
43 | gst-plugins-bad-faad \ | 49 | gst-plugins-bad-faad \ |
50 | gst-plugins-bad-camerabin2 \ | ||
51 | gst-plugins-bad-jpegformat \ | ||
44 | gst-ffmpeg \ | 52 | gst-ffmpeg \ |
45 | " | 53 | " |