diff options
author | Laszlo Agocs <laszlo.agocs@digia.com> | 2014-09-24 10:50:59 +0200 |
---|---|---|
committer | Laszlo Agocs <laszlo.agocs@digia.com> | 2014-09-26 11:32:21 +0300 |
commit | d5bdc310ef22ebbe336d5b0f8cbd12aeff94be9b (patch) | |
tree | 0cc71ff2d66151ac1b7f20214d080fe31fced61d | |
parent | 8962af850b3317680b88f0d8fa10df5787747e27 (diff) | |
download | meta-boot2qt-d5bdc310ef22ebbe336d5b0f8cbd12aeff94be9b.tar.gz |
Add Wayland and Weston into the iMX6 images
weston-examples may get removed later on, for now they are necessary
for testing and development.
Change-Id: I0bbb1d9d66045d8844f07d8e0bca9d7fc19251c3
Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
6 files changed, 74 insertions, 2 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf index 8819c93..679d768 100644 --- a/conf/distro/b2qt.conf +++ b/conf/distro/b2qt.conf | |||
@@ -35,8 +35,6 @@ SANITY_TESTED_DISTROS += " \ | |||
35 | LinuxMint-16 \n \ | 35 | LinuxMint-16 \n \ |
36 | " | 36 | " |
37 | 37 | ||
38 | include conf/distro/include/${MACHINE}.conf | ||
39 | |||
40 | SYSVINIT_ENABLED_GETTYS = "" | 38 | SYSVINIT_ENABLED_GETTYS = "" |
41 | 39 | ||
42 | DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs" | 40 | DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost wifi xattr nfs" |
@@ -50,3 +48,5 @@ MACHINE_EXTRA_INSTALL ?= "" | |||
50 | 48 | ||
51 | LICENSE_CREATE_PACKAGE = "1" | 49 | LICENSE_CREATE_PACKAGE = "1" |
52 | COPY_LIC_MANIFEST = "1" | 50 | COPY_LIC_MANIFEST = "1" |
51 | |||
52 | include conf/distro/include/${MACHINE}.conf | ||
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf index 5a19c07..7ee426e 100644 --- a/conf/distro/include/imx6qsabresd.conf +++ b/conf/distro/include/imx6qsabresd.conf | |||
@@ -34,11 +34,16 @@ BOOTFS_DEPENDS = "u-boot:do_deploy" | |||
34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" | 34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" |
35 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" | 35 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" |
36 | 36 | ||
37 | DISTRO_FEATURES_DEFAULT += "wayland" | ||
38 | |||
37 | MACHINE_EXTRA_INSTALL = "\ | 39 | MACHINE_EXTRA_INSTALL = "\ |
38 | libgal-mx6 \ | 40 | libgal-mx6 \ |
39 | libegl-mx6 \ | 41 | libegl-mx6 \ |
40 | libgles2-mx6 \ | 42 | libgles2-mx6 \ |
41 | gst-fsl-plugin \ | 43 | gst-fsl-plugin \ |
44 | wayland \ | ||
45 | weston \ | ||
46 | weston-examples \ | ||
42 | " | 47 | " |
43 | 48 | ||
44 | MACHINE_EXTRA_INSTALL_SDK = " \ | 49 | MACHINE_EXTRA_INSTALL_SDK = " \ |
@@ -47,6 +52,7 @@ MACHINE_EXTRA_INSTALL_SDK = " \ | |||
47 | libegl-mx6-dev \ | 52 | libegl-mx6-dev \ |
48 | libgles2-mx6 \ | 53 | libgles2-mx6 \ |
49 | libgles2-mx6-dev \ | 54 | libgles2-mx6-dev \ |
55 | libwayland-egl-mx6-dev \ | ||
50 | " | 56 | " |
51 | 57 | ||
52 | ADB_PRODUCTID = "0x0000" | 58 | ADB_PRODUCTID = "0x0000" |
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index 0907f93..65c7b14 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -37,11 +37,16 @@ EXTRA_IMAGEDEPENDS += "u-boot-script-boundary" | |||
37 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" | 37 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.1-hfp" |
38 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" | 38 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" |
39 | 39 | ||
40 | DISTRO_FEATURES_DEFAULT += "wayland" | ||
41 | |||
40 | MACHINE_EXTRA_INSTALL = "\ | 42 | MACHINE_EXTRA_INSTALL = "\ |
41 | libgal-mx6 \ | 43 | libgal-mx6 \ |
42 | libegl-mx6 \ | 44 | libegl-mx6 \ |
43 | libgles2-mx6 \ | 45 | libgles2-mx6 \ |
44 | gst-fsl-plugin \ | 46 | gst-fsl-plugin \ |
47 | wayland \ | ||
48 | weston \ | ||
49 | weston-examples \ | ||
45 | " | 50 | " |
46 | 51 | ||
47 | MACHINE_EXTRA_INSTALL_SDK = " \ | 52 | MACHINE_EXTRA_INSTALL_SDK = " \ |
@@ -50,6 +55,7 @@ MACHINE_EXTRA_INSTALL_SDK = " \ | |||
50 | libegl-mx6-dev \ | 55 | libegl-mx6-dev \ |
51 | libgles2-mx6 \ | 56 | libgles2-mx6 \ |
52 | libgles2-mx6-dev \ | 57 | libgles2-mx6-dev \ |
58 | libwayland-egl-mx6-dev \ | ||
53 | " | 59 | " |
54 | 60 | ||
55 | ADB_PRODUCTID = "0x0d02" | 61 | ADB_PRODUCTID = "0x0d02" |
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb index 281204c..b29aa36 100644 --- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb +++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb | |||
@@ -34,6 +34,7 @@ RDEPENDS_${PN} = "\ | |||
34 | python-multiprocessing-nativesdk \ | 34 | python-multiprocessing-nativesdk \ |
35 | python-shell-nativesdk \ | 35 | python-shell-nativesdk \ |
36 | python-threading-nativesdk \ | 36 | python-threading-nativesdk \ |
37 | wayland-nativesdk \ | ||
37 | " | 38 | " |
38 | 39 | ||
39 | 40 | ||
diff --git a/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch b/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch new file mode 100644 index 0000000..2a691a1 --- /dev/null +++ b/recipes/wayland/wayland/0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From a9ab89496d32ab42d9f697c43cf8bb04feaeabfa Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@digia.com> | ||
3 | Date: Fri, 26 Sep 2014 10:39:51 +0300 | ||
4 | Subject: [PATCH] Use native wayland-scanner when building nativesdk-wayland | ||
5 | |||
6 | The wayland-scanner built for the nativesdk cannot be run during the build, | ||
7 | so instead use the wayland-scanner from native build. | ||
8 | --- | ||
9 | src/Makefile.am | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
13 | index b938d17..84fcdf6 100644 | ||
14 | --- a/src/Makefile.am | ||
15 | +++ b/src/Makefile.am | ||
16 | @@ -41,7 +41,7 @@ AM_CFLAGS = $(GCC_CFLAGS) -pthread | ||
17 | protocoldir = $(top_srcdir)/protocol | ||
18 | |||
19 | if ENABLE_SCANNER | ||
20 | -wayland_scanner = $(top_builddir)/src/wayland-scanner | ||
21 | +wayland_scanner = wayland-scanner | ||
22 | else | ||
23 | wayland_scanner = wayland-scanner | ||
24 | endif | ||
25 | -- | ||
26 | 1.8.3.2 | ||
27 | |||
diff --git a/recipes/wayland/wayland_1.4.0.bbappend b/recipes/wayland/wayland_1.4.0.bbappend new file mode 100644 index 0000000..ed064bc --- /dev/null +++ b/recipes/wayland/wayland_1.4.0.bbappend | |||
@@ -0,0 +1,32 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
24 | SRC_URI_append_class-nativesdk = " file://just-scanner.patch \ | ||
25 | file://disable-macro-checks-not-used-for-scanner.patch \ | ||
26 | file://0001-Use-native-wayland-scanner-when-building-nativesdk-w.patch \ | ||
27 | " | ||
28 | |||
29 | EXTRA_OECONF_class-nativesdk = "--disable-documentation --enable-scanner" | ||
30 | DEPENDS_class-nativesdk = "wayland-native" | ||
31 | |||
32 | BBCLASSEXTEND = "native nativesdk" | ||