diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-03-31 10:15:32 +0300 |
---|---|---|
committer | Eirik Aavitsland <eirik.aavitsland@theqtcompany.com> | 2015-06-19 11:07:23 +0300 |
commit | 43c3f03b7e9e1daf7ba408c704062a16c632a7da (patch) | |
tree | 57dbbe0502e712d09929513eb6b35b840f535078 | |
parent | 6bff46162db6cc701efa7fe8255fea81076b6b03 (diff) | |
download | meta-boot2qt-43c3f03b7e9e1daf7ba408c704062a16c632a7da.tar.gz |
gstreamer: make gstreamer version a DISTRO_FEATURE
GStreamer version can now be changed using a DISTRO_FEATURE:
'gstreamer010' for GStreamer 0.10 and 'gstreamer' for GStreamer 1.0
This can also be used to remove all gstreamer packages from image
and toolchain.
Default version is still the old 0.10
Change-Id: I54b19962ccd0dfd2f71bb44e231bf5af43ccfab9
Reviewed-by: Eirik Aavitsland <eirik.aavitsland@theqtcompany.com>
-rw-r--r-- | conf/distro/b2qt.conf | 6 | ||||
-rw-r--r-- | conf/distro/include/apalis-imx6.conf | 3 | ||||
-rw-r--r-- | conf/distro/include/colibri-imx6.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/imx6qsabresd.conf | 3 | ||||
-rw-r--r-- | conf/distro/include/nitrogen6x.conf | 3 | ||||
-rw-r--r-- | conf/distro/include/tibidabo.conf | 3 | ||||
-rw-r--r-- | recipes-qt/images/b2qt-embedded-qt5-image.bb | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtmultimedia_%.bbappend | 2 | ||||
-rw-r--r-- | recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend | 1 | ||||
-rw-r--r-- | recipes/images/b2qt-embedded-image.bb | 3 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb | 32 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer010.bb | 59 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb | 4 |
14 files changed, 89 insertions, 36 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf index 1cfcac2..ac635d8 100644 --- a/conf/distro/b2qt.conf +++ b/conf/distro/b2qt.conf | |||
@@ -42,12 +42,12 @@ DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost | |||
42 | POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" | 42 | POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" |
43 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" | 43 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio" |
44 | 44 | ||
45 | # use GStreamer 0.10, optionally change to "gstreamer" to use GStreamer 1.0 | ||
46 | DISTRO_FEATURES += "gstreamer010" | ||
47 | |||
45 | PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo" | 48 | PREFERRED_PROVIDER_jpeg ?= "libjpeg-turbo" |
46 | PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native" | 49 | PREFERRED_PROVIDER_jpeg-native ?= "libjpeg-turbo-native" |
47 | 50 | ||
48 | COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse" | ||
49 | COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse" | ||
50 | |||
51 | MACHINE_EXTRA_INSTALL ?= "" | 51 | MACHINE_EXTRA_INSTALL ?= "" |
52 | MACHINE_EXTRA_INSTALL_SDK ?= "" | 52 | MACHINE_EXTRA_INSTALL_SDK ?= "" |
53 | MACHINE_EXTRA_INSTALL_SDK_HOST ?= "" | 53 | MACHINE_EXTRA_INSTALL_SDK_HOST ?= "" |
diff --git a/conf/distro/include/apalis-imx6.conf b/conf/distro/include/apalis-imx6.conf index c1e9c1b..2ceb4fe 100644 --- a/conf/distro/include/apalis-imx6.conf +++ b/conf/distro/include/apalis-imx6.conf | |||
@@ -39,7 +39,8 @@ MACHINE_EXTRA_INSTALL = "\ | |||
39 | libgal-mx6 \ | 39 | libgal-mx6 \ |
40 | libegl-mx6 \ | 40 | libegl-mx6 \ |
41 | libgles2-mx6 \ | 41 | libgles2-mx6 \ |
42 | gst-fsl-plugin \ | 42 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gst-fsl-plugin", "", d)} \ |
43 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | ||
43 | " | 44 | " |
44 | 45 | ||
45 | MACHINE_EXTRA_INSTALL_SDK = " \ | 46 | MACHINE_EXTRA_INSTALL_SDK = " \ |
diff --git a/conf/distro/include/colibri-imx6.conf b/conf/distro/include/colibri-imx6.conf index 8a048b1..f0b6179 100644 --- a/conf/distro/include/colibri-imx6.conf +++ b/conf/distro/include/colibri-imx6.conf | |||
@@ -37,6 +37,8 @@ MACHINE_EXTRA_INSTALL = "\ | |||
37 | libegl-mx6 \ | 37 | libegl-mx6 \ |
38 | libgles2-mx6 \ | 38 | libgles2-mx6 \ |
39 | gst-fsl-plugin \ | 39 | gst-fsl-plugin \ |
40 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gst-fsl-plugin", "", d)} \ | ||
41 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | ||
40 | " | 42 | " |
41 | 43 | ||
42 | MACHINE_EXTRA_INSTALL_SDK = " \ | 44 | MACHINE_EXTRA_INSTALL_SDK = " \ |
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf index 74b22d3..c677500 100644 --- a/conf/distro/include/imx6qsabresd.conf +++ b/conf/distro/include/imx6qsabresd.conf | |||
@@ -40,7 +40,8 @@ MACHINE_EXTRA_INSTALL = "\ | |||
40 | libgal-mx6 \ | 40 | libgal-mx6 \ |
41 | libegl-mx6 \ | 41 | libegl-mx6 \ |
42 | libgles2-mx6 \ | 42 | libgles2-mx6 \ |
43 | gst-fsl-plugin \ | 43 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gst-fsl-plugin", "", d)} \ |
44 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | ||
44 | libopencv-core \ | 45 | libopencv-core \ |
45 | libopencv-imgproc \ | 46 | libopencv-imgproc \ |
46 | libopencv-objdetect \ | 47 | libopencv-objdetect \ |
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index d9a11ab..819960d 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -54,7 +54,8 @@ MACHINE_EXTRA_INSTALL = "\ | |||
54 | libgal-mx6 \ | 54 | libgal-mx6 \ |
55 | libegl-mx6 \ | 55 | libegl-mx6 \ |
56 | libgles2-mx6 \ | 56 | libgles2-mx6 \ |
57 | gst-fsl-plugin \ | 57 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gst-fsl-plugin", "", d)} \ |
58 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | ||
58 | bcm4330-nvram-config \ | 59 | bcm4330-nvram-config \ |
59 | libopencv-core \ | 60 | libopencv-core \ |
60 | libopencv-imgproc \ | 61 | libopencv-imgproc \ |
diff --git a/conf/distro/include/tibidabo.conf b/conf/distro/include/tibidabo.conf index cb8e019..cec9fd5 100644 --- a/conf/distro/include/tibidabo.conf +++ b/conf/distro/include/tibidabo.conf | |||
@@ -34,7 +34,8 @@ MACHINE_EXTRA_INSTALL = "\ | |||
34 | libgal-mx6 \ | 34 | libgal-mx6 \ |
35 | libegl-mx6 \ | 35 | libegl-mx6 \ |
36 | libgles2-mx6 \ | 36 | libgles2-mx6 \ |
37 | gst-fsl-plugin \ | 37 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gst-fsl-plugin", "", d)} \ |
38 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-plugins-imx-meta", "", d)} \ | ||
38 | " | 39 | " |
39 | 40 | ||
40 | MACHINE_EXTRA_INSTALL_SDK = " \ | 41 | MACHINE_EXTRA_INSTALL_SDK = " \ |
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb index daaa6e4..924ba61 100644 --- a/recipes-qt/images/b2qt-embedded-qt5-image.bb +++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb | |||
@@ -42,7 +42,8 @@ IMAGE_INSTALL += "\ | |||
42 | ${MACHINE_EXTRA_INSTALL_QT} \ | 42 | ${MACHINE_EXTRA_INSTALL_QT} \ |
43 | packagegroup-b2qt-embedded-base \ | 43 | packagegroup-b2qt-embedded-base \ |
44 | packagegroup-b2qt-embedded-tools \ | 44 | packagegroup-b2qt-embedded-tools \ |
45 | packagegroup-b2qt-embedded-gstreamer \ | 45 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ |
46 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \ | ||
46 | packagegroup-b2qt-embedded-qt5 \ | 47 | packagegroup-b2qt-embedded-qt5 \ |
47 | packagegroup-b2qt-embedded-qt5-addons \ | 48 | packagegroup-b2qt-embedded-qt5-addons \ |
48 | " | 49 | " |
diff --git a/recipes-qt/qt5/qtmultimedia_%.bbappend b/recipes-qt/qt5/qtmultimedia_%.bbappend index cb1dc53..0c2560a 100644 --- a/recipes-qt/qt5/qtmultimedia_%.bbappend +++ b/recipes-qt/qt5/qtmultimedia_%.bbappend | |||
@@ -20,4 +20,4 @@ | |||
20 | ## | 20 | ## |
21 | ############################################################################# | 21 | ############################################################################# |
22 | 22 | ||
23 | PACKAGECONFIG += "gstreamer010" | 23 | PACKAGECONFIG += "${@base_contains("DISTRO_FEATURES", "gstreamer010", "gstreamer010", "gstreamer", d)}" |
diff --git a/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend new file mode 100644 index 0000000..1c5cc7c --- /dev/null +++ b/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | |||
@@ -0,0 +1 @@ | |||
PACKAGECONFIG_append = " faad" | |||
diff --git a/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend b/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend new file mode 100644 index 0000000..eee313b --- /dev/null +++ b/recipes/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend | |||
@@ -0,0 +1 @@ | |||
PACKAGECONFIG_append = " x264" | |||
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb index 9b452c6..d8e55ef 100644 --- a/recipes/images/b2qt-embedded-image.bb +++ b/recipes/images/b2qt-embedded-image.bb | |||
@@ -38,5 +38,6 @@ inherit bootfs-image | |||
38 | IMAGE_INSTALL += "\ | 38 | IMAGE_INSTALL += "\ |
39 | packagegroup-b2qt-embedded-base \ | 39 | packagegroup-b2qt-embedded-base \ |
40 | packagegroup-b2qt-embedded-tools \ | 40 | packagegroup-b2qt-embedded-tools \ |
41 | packagegroup-b2qt-embedded-gstreamer \ | 41 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ |
42 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \ | ||
42 | " | 43 | " |
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb index f9892dc..b76304e 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb | |||
@@ -27,28 +27,12 @@ PR = "r0" | |||
27 | inherit packagegroup | 27 | inherit packagegroup |
28 | 28 | ||
29 | RDEPENDS_${PN} = "\ | 29 | RDEPENDS_${PN} = "\ |
30 | gst-meta-video \ | 30 | gstreamer1.0-meta-base \ |
31 | gst-meta-audio \ | 31 | gstreamer1.0-meta-video \ |
32 | gst-plugins-good \ | 32 | gstreamer1.0-meta-audio \ |
33 | gst-plugins-base-app \ | 33 | gstreamer1.0-plugins-base-meta \ |
34 | gst-plugins-base-audiorate \ | 34 | gstreamer1.0-plugins-good-meta \ |
35 | gst-plugins-base-videorate \ | 35 | gstreamer1.0-plugins-ugly-meta \ |
36 | gst-plugins-base-encodebin \ | 36 | gstreamer1.0-plugins-bad-meta \ |
37 | gst-plugins-good-videofilter \ | 37 | gstreamer1.0-libav \ |
38 | gst-plugins-good-id3demux \ | ||
39 | gst-plugins-good-auparse \ | ||
40 | gst-plugins-good-isomp4 \ | ||
41 | gst-plugins-good-icydemux \ | ||
42 | gst-plugins-good-video4linux2 \ | ||
43 | gst-plugins-good-multifile \ | ||
44 | gst-plugins-good-videocrop \ | ||
45 | gst-plugins-good-jpeg \ | ||
46 | gst-plugins-ugly-rmdemux \ | ||
47 | gst-plugins-ugly-asf \ | ||
48 | gst-plugins-ugly-a52dec \ | ||
49 | gst-plugins-bad-mpegdemux \ | ||
50 | gst-plugins-bad-faad \ | ||
51 | gst-plugins-bad-camerabin2 \ | ||
52 | gst-plugins-bad-jpegformat \ | ||
53 | gst-ffmpeg \ | ||
54 | " | 38 | " |
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer010.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer010.bb new file mode 100644 index 0000000..5567303 --- /dev/null +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer010.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image" | ||
24 | LICENSE = "CLOSED" | ||
25 | PR = "r0" | ||
26 | |||
27 | inherit packagegroup | ||
28 | |||
29 | RDEPENDS_${PN} = "\ | ||
30 | gst-meta-video \ | ||
31 | gst-meta-audio \ | ||
32 | gst-plugins-good \ | ||
33 | gst-plugins-base-app \ | ||
34 | gst-plugins-base-audiorate \ | ||
35 | gst-plugins-base-videorate \ | ||
36 | gst-plugins-base-encodebin \ | ||
37 | gst-plugins-good-videofilter \ | ||
38 | gst-plugins-good-id3demux \ | ||
39 | gst-plugins-good-auparse \ | ||
40 | gst-plugins-good-isomp4 \ | ||
41 | gst-plugins-good-icydemux \ | ||
42 | gst-plugins-good-video4linux2 \ | ||
43 | gst-plugins-good-multifile \ | ||
44 | gst-plugins-good-videocrop \ | ||
45 | gst-plugins-good-jpeg \ | ||
46 | gst-plugins-ugly-rmdemux \ | ||
47 | gst-plugins-ugly-asf \ | ||
48 | gst-plugins-ugly-a52dec \ | ||
49 | gst-plugins-bad-mpegdemux \ | ||
50 | gst-plugins-bad-faad \ | ||
51 | gst-plugins-bad-camerabin2 \ | ||
52 | gst-plugins-bad-jpegformat \ | ||
53 | gst-plugins-ugly-mad \ | ||
54 | gst-plugins-ugly-mpegaudioparse \ | ||
55 | gst-plugins-ugly-mpeg2dec \ | ||
56 | gst-plugins-ugly-mpegstream \ | ||
57 | gst-plugins-bad-mpegvideoparse \ | ||
58 | gst-ffmpeg \ | ||
59 | " | ||
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb index 4d24c1e..b0b35d0 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb | |||
@@ -37,8 +37,8 @@ RDEPENDS_${PN} += "\ | |||
37 | dbus-dev \ | 37 | dbus-dev \ |
38 | freetype-dev \ | 38 | freetype-dev \ |
39 | fontconfig-dev \ | 39 | fontconfig-dev \ |
40 | gstreamer-dev \ | 40 | ${@base_contains("DISTRO_FEATURES", "gstreamer010", "gstreamer-dev gst-plugins-base-dev", "", d)} \ |
41 | gst-plugins-base-dev \ | 41 | ${@base_contains("DISTRO_FEATURES", "gstreamer", "gstreamer1.0-dev gstreamer1.0-plugins-base-dev", "", d)} \ |
42 | icu-dev \ | 42 | icu-dev \ |
43 | libxslt-dev \ | 43 | libxslt-dev \ |
44 | udev-dev \ | 44 | udev-dev \ |