diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-09-28 10:12:01 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-09-28 07:33:10 +0000 |
commit | 8874262b25488d81bf9ee23f4d425a104f31a7e1 (patch) | |
tree | c0794482476aac06c3c68fbca602a4452adb3630 | |
parent | a3f443f1d7c721aa1df61e18da97276992e51665 (diff) | |
download | meta-boot2qt-8874262b25488d81bf9ee23f4d425a104f31a7e1.tar.gz |
Revert "toradex: move to V2.4 branch"
This reverts commit 299aa675369abe4f1eae062bd4f468a006449033.
Colibri VF kernel breaks with adb, revert back to older release.
Change-Id: I3c933eb55b0fb03c5837fdbb4678c0a7f3b13df8
Reviewed-by: aavit <eirik.aavitsland@theqtcompany.com>
-rw-r--r-- | conf/distro/include/colibri-imx6.conf | 3 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch | 32 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend | 6 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend (renamed from meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend) | 0 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch | 30 | ||||
-rw-r--r-- | meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch | 38 | ||||
-rw-r--r-- | scripts/manifest.xml | 2 | ||||
-rw-r--r-- | scripts/manifest_dizzy.xml | 2 |
8 files changed, 80 insertions, 33 deletions
diff --git a/conf/distro/include/colibri-imx6.conf b/conf/distro/include/colibri-imx6.conf index fcf716a..f0b6179 100644 --- a/conf/distro/include/colibri-imx6.conf +++ b/conf/distro/include/colibri-imx6.conf | |||
@@ -27,8 +27,7 @@ KERNEL_IMAGETYPE = "uImage" | |||
27 | 27 | ||
28 | BOOTFS_CONTENT = "\ | 28 | BOOTFS_CONTENT = "\ |
29 | ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \ | 29 | ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \ |
30 | ${KERNEL_IMAGETYPE}-imx6dl-colibri-eval-v3.dtb:imx6dl-colibri-eval-v3.dtb \ | 30 | ${KERNEL_IMAGETYPE}-${KERNEL_DEVICETREE}:${KERNEL_DEVICETREE} \ |
31 | ${KERNEL_IMAGETYPE}-imx6dl-colibri-cam-eval-v3.dtb:imx6dl-colibri-cam-eval-v3.dtb \ | ||
32 | u-boot-${MACHINE}.imx:u-boot.imx \ | 31 | u-boot-${MACHINE}.imx:u-boot.imx \ |
33 | " | 32 | " |
34 | BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" | 33 | BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" |
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch b/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch new file mode 100644 index 0000000..719a38d --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 7515eb259a380578540323be5d4913245e81c454 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Mon, 13 Apr 2015 12:54:17 +0200 | ||
4 | Subject: [PATCH] Colibri-iMX6: set 1280x720@16 for HDMI by default | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/imx6qdl-colibri.dtsi | 7 +++---- | ||
8 | 1 file changed, 3 insertions(+), 4 deletions(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/imx6qdl-colibri.dtsi b/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
11 | index e638266..dd8b21fc5 100644 | ||
12 | --- a/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
13 | +++ b/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
14 | @@ -70,12 +70,11 @@ | ||
15 | compatible = "fsl,mxc_sdc_fb"; | ||
16 | disp_dev = "hdmi"; | ||
17 | interface_pix_fmt = "RGB24"; | ||
18 | - mode_str ="1920x1080M@60"; | ||
19 | -/* default_bpp = <16>;*/ | ||
20 | - default_bpp = <24>; | ||
21 | + mode_str ="1280x729M@60"; | ||
22 | + default_bpp = <16>; | ||
23 | int_clk = <0>; | ||
24 | late_init = <0>; | ||
25 | - status = "disabled"; | ||
26 | + status = "okay"; | ||
27 | }; | ||
28 | |||
29 | mxcfb2: fb@1 { | ||
30 | -- | ||
31 | 2.3.5 | ||
32 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend index f739245..7c19d86 100644 --- a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend +++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend | |||
@@ -26,6 +26,12 @@ SRC_URI += "\ | |||
26 | file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \ | 26 | file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \ |
27 | " | 27 | " |
28 | 28 | ||
29 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
30 | |||
31 | SRC_URI += " \ | ||
32 | file://0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch \ | ||
33 | " | ||
34 | |||
29 | # kernel image files are not needed in the image | 35 | # kernel image files are not needed in the image |
30 | RDEPENDS_kernel-base = "" | 36 | RDEPENDS_kernel-base = "" |
31 | 37 | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend index fd9ad55..fd9ad55 100644 --- a/meta-toradex-extras/recipes/linux/linux-toradex-vf_4.%.bbappend +++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend | |||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch index 174f3b0..60c5171 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch +++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 1d5baa56ff177d7858727d1c4428096781e3817c Mon Sep 17 00:00:00 2001 | 1 | From 7538ad166d0fb1999f32f2d80969184484c2ba07 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@digia.com> | 2 | From: Samuli Piippo <samuli.piippo@digia.com> |
3 | Date: Mon, 27 Oct 2014 14:53:25 +0200 | 3 | Date: Mon, 27 Oct 2014 14:53:25 +0200 |
4 | Subject: [PATCH] Update default args for apalis imx6 | 4 | Subject: [PATCH] Update default args for apalis imx6 |
@@ -10,30 +10,30 @@ disable cursor blinking. | |||
10 | 1 file changed, 8 insertions(+), 7 deletions(-) | 10 | 1 file changed, 8 insertions(+), 7 deletions(-) |
11 | 11 | ||
12 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | 12 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h |
13 | index 162be2e..f659384 100644 | 13 | index 5d32118..289d611 100644 |
14 | --- a/include/configs/apalis_imx6.h | 14 | --- a/include/configs/apalis_imx6.h |
15 | +++ b/include/configs/apalis_imx6.h | 15 | +++ b/include/configs/apalis_imx6.h |
16 | @@ -246,14 +246,14 @@ | 16 | @@ -212,14 +212,14 @@ |
17 | "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | 17 | "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0" |
18 | 18 | ||
19 | #define SD_BOOTCMD \ | 19 | #define SD_BOOTCMD \ |
20 | - "sdargs=ip=off root=/dev/mmcblk1p2 rw,noatime rootfstype=ext3 " \ | 20 | - "sdargs=ip=off root=/dev/mmcblk1p2 rw,noatime rootfstype=ext3 " \ |
21 | - "rootwait\0" \ | 21 | - "rootwait\0" \ |
22 | + "drive=2\0" \ | 22 | + "drive=2\0" \ |
23 | "sdboot=run setup; " \ | 23 | "sdboot=" "run setup; " \ |
24 | - "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \ | 24 | - "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \ |
25 | + "setenv bootargs ${defargs} ip=off root=/dev/mmcblk${drive}p2 " \ | 25 | + "setenv bootargs ${defargs} ip=off root=/dev/mmcblk${drive}p2 " \ |
26 | + "rw,noatime rootfstype=ext3 rootwait ${setupargs} " \ | 26 | + "rw,noatime rootfstype=ext3 rootwait ${setupargs} " \ |
27 | "${vidargs}; echo Booting from SD card in 8bit slot...; " \ | 27 | "${vidargs}; echo Booting from SD card in 8bit slot...; " \ |
28 | - "run sddtbload; load mmc 1:1 ${kernel_addr_r} " \ | 28 | - "run sddtbload; fatload mmc 1:1 ${kernel_addr_r} " \ |
29 | + "run sddtbload; load mmc ${drive}:1 ${kernel_addr_r} " \ | 29 | + "run sddtbload; fatload mmc ${drive}:1 ${kernel_addr_r} " \ |
30 | "${boot_file} && bootm ${kernel_addr_r} ${dtbparam}\0" \ | 30 | "${boot_file} && bootm ${kernel_addr_r} ${dtbparam}\0" \ |
31 | - "sddtbload=setenv dtbparam; load mmc 1:1 ${fdt_addr_r} " \ | 31 | - "sddtbload=setenv dtbparam; fatload mmc 1:1 ${fdt_addr_r} " \ |
32 | + "sddtbload=setenv dtbparam; load mmc ${drive}:1 ${fdt_addr_r} " \ | 32 | + "sddtbload=setenv dtbparam; fatload mmc ${drive}:1 ${fdt_addr_r} " \ |
33 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | 33 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" |
34 | 34 | ||
35 | #define USB_BOOTCMD \ | 35 | #ifndef CONFIG_APALIS_IMX6_V1_0 |
36 | @@ -273,7 +273,8 @@ | 36 | @@ -229,7 +229,8 @@ |
37 | #define FDT_FILE "imx6q-apalis-eval_v1_0.dtb" | 37 | #define FDT_FILE "imx6q-apalis-eval_v1_0.dtb" |
38 | #endif | 38 | #endif |
39 | #define CONFIG_EXTRA_ENV_SETTINGS \ | 39 | #define CONFIG_EXTRA_ENV_SETTINGS \ |
@@ -43,15 +43,15 @@ index 162be2e..f659384 100644 | |||
43 | "run nfsboot ; echo ; echo nfsboot failed ; " \ | 43 | "run nfsboot ; echo ; echo nfsboot failed ; " \ |
44 | "usb start ;" \ | 44 | "usb start ;" \ |
45 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ | 45 | "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \ |
46 | @@ -292,7 +293,7 @@ | 46 | @@ -242,7 +243,7 @@ |
47 | "|| setenv drive 2; load ${interface} ${drive}:1 " \ | 47 | NFS_BOOTCMD \ |
48 | "${kernel_addr_r} flash_blk.img\0" \ | 48 | SD_BOOTCMD \ |
49 | "setup=setenv setupargs fec_mac=${ethaddr} " \ | 49 | "setup=setenv setupargs fec_mac=${ethaddr} " \ |
50 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ | 50 | - "consoleblank=0 no_console_suspend=1 console=tty1 " \ |
51 | + "consoleblank=0 no_console_suspend=1 vt.global_cursor_default=0 " \ | 51 | + "consoleblank=0 no_console_suspend=1 vt.global_cursor_default=0 " \ |
52 | "console=${console},${baudrate}n8\0 " \ | 52 | "console=${console},${baudrate}n8\0 " \ |
53 | "setupdate=run setsdupdate || run setusbupdate || run setethupdate;" \ | 53 | "setupdate=setenv drive 1; fatload mmc ${drive}:1 ${kernel_addr_r} " \ |
54 | " source ${kernel_addr_r}\0" \ | 54 | "flash_mmc.img || setenv drive 2; fatload mmc ${drive}:1 " \ |
55 | -- | 55 | -- |
56 | 1.9.1 | 56 | 1.9.1 |
57 | 57 | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch index bae71d5..2e72ff6 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch +++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch | |||
@@ -1,35 +1,45 @@ | |||
1 | From 878f506e43f40c2667e9e5ae82741d32fc653cac Mon Sep 17 00:00:00 2001 | 1 | From a388755704c3f8c4336939f3c868942d68b1e256 Mon Sep 17 00:00:00 2001 |
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | 2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> |
3 | Date: Thu, 28 May 2015 09:06:54 +0300 | 3 | Date: Thu, 28 May 2015 09:06:54 +0300 |
4 | Subject: [PATCH] colibri vf: enable sdboot by default | 4 | Subject: [PATCH] colibri vf: enable sdboot by default |
5 | 5 | ||
6 | Run sdboot first and remove console message from tty1 | 6 | Run sdboot first, update dtb file location to /boot/ and |
7 | remove console message from tty1 | ||
7 | --- | 8 | --- |
8 | include/configs/colibri_vf.h | 4 ++-- | 9 | include/configs/colibri_vf.h | 6 +++--- |
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | 10 | 1 file changed, 3 insertions(+), 3 deletions(-) |
10 | 11 | ||
11 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h | 12 | diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h |
12 | index 06caabd..fb9fe41 100644 | 13 | index feea159..b080510 100644 |
13 | --- a/include/configs/colibri_vf.h | 14 | --- a/include/configs/colibri_vf.h |
14 | +++ b/include/configs/colibri_vf.h | 15 | +++ b/include/configs/colibri_vf.h |
15 | @@ -174,7 +174,7 @@ | 16 | @@ -135,7 +135,7 @@ |
16 | "ubifsload ${fdt_addr_r} /boot/${soc}-colibri-${fdt_board}.dtb && " \ | 17 | "load mmc 0:2 ${kernel_addr_r} /boot/${kernel_file} && " \ |
17 | "bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \ | 18 | "run sddtbload; bootz ${kernel_addr_r} - ${dtbparam}\0" \ |
19 | "sddtbload=setenv dtbparam; load mmc 0:2 ${fdt_addr_r} " \ | ||
20 | - "${soc}-colibri-${fdt_board}.dtb && " \ | ||
21 | + "/boot/${soc}-colibri-${fdt_board}.dtb && " \ | ||
22 | "setenv dtbparam ${fdt_addr_r}\0" | ||
23 | |||
24 | #define NFS_BOOTCMD \ | ||
25 | @@ -160,7 +160,7 @@ | ||
26 | "/boot/${soc}-colibri-${fdt_board}.dtb && " \ | ||
27 | "setenv dtbparam ${fdt_addr_r}\0" | ||
18 | 28 | ||
19 | -#define CONFIG_BOOTCOMMAND "run ubiboot; run sdboot; run nfsboot" | 29 | -#define CONFIG_BOOTCOMMAND "run ubiboot; run sdboot; run nfsboot" |
20 | +#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; run nfsboot" | 30 | +#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; run nfsboot" |
21 | 31 | ||
22 | #define DFU_ALT_NAND_INFO "vf-bcb part 0,1;u-boot part 0,2;ubi part 0,4" | 32 | #define DFU_ALT_NAND_INFO "vf-bcb part 0,1;u-boot part 0,2;ubi part 0,4" |
23 | 33 | ||
24 | @@ -187,7 +187,7 @@ | 34 | @@ -173,7 +173,7 @@ |
25 | "defargs=\0" \ | 35 | "defargs=\0" \ |
26 | "console=ttyLP0\0" \ | 36 | "console=ttyLP0\0" \ |
27 | "setup=setenv setupargs " \ | 37 | "setup=setenv setupargs fec_mac=${ethaddr} consoleblank=0 " \ |
28 | - "console=tty1 console=${console}" \ | 38 | - "console=tty1 console=${console},${baudrate}n8 ${memargs}\0" \ |
29 | + "console=${console}" \ | 39 | + "console=${console},${baudrate}n8 ${memargs}\0" \ |
30 | ",${baudrate}n8 ${memargs} consoleblank=0\0" \ | 40 | "setsdupdate=mmc rescan && set interface mmc && " \ |
31 | "setsdupdate=mmc rescan && setenv interface mmc && " \ | ||
32 | "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \ | 41 | "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \ |
42 | "source ${loadaddr}\0" \ | ||
33 | -- | 43 | -- |
34 | 1.9.1 | 44 | 1.9.1 |
35 | 45 | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index ca71c1c..4a88a1b 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -46,7 +46,7 @@ | |||
46 | groups="notdefault,bbb"/> | 46 | groups="notdefault,bbb"/> |
47 | <project name="meta-toradex" | 47 | <project name="meta-toradex" |
48 | remote="toradex" | 48 | remote="toradex" |
49 | revision="a76e317a2ae638ed62ccf88636aa79d0ae368d78" | 49 | revision="36c19b10b340983946f8f52ab7fa91d9aa1e53f6" |
50 | path="sources/meta-toradex" | 50 | path="sources/meta-toradex" |
51 | groups="notdefault,toradex"/> | 51 | groups="notdefault,toradex"/> |
52 | <project name="meta-tibidabo" | 52 | <project name="meta-tibidabo" |
diff --git a/scripts/manifest_dizzy.xml b/scripts/manifest_dizzy.xml index 4b2e4ff..d6fdd0b 100644 --- a/scripts/manifest_dizzy.xml +++ b/scripts/manifest_dizzy.xml | |||
@@ -46,7 +46,7 @@ | |||
46 | groups="notdefault,bbb"/> | 46 | groups="notdefault,bbb"/> |
47 | <project name="meta-toradex" | 47 | <project name="meta-toradex" |
48 | remote="toradex" | 48 | remote="toradex" |
49 | revision="V2.4" | 49 | revision="V2.3-next" |
50 | path="sources/meta-toradex" | 50 | path="sources/meta-toradex" |
51 | groups="notdefault,toradex"/> | 51 | groups="notdefault,toradex"/> |
52 | <project name="meta-tibidabo" | 52 | <project name="meta-tibidabo" |