diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-04-11 09:13:23 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-04-12 09:24:26 +0000 |
commit | 5a14a092e02921b63c0add8e278089ef96beb314 (patch) | |
tree | 1205d8a51535ada20ad20e86071ea7ff7cda8a10 | |
parent | d153b85f7c96a1a6a033fc2764efab877e7f9e9d (diff) | |
download | meta-boot2qt-5a14a092e02921b63c0add8e278089ef96beb314.tar.gz |
gcc: patch already applied on oe layer
Change-Id: I8230869a08fcb902c55b5dfd22e1221c918ce895
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r-- | recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch | 39 | ||||
-rw-r--r-- | recipes/gcc/gcc-source_4.9.bbappend | 26 |
2 files changed, 0 insertions, 65 deletions
diff --git a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch b/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch deleted file mode 100644 index c0ea62f..0000000 --- a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From b30ffb8097749fdb55704aa7d8307ca1a58255d6 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Stefan=20M=C3=BCller-Klieser?= <s.mueller-klieser@phytec.de> | ||
3 | Date: Tue, 7 Apr 2015 16:15:11 +0200 | ||
4 | Subject: [PATCH] gcc/var-tracking.c: backport from gcc trunk r212178 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | resolves a bug seen on cortexa8 building qt5 libraries. | ||
10 | |||
11 | 2014-06-30 Joseph Myers <joseph@codesourcery.com> | ||
12 | |||
13 | * var-tracking.c (add_stores): Return instead of asserting if old | ||
14 | and new values for conditional store are the same. | ||
15 | |||
16 | git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@212178 138bc75d-0d04-0410-961f-82ee72b054a4 | ||
17 | |||
18 | Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> | ||
19 | --- | ||
20 | gcc/var-tracking.c | 3 ++- | ||
21 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/gcc/var-tracking.c b/gcc/var-tracking.c | ||
24 | index 65d8285..7c38910 100644 | ||
25 | --- a/gcc/var-tracking.c | ||
26 | +++ b/gcc/var-tracking.c | ||
27 | @@ -5997,7 +5997,8 @@ add_stores (rtx loc, const_rtx expr, void *cuip) | ||
28 | { | ||
29 | cselib_val *oval = cselib_lookup (oloc, GET_MODE (oloc), 0, VOIDmode); | ||
30 | |||
31 | - gcc_assert (oval != v); | ||
32 | + if (oval == v) | ||
33 | + return; | ||
34 | gcc_assert (REG_P (oloc) || MEM_P (oloc)); | ||
35 | |||
36 | if (oval && !cselib_preserved_value_p (oval)) | ||
37 | -- | ||
38 | 1.9.1 | ||
39 | |||
diff --git a/recipes/gcc/gcc-source_4.9.bbappend b/recipes/gcc/gcc-source_4.9.bbappend deleted file mode 100644 index 2b937e6..0000000 --- a/recipes/gcc/gcc-source_4.9.bbappend +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_append := "${THISDIR}/gcc-4.9:" | ||
23 | |||
24 | SRC_URI += " \ | ||
25 | file://0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch \ | ||
26 | " | ||