diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-05-04 16:12:59 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-05-17 09:17:45 +0000 |
commit | e453be26fc4836ded18041addcd47daf4e192556 (patch) | |
tree | 443cd14c102ec33461ed15f19230030b34f02ce0 | |
parent | e3ef984ac6f5926d7a910eff33bafeb5da6c2ff0 (diff) | |
download | meta-boot2qt-e453be26fc4836ded18041addcd47daf4e192556.tar.gz |
qt5: update submodules and meta-qt5
meta-qt5 now depends on remove-libtool that is available
only in oe/jetro, so backport it our layer.
Change-Id: I5989ddb25ddecb6c749292d4e3fec63d0f61368f
Reviewed-by: David Schulz <david.schulz@theqtcompany.com>
22 files changed, 35 insertions, 21 deletions
diff --git a/classes/remove-libtool.bbclass b/classes/remove-libtool.bbclass new file mode 100644 index 0000000..0d7bd21 --- /dev/null +++ b/classes/remove-libtool.bbclass | |||
@@ -0,0 +1,11 @@ | |||
1 | # This class removes libtool .la files after do_install | ||
2 | |||
3 | REMOVE_LIBTOOL_LA ?= "1" | ||
4 | |||
5 | remove_libtool_la() { | ||
6 | if [ "${REMOVE_LIBTOOL_LA}" != "0" ]; then | ||
7 | find "${D}" -ignore_readdir_race -name "*.la" -delete | ||
8 | fi | ||
9 | } | ||
10 | |||
11 | do_install[postfuncs] += "remove_libtool_la" | ||
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf index 7b56113..8b38faa 100644 --- a/conf/distro/b2qt.conf +++ b/conf/distro/b2qt.conf | |||
@@ -45,6 +45,9 @@ DISTRO_FEATURES_DEFAULT = "alsa argp bluetooth ext2 largefile usbgadget usbhost | |||
45 | POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" | 45 | POKY_DEFAULT_DISTRO_FEATURES = "largefile opengl multiarch" |
46 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio sysvinit" | 46 | DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio sysvinit" |
47 | 47 | ||
48 | # backport from oe/master, needed by meta-qt5 | ||
49 | PACKAGECONFIG_CONFARGS += "${EXTRA_OECONF}" | ||
50 | |||
48 | # use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10 | 51 | # use GStreamer 1.0, optionally change to "gstreamer010" to use GStreamer 0.10 |
49 | DISTRO_FEATURES += "gstreamer" | 52 | DISTRO_FEATURES += "gstreamer" |
50 | 53 | ||
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend index 5b25f39..41922ab 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend | |||
@@ -19,7 +19,7 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "8ce657d0279566ef327af1b88339534041ddc012" | 22 | SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374" |
23 | 23 | ||
24 | FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" | 24 | FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" |
25 | 25 | ||
diff --git a/recipes-qt/qt5/qt3d_git.bbappend b/recipes-qt/qt5/qt3d_git.bbappend index 318bb1b..b050083 100644 --- a/recipes-qt/qt5/qt3d_git.bbappend +++ b/recipes-qt/qt5/qt3d_git.bbappend | |||
@@ -25,4 +25,4 @@ SRC_URI_append_class-target = " \ | |||
25 | file://0001-Remove-qgltf.patch \ | 25 | file://0001-Remove-qgltf.patch \ |
26 | " | 26 | " |
27 | 27 | ||
28 | SRCREV = "9c67288ea4791fee5e28d1b4f2981c232b95c9d0" | 28 | SRCREV = "8fb8f65da85e16a3f4d798d2175cec918d2c5afb" |
diff --git a/recipes-qt/qt5/qtbase-native_git.bbappend b/recipes-qt/qt5/qtbase-native_git.bbappend index fcbbcf0..79e150e 100644 --- a/recipes-qt/qt5/qtbase-native_git.bbappend +++ b/recipes-qt/qt5/qtbase-native_git.bbappend | |||
@@ -19,7 +19,7 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "8ce657d0279566ef327af1b88339534041ddc012" | 22 | SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374" |
23 | 23 | ||
24 | FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" | 24 | FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" |
25 | 25 | ||
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend index bb778a0..cc68c72 100644 --- a/recipes-qt/qt5/qtbase_git.bbappend +++ b/recipes-qt/qt5/qtbase_git.bbappend | |||
@@ -45,7 +45,7 @@ do_configure_prepend() { | |||
45 | install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs | 45 | install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs |
46 | } | 46 | } |
47 | 47 | ||
48 | SRCREV = "8ce657d0279566ef327af1b88339534041ddc012" | 48 | SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374" |
49 | 49 | ||
50 | # Temporarily here, until merged upstream | 50 | # Temporarily here, until merged upstream |
51 | PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl" | 51 | PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl" |
diff --git a/recipes-qt/qt5/qtconnectivity_git.bbappend b/recipes-qt/qt5/qtconnectivity_git.bbappend index 9c4a689..f2040cc 100644 --- a/recipes-qt/qt5/qtconnectivity_git.bbappend +++ b/recipes-qt/qt5/qtconnectivity_git.bbappend | |||
@@ -21,4 +21,4 @@ | |||
21 | 21 | ||
22 | PACKAGECONFIG += "bluez4" | 22 | PACKAGECONFIG += "bluez4" |
23 | 23 | ||
24 | SRCREV = "80b6557be3a23a5118ddf8c4b68bc28b66f52b49" | 24 | SRCREV = "dedff12a896d51c469d2af82664b86a10f8fa7fe" |
diff --git a/recipes-qt/qt5/qtdeclarative_git.bbappend b/recipes-qt/qt5/qtdeclarative_git.bbappend index f7d8ed7..4975e59 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bbappend +++ b/recipes-qt/qt5/qtdeclarative_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "d438b4f4b93d04a841edf031359e26af617d889d" | 22 | SRCREV = "2e6f7f362e62c3285e7d395aca607502c8e8160e" |
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend index a175291..68d1832 100644 --- a/recipes-qt/qt5/qtlocation_git.bbappend +++ b/recipes-qt/qt5/qtlocation_git.bbappend | |||
@@ -24,4 +24,4 @@ PACKAGECONFIG += "gypsy" | |||
24 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" | 24 | EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" |
25 | DEPENDS_emulator += "qtsimulator" | 25 | DEPENDS_emulator += "qtsimulator" |
26 | 26 | ||
27 | SRCREV = "f40e92b147560be15e0f53dfd7f6b2d698c00fb9" | 27 | SRCREV = "d1f66746ab0b77b4f3300cbeeaafe61d25d78e98" |
diff --git a/recipes-qt/qt5/qtmultimedia_git.bbappend b/recipes-qt/qt5/qtmultimedia_git.bbappend index 24f176d..01ad196 100644 --- a/recipes-qt/qt5/qtmultimedia_git.bbappend +++ b/recipes-qt/qt5/qtmultimedia_git.bbappend | |||
@@ -21,4 +21,4 @@ | |||
21 | 21 | ||
22 | PACKAGECONFIG += "${@base_contains("DISTRO_FEATURES", "gstreamer010", "gstreamer010", "gstreamer", d)}" | 22 | PACKAGECONFIG += "${@base_contains("DISTRO_FEATURES", "gstreamer010", "gstreamer010", "gstreamer", d)}" |
23 | 23 | ||
24 | SRCREV = "3fb3231a9e22dcb780d5b31ec57896429d40b0e5" | 24 | SRCREV = "7553a0521356d0b28bacb8c8d07a25e4ba26097e" |
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb index a80b21f..4427501 100644 --- a/recipes-qt/qt5/qtquickcontrols2_git.bb +++ b/recipes-qt/qt5/qtquickcontrols2_git.bb | |||
@@ -31,7 +31,7 @@ LIC_FILES_CHKSUM = " \ | |||
31 | 31 | ||
32 | DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects" | 32 | DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects" |
33 | 33 | ||
34 | SRCREV = "bed6b3d633d83302a8e2167845db4b36e6847f0b" | 34 | SRCREV = "ac152bfcd37f94453e9705b57ca6520ad30bade0" |
35 | 35 | ||
36 | FILES_${PN}-qmldesigner += " \ | 36 | FILES_${PN}-qmldesigner += " \ |
37 | ${OE_QMAKE_PATH_QML}/*/*/*/designer \ | 37 | ${OE_QMAKE_PATH_QML}/*/*/*/designer \ |
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bbappend b/recipes-qt/qt5/qtquickcontrols_git.bbappend index 29fb136..3a988d8 100644 --- a/recipes-qt/qt5/qtquickcontrols_git.bbappend +++ b/recipes-qt/qt5/qtquickcontrols_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "b1d29faf96ee6323bf2dad054291fd7c30a30c05" | 22 | SRCREV = "26f7894dae87ef2dd6cf596decf645d1c877c950" |
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb index 484d6ee..fbb79ae 100644 --- a/recipes-qt/qt5/qtserialbus_git.bb +++ b/recipes-qt/qt5/qtserialbus_git.bb | |||
@@ -31,4 +31,4 @@ LIC_FILES_CHKSUM = " \ | |||
31 | 31 | ||
32 | DEPENDS += "qtbase qtserialport" | 32 | DEPENDS += "qtbase qtserialport" |
33 | 33 | ||
34 | SRCREV = "04b75569f36eec14662505a08bf8c1d565cb10fe" | 34 | SRCREV = "edf55f657a46fe16bf80d63f523848bb9b71d9f3" |
diff --git a/recipes-qt/qt5/qtsvg_git.bbappend b/recipes-qt/qt5/qtsvg_git.bbappend index beb7513..f2d7292 100644 --- a/recipes-qt/qt5/qtsvg_git.bbappend +++ b/recipes-qt/qt5/qtsvg_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "b722836765dccca04683939d0d4f72a9e2585d88" | 22 | SRCREV = "e02df9c098b4d304b34c0ff65806a0576e45ed1a" |
diff --git a/recipes-qt/qt5/qttools_git.bbappend b/recipes-qt/qt5/qttools_git.bbappend index 31d5773..740e3fa 100644 --- a/recipes-qt/qt5/qttools_git.bbappend +++ b/recipes-qt/qt5/qttools_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "aec1d10c66a676781c767099e81871faa040162f" | 22 | SRCREV = "e33532e048fa12ee32429ca83ee31aa8f065147d" |
diff --git a/recipes-qt/qt5/qttranslations_git.bbappend b/recipes-qt/qt5/qttranslations_git.bbappend index cfe42a8..caba045 100644 --- a/recipes-qt/qt5/qttranslations_git.bbappend +++ b/recipes-qt/qt5/qttranslations_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "cbef985e3c3e9af2d124d40959fc674b3b8aa33f" | 22 | SRCREV = "13f1f2f12ddfc9b84535361d77a5f0f0ec8c3e0f" |
diff --git a/recipes-qt/qt5/qtwayland-native_git.bbappend b/recipes-qt/qt5/qtwayland-native_git.bbappend index 66656e6..9fa9184 100644 --- a/recipes-qt/qt5/qtwayland-native_git.bbappend +++ b/recipes-qt/qt5/qtwayland-native_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "b94be41409a6dfa58d8b3ae8413c6930e76fc040" | 22 | SRCREV = "2e08d3afc08ea305052d75a306dac381d3025134" |
diff --git a/recipes-qt/qt5/qtwayland_git.bbappend b/recipes-qt/qt5/qtwayland_git.bbappend index 66656e6..9fa9184 100644 --- a/recipes-qt/qt5/qtwayland_git.bbappend +++ b/recipes-qt/qt5/qtwayland_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "b94be41409a6dfa58d8b3ae8413c6930e76fc040" | 22 | SRCREV = "2e08d3afc08ea305052d75a306dac381d3025134" |
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend index 319a9ad..87fc55a 100644 --- a/recipes-qt/qt5/qtwebengine_git.bbappend +++ b/recipes-qt/qt5/qtwebengine_git.bbappend | |||
@@ -25,5 +25,5 @@ SRC_URI_append_mx6 = " \ | |||
25 | file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \ | 25 | file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \ |
26 | " | 26 | " |
27 | 27 | ||
28 | SRCREV_qtwebengine = "4ed08bb0a8195746c333dabbdb9da3400d174296" | 28 | SRCREV_qtwebengine = "a3318c84b022282a5a4a2babc51d1e3ca634e25b" |
29 | SRCREV_chromium = "0a385bb01d9cf060fae4c9d350ee98561654df96" | 29 | SRCREV_chromium = "8252b18aa3efa52138e91f9756945afb142a1c8c" |
diff --git a/recipes-qt/qt5/qtwebsockets_git.bbappend b/recipes-qt/qt5/qtwebsockets_git.bbappend index 91881b4..911457c 100644 --- a/recipes-qt/qt5/qtwebsockets_git.bbappend +++ b/recipes-qt/qt5/qtwebsockets_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "3b128f9b45f4fafc305ff0c89cfc2cb665c856d5" | 22 | SRCREV = "ba9306ec5a1271275d79b2f48ceb227f79352f33" |
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bbappend b/recipes-qt/qt5/qtxmlpatterns_git.bbappend index 28d0211..a057fb1 100644 --- a/recipes-qt/qt5/qtxmlpatterns_git.bbappend +++ b/recipes-qt/qt5/qtxmlpatterns_git.bbappend | |||
@@ -19,4 +19,4 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | SRCREV = "7a8d395a3b1eb5f24aa96509666326bad4218c14" | 22 | SRCREV = "5e6acdb2ea92add793835561e7a2d6b0ed8890f8" |
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 5e326c9..5912e6f 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -25,7 +25,7 @@ | |||
25 | path="sources/meta-openembedded"/> | 25 | path="sources/meta-openembedded"/> |
26 | <project name="meta-qt5" | 26 | <project name="meta-qt5" |
27 | remote="qtyocto" | 27 | remote="qtyocto" |
28 | revision="46817620916ed6d8b8f07c720f29d1faa73eafae" | 28 | revision="afb62012ec358e12fcad06e8096be1f6ec13f1ba" |
29 | path="sources/meta-qt5"/> | 29 | path="sources/meta-qt5"/> |
30 | <project name="meta-mingw" | 30 | <project name="meta-mingw" |
31 | remote="qtyocto" | 31 | remote="qtyocto" |