diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-23 16:47:21 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-24 10:55:03 +0000 |
commit | 960945859db570e237c022b2c3269cec3902c876 (patch) | |
tree | be60b9d1c0c3207d51c290e3b812624f9fcd3ff8 | |
parent | e245c1dc8fe450fe9aeb5e505c90ba6dadf365d1 (diff) | |
download | meta-boot2qt-960945859db570e237c022b2c3269cec3902c876.tar.gz |
Update meta layers
Pull in latest from poky/yocto and openembedded
Change-Id: Ifd57a6ddb4714eb07b5bbaaf76138e84e0cf07c6
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r-- | recipes/os-release/os-release.bbappend | 47 | ||||
-rw-r--r-- | scripts/manifest.xml | 4 |
2 files changed, 2 insertions, 49 deletions
diff --git a/recipes/os-release/os-release.bbappend b/recipes/os-release/os-release.bbappend deleted file mode 100644 index a225573..0000000 --- a/recipes/os-release/os-release.bbappend +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # Reported upstream https://bugzilla.yoctoproject.org/show_bug.cgi?id=9144 | ||
31 | python do_fix_quotes () { | ||
32 | with open(d.expand('${B}/os-release'), 'w') as f: | ||
33 | for field in d.getVar('OS_RELEASE_FIELDS', True).split(): | ||
34 | value = d.getVar(field, True) | ||
35 | if value: | ||
36 | f.write('{0}="{1}"\n'.format(field, value)) | ||
37 | } | ||
38 | |||
39 | do_verify_if_fixed_by_upstream () { | ||
40 | pretty_name_first_char=$(cat ${B}/os-release | grep "^PRETTY_NAME" | cut -f 2 -d '=' | cut -c1) | ||
41 | if [ "${pretty_name_first_char}" = "\"" ]] ; then | ||
42 | bbwarn "Issue appears to be fixed by upstream, remove this workaround." | ||
43 | fi | ||
44 | } | ||
45 | |||
46 | addtask do_verify_if_fixed_by_upstream after do_compile before do_install | ||
47 | addtask do_fix_quotes after do_verify_if_fixed_by_upstream before do_install | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 9d6effc..3354dd2 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -17,11 +17,11 @@ | |||
17 | 17 | ||
18 | <project name="poky" | 18 | <project name="poky" |
19 | remote="yocto" | 19 | remote="yocto" |
20 | revision="b1f23d1254682866236bfaeb843c0d8aa332efc2" | 20 | revision="40376446904ae3529be41737fed9a0b650ed167d" |
21 | path="sources/poky"/> | 21 | path="sources/poky"/> |
22 | <project name="meta-openembedded" | 22 | <project name="meta-openembedded" |
23 | remote="oe-mirror" | 23 | remote="oe-mirror" |
24 | revision="dc5634968b270dde250690609f0015f881db81f2" | 24 | revision="8ab04afbffb4bc5184cfe0655049de6f44269990" |
25 | path="sources/meta-openembedded"/> | 25 | path="sources/meta-openembedded"/> |
26 | <project name="meta-qt5" | 26 | <project name="meta-qt5" |
27 | remote="qtyocto" | 27 | remote="qtyocto" |