summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-04-29 14:10:09 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:47:34 +0300
commitcbf5a7653383beebf44c9634506661d1fa6dfcf3 (patch)
tree4038adc4aa9c751f2ed3aac4c38a5b811179c951
parentae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (diff)
downloadmeta-boot2qt-cbf5a7653383beebf44c9634506661d1fa6dfcf3.tar.gz
Enable Qt Quick Compiler
Build Qt Quick Compiler and use it for VKB and QtCharts. Use BBCLASSEXTEND to build all 3 version (target, native and nativesdk) of Qt Quick Compiler. Change-Id: I611fe7762b8d9124b146b7fe976f09130d5912fa Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
-rw-r--r--classes/qtquickcompiler.bbclass13
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-addons-toolchain-target.bb1
-rw-r--r--recipes-qt/qt5-addons/qtcharts_2.0.bb2
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler_2.0.bb44
-rw-r--r--recipes-qt/qt5-addons/qtvirtualkeyboard_1.3.bb6
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_%.bbappend24
7 files changed, 87 insertions, 4 deletions
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass
new file mode 100644
index 0000000..202d592
--- /dev/null
+++ b/classes/qtquickcompiler.bbclass
@@ -0,0 +1,13 @@
1EXTRA_QMAKEVARS_PRE += "CONFIG+=qtquickcompiler CONFIG+=no_qtquickcompiler_depend"
2
3DEPENDS_prepend = "qtquickcompiler qtquickcompiler-native "
4
5#python __anonymous() {
6# do the magic:
7# if QT_SDK path is set,
8# add dependency to qtquickcompiler-sdk-native package that
9# copies the needed files (binary and mkspec files) from the SDK
10# else
11# add dependency to qtquickcompiler-native package that
12# builds it from internal repos
13#}
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
index 1979879..b424fb7 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
@@ -31,4 +31,5 @@ RDEPENDS_${PN} += "\
31 nativesdk-qttools \ 31 nativesdk-qttools \
32 nativesdk-qtbase-tools \ 32 nativesdk-qtbase-tools \
33 nativesdk-qtbase-tools-staticdev \ 33 nativesdk-qtbase-tools-staticdev \
34 nativesdk-qtquickcompiler-tools \
34 " 35 "
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-addons-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-addons-toolchain-target.bb
index 66e7457..f009340 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-addons-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-addons-toolchain-target.bb
@@ -32,5 +32,6 @@ RDEPENDS_${PN} += " \
32 qtenterprisecontrols-dev \ 32 qtenterprisecontrols-dev \
33 qtcharts-dev \ 33 qtcharts-dev \
34 qtvirtualkeyboard-dev \ 34 qtvirtualkeyboard-dev \
35 qtquickcompiler-dev \
35 b2qt-utils-dev \ 36 b2qt-utils-dev \
36 " 37 "
diff --git a/recipes-qt/qt5-addons/qtcharts_2.0.bb b/recipes-qt/qt5-addons/qtcharts_2.0.bb
index 4b350de..77fe3c3 100644
--- a/recipes-qt/qt5-addons/qtcharts_2.0.bb
+++ b/recipes-qt/qt5-addons/qtcharts_2.0.bb
@@ -24,7 +24,7 @@ DESCRIPTION = "Qt Charts"
24LICENSE = "QtEnterprise" 24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://src/charts/qchart.cpp;md5=735b3be820c0a733e328a4d2e1e430de;beginline=1;endline=17" 25LIC_FILES_CHKSUM = "file://src/charts/qchart.cpp;md5=735b3be820c0a733e328a4d2e1e430de;beginline=1;endline=17"
26 26
27inherit qt5-module 27inherit qt5-module qtquickcompiler
28 28
29SRC_URI = " \ 29SRC_URI = " \
30 git://qt-gerrit.it.local/QtRD-15810/charts.git;branch=${QT_BRANCH};protocol=ssh \ 30 git://qt-gerrit.it.local/QtRD-15810/charts.git;branch=${QT_BRANCH};protocol=ssh \
diff --git a/recipes-qt/qt5-addons/qtquickcompiler_2.0.bb b/recipes-qt/qt5-addons/qtquickcompiler_2.0.bb
new file mode 100644
index 0000000..fd7e8be
--- /dev/null
+++ b/recipes-qt/qt5-addons/qtquickcompiler_2.0.bb
@@ -0,0 +1,44 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Qt Quick Compiler"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=553f8ee8d120874969caca3193ae686c;beginline=1;endline=6"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.ci.local/QtRD-15810/qmlcompiler.git;branch=${QT_BRANCH};protocol=ssh;name=compiler;destsuffix=git \
31 git://qt-gerrit.ci.local/QtRD-15810/qtsdk-enterprise.git;branch=${QT_BRANCH};protocol=ssh;name=sdk;destsuffix=git/compiler/license-checker \
32 "
33
34SRCREV_compiler = "60c13275dec85d8224ea5826ae5533d87c65e76e"
35QT_BRANCH_compiler = "2.0"
36
37SRCREV_sdk = "60cb1a7763b670108b17c7e1345394e424153bea"
38QT_BRANCH_sdk = "master"
39
40S = "${WORKDIR}/git"
41
42DEPENDS = "qtbase qtdeclarative"
43
44BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5-addons/qtvirtualkeyboard_1.3.bb b/recipes-qt/qt5-addons/qtvirtualkeyboard_1.3.bb
index 40669e1..25441aa 100644
--- a/recipes-qt/qt5-addons/qtvirtualkeyboard_1.3.bb
+++ b/recipes-qt/qt5-addons/qtvirtualkeyboard_1.3.bb
@@ -24,7 +24,7 @@ DESCRIPTION = "Qt Virtual Keyboard"
24LICENSE = "QtEnterprise" 24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=9e7c3707428a49f2fd857aa1538823b6;beginline=1;endline=17" 25LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=9e7c3707428a49f2fd857aa1538823b6;beginline=1;endline=17"
26 26
27inherit qt5-module 27inherit qt5-module qtquickcompiler
28 28
29FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 29FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
30 30
@@ -32,14 +32,14 @@ SRC_URI = " \
32 git://qt-gerrit.it.local/QtRD-15810/qtvirtualkeyboard.git;branch=${QT_BRANCH};protocol=ssh \ 32 git://qt-gerrit.it.local/QtRD-15810/qtvirtualkeyboard.git;branch=${QT_BRANCH};protocol=ssh \
33 " 33 "
34 34
35SRCREV = "fa1aae525f94e9a870d0fcc0fb1be50648b76739" 35SRCREV = "b5f0a28522f2fcb916966bd0da0b86f2d93d2b97"
36QT_BRANCH = "master" 36QT_BRANCH = "master"
37 37
38S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
39 39
40DEPENDS = "qtbase qtdeclarative hunspell" 40DEPENDS = "qtbase qtdeclarative hunspell"
41 41
42EXTRA_QMAKEVARS_PRE += "CONFIG+=disable-xcb" 42EXTRA_QMAKEVARS_PRE += "CONFIG+=disable-desktop"
43 43
44FILES_${PN}-qmlplugins-dbg = " \ 44FILES_${PN}-qmlplugins-dbg = " \
45 ${OE_QMAKE_PATH_QML}/QtQuick/Enterprise/VirtualKeyboard/Styles/.debug/* \ 45 ${OE_QMAKE_PATH_QML}/QtQuick/Enterprise/VirtualKeyboard/Styles/.debug/* \
diff --git a/recipes-qt/qt5/nativesdk-qtbase_%.bbappend b/recipes-qt/qt5/nativesdk-qtbase_%.bbappend
new file mode 100644
index 0000000..e6651e5
--- /dev/null
+++ b/recipes-qt/qt5/nativesdk-qtbase_%.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# Needed by qtxmlpatterns
24EXTRA_QTLIB = "Network Sql"