diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 16:17:30 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-24 10:54:52 +0000 |
commit | e245c1dc8fe450fe9aeb5e505c90ba6dadf365d1 (patch) | |
tree | 8a0c7296e7f6655e620427d7f05e6a7adad3c258 | |
parent | af902739757f9581473009ad8668fc64cc92e279 (diff) | |
download | meta-boot2qt-e245c1dc8fe450fe9aeb5e505c90ba6dadf365d1.tar.gz |
Reuse qt5-git.inc in automotive recipes
Instead of using codereview.qt-project.org directly, reuse qt5-git.inc
from meta-qt5 that defines git url to be used which simplyfies the recipes.
Also cleanup unnecessary use of sdk-sources for opened repos.
Change-Id: I80e02c9aba600eb41e2618f377e878fd8ecead11
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 12 | ||||
-rw-r--r-- | recipes-qt/automotive/qmllive-target_git.bb | 43 | ||||
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 10 | ||||
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 10 | ||||
-rw-r--r-- | recipes-qt/automotive/qtwebbrowser_git.bb | 11 |
5 files changed, 50 insertions, 36 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index 70f213b..66703c6 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -31,17 +31,17 @@ DESCRIPTION = "Neptune IVI UI" | |||
31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" |
33 | 33 | ||
34 | inherit qt5-module sdk-sources systemd | 34 | inherit qt5-module systemd |
35 | require recipes-qt/qt5/qt5-git.inc | ||
35 | 36 | ||
36 | SRC_URI = " \ | 37 | QT_MODULE = "qt-apps-neptune-ui" |
37 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \ | 38 | QT_MODULE_BRANCH = "master" |
39 | |||
40 | SRC_URI += " \ | ||
38 | file://neptune.service \ | 41 | file://neptune.service \ |
39 | " | 42 | " |
40 | 43 | ||
41 | SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814" | 44 | SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814" |
42 | BRANCH = "master" | ||
43 | |||
44 | S = "${WORKDIR}/git" | ||
45 | 45 | ||
46 | DEPENDS = "qtbase qtdeclarative" | 46 | DEPENDS = "qtbase qtdeclarative" |
47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ | 47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ |
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb index efcac4d..7819941 100644 --- a/recipes-qt/automotive/qmllive-target_git.bb +++ b/recipes-qt/automotive/qmllive-target_git.bb | |||
@@ -1,19 +1,48 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
1 | DESCRIPTION = "QML Live target runtime" | 30 | DESCRIPTION = "QML Live target runtime" |
2 | 31 | ||
3 | LICENSE = "GPL-3.0" | 32 | LICENSE = "GPL-3.0" |
4 | LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" | 33 | LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" |
5 | 34 | ||
6 | inherit qmake5 sdk-sources | 35 | inherit qmake5 |
36 | require recipes-qt/qt5/qt5-git.inc | ||
7 | 37 | ||
8 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 38 | QT_MODULE = "qt-apps-qmllive" |
39 | QT_MODULE_BRANCH = "master" | ||
9 | 40 | ||
10 | SRC_URI = " \ | 41 | SRC_URI += " \ |
11 | git://codereview.qt-project.org/qt-apps/qmllive.git;branch=${BRANCH};protocol=ssh;name=tools \ | ||
12 | file://qmllive-target.patch \ | 42 | file://qmllive-target.patch \ |
13 | " | 43 | " |
14 | 44 | ||
15 | BRANCH = "master" | 45 | SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc" |
16 | SRCREV_tools="d0d41c71c4691a5f3e2b72e22917f314b4190ffc" | ||
17 | 46 | ||
18 | S = "${WORKDIR}/git/src/runtime" | 47 | S = "${WORKDIR}/git/src/runtime" |
19 | 48 | ||
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index fd128bd..028df78 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -31,21 +31,15 @@ DESCRIPTION = "Qt component for application lifecycle management" | |||
31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" |
33 | 33 | ||
34 | inherit qmake5 sdk-sources | 34 | inherit qmake5 |
35 | 35 | require recipes-qt/qt5/qt5-git.inc | |
36 | SRC_URI = " \ | ||
37 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \ | ||
38 | " | ||
39 | 36 | ||
40 | SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76" | 37 | SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76" |
41 | BRANCH = "5.7" | ||
42 | 38 | ||
43 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | 39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ |
44 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 40 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
45 | RDEPENDS_${PN} = "libcrypto" | 41 | RDEPENDS_${PN} = "libcrypto" |
46 | 42 | ||
47 | S = "${WORKDIR}/git" | ||
48 | |||
49 | EXTRA_QMAKEVARS_PRE += "\ | 43 | EXTRA_QMAKEVARS_PRE += "\ |
50 | ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ | 44 | ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ |
51 | -config enable-dummydata \ | 45 | -config enable-dummydata \ |
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index b50defc..0c50457 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -35,15 +35,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | |||
35 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ | 35 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ |
36 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" | 36 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" |
37 | 37 | ||
38 | inherit qt5-module sdk-sources | 38 | inherit qt5-module |
39 | 39 | require recipes-qt/qt5/qt5-git.inc | |
40 | SRC_URI = " \ | ||
41 | git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \ | ||
42 | " | ||
43 | 40 | ||
44 | SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a" | 41 | SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a" |
45 | BRANCH = "5.7" | ||
46 | |||
47 | S = "${WORKDIR}/git" | ||
48 | 42 | ||
49 | DEPENDS = "qtbase qtdeclarative" | 43 | DEPENDS = "qtbase qtdeclarative" |
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb index 8031aac..b06446e 100644 --- a/recipes-qt/automotive/qtwebbrowser_git.bb +++ b/recipes-qt/automotive/qtwebbrowser_git.bb | |||
@@ -31,16 +31,13 @@ DESCRIPTION = "Qt Web Browser" | |||
31 | LICENSE = "GPL-3.0" | 31 | LICENSE = "GPL-3.0" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6" |
33 | 33 | ||
34 | inherit qmake5 sdk-sources | 34 | inherit qmake5 |
35 | require recipes-qt/qt5/qt5-git.inc | ||
35 | 36 | ||
36 | SRC_URI = " \ | 37 | QT_MODULE = "qt-apps-qtwebbrowser" |
37 | git://codereview.qt-project.org/qt-apps/qtwebbrowser;branch=${BRANCH};protocol=http;sdk-uri=5.7/Src/qtwebbrowser \ | 38 | QT_MODULE_BRANCH = "dev" |
38 | " | ||
39 | 39 | ||
40 | SRCREV = "023733af5523a5ad84359926224fa106001215f4" | 40 | SRCREV = "023733af5523a5ad84359926224fa106001215f4" |
41 | BRANCH = "dev" | ||
42 | |||
43 | S = "${WORKDIR}/git" | ||
44 | 41 | ||
45 | DEPENDS = "qtbase qtdeclarative qtwebengine" | 42 | DEPENDS = "qtbase qtdeclarative qtwebengine" |
46 | 43 | ||