diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-05-09 05:48:35 +0000 |
---|---|---|
committer | The Qt Project <gerrit-noreply@qt-project.org> | 2016-05-09 05:48:35 +0000 |
commit | 00026e5b464499e7cc93425150c9f9060791c3a0 (patch) | |
tree | c28dc7e9e2c60ba37fd9e5b15bb48bd1262edcfd | |
parent | 86ce53afdeb5fbf863100231b83521bf34375930 (diff) | |
parent | 51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32 (diff) | |
download | meta-boot2qt-00026e5b464499e7cc93425150c9f9060791c3a0.tar.gz |
Merge "Merge remote-tracking branch 'origin/fido' into dev" into refs/staging/dev
-rw-r--r-- | classes/abi-arch.bbclass | 41 | ||||
-rw-r--r-- | classes/populate_b2qt_qt5_sdk.bbclass | 4 | ||||
-rw-r--r-- | conf/distro/include/colibri-vf.conf | 1 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 2 |
6 files changed, 47 insertions, 5 deletions
diff --git a/classes/abi-arch.bbclass b/classes/abi-arch.bbclass new file mode 100644 index 0000000..826fed4 --- /dev/null +++ b/classes/abi-arch.bbclass | |||
@@ -0,0 +1,41 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | # map target architecture to abi architectures used by Qt Creator | ||
23 | valid_archs = "arm x86 itanium mips ppc sh" | ||
24 | |||
25 | def map_abi_arch(a, d): | ||
26 | import re | ||
27 | |||
28 | valid_archs = d.getVar('valid_archs', True).split() | ||
29 | |||
30 | if re.match('i.86$', a): return 'x86' | ||
31 | elif re.match('x86.64$', a): return 'x86' | ||
32 | elif re.match('armeb$', a): return 'arm' | ||
33 | elif re.match('aarch64', a): return 'arm' | ||
34 | elif re.match('mips(el|64|64el)$', a): return 'mips' | ||
35 | elif re.match('p(pc|owerpc)(|64)', a): return 'ppc' | ||
36 | elif re.match('sh(3|4)$', a): return 'sh' | ||
37 | elif a in valid_archs: return a | ||
38 | else: | ||
39 | bb.error("cannot map '%s' to a abi architecture" % a) | ||
40 | |||
41 | ABI = "${@map_abi_arch(d.getVar('TARGET_ARCH', True), d)}" | ||
diff --git a/classes/populate_b2qt_qt5_sdk.bbclass b/classes/populate_b2qt_qt5_sdk.bbclass index d6b2b10..ae88685 100644 --- a/classes/populate_b2qt_qt5_sdk.bbclass +++ b/classes/populate_b2qt_qt5_sdk.bbclass | |||
@@ -19,7 +19,7 @@ | |||
19 | ## | 19 | ## |
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | inherit populate_b2qt_sdk populate_sdk_qt5_base | 22 | inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo |
23 | 23 | ||
24 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" | 24 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" |
25 | SDK_MKSPEC = "devices/linux-oe-generic-g++" | 25 | SDK_MKSPEC = "devices/linux-oe-generic-g++" |
@@ -65,7 +65,7 @@ create_qtcreator_configure_script () { | |||
65 | # add qtcreator configuration script | 65 | # add qtcreator configuration script |
66 | install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH} | 66 | install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH} |
67 | sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh | 67 | sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh |
68 | sed -i -e '/^ABI=/c\ABI="${ARCH}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh | 68 | sed -i -e '/^ABI=/c\ABI="${ABI}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh |
69 | } | 69 | } |
70 | 70 | ||
71 | create_qtcreator_configure_script_mingw32 () { | 71 | create_qtcreator_configure_script_mingw32 () { |
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf index 0d31f99..6512f2b 100644 --- a/conf/distro/include/colibri-vf.conf +++ b/conf/distro/include/colibri-vf.conf | |||
@@ -24,6 +24,7 @@ include conf/distro/include/toradex.inc | |||
24 | DEPLOY_CONF_NAME = "Toradex Colibri VF" | 24 | DEPLOY_CONF_NAME = "Toradex Colibri VF" |
25 | 25 | ||
26 | IMAGE_FSTYPES += "ext3 sdcard" | 26 | IMAGE_FSTYPES += "ext3 sdcard" |
27 | IMAGE_ROOTFS_ALIGNMENT_colibri-vf = "1024" | ||
27 | 28 | ||
28 | BOOTFS_CONTENT = "\ | 29 | BOOTFS_CONTENT = "\ |
29 | u-boot-${MACHINE}.imx:u-boot.imx \ | 30 | u-boot-${MACHINE}.imx:u-boot.imx \ |
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index 702ca90..5f8d9cf 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -26,7 +26,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" | |||
26 | inherit qt5-module sdk-sources systemd | 26 | inherit qt5-module sdk-sources systemd |
27 | 27 | ||
28 | SRC_URI = " \ | 28 | SRC_URI = " \ |
29 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/neptune-ui \ | 29 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh \ |
30 | file://neptune.service \ | 30 | file://neptune.service \ |
31 | " | 31 | " |
32 | 32 | ||
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index 240fedc..db16275 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -26,7 +26,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" | |||
26 | inherit qmake5 sdk-sources | 26 | inherit qmake5 sdk-sources |
27 | 27 | ||
28 | SRC_URI = " \ | 28 | SRC_URI = " \ |
29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/qtapplicationmanager \ | 29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \ |
30 | " | 30 | " |
31 | 31 | ||
32 | SRCREV = "97530155847257102fe0a159c681857fb9eb1194" | 32 | SRCREV = "97530155847257102fe0a159c681857fb9eb1194" |
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index 9149c76..88990de 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -30,7 +30,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | |||
30 | inherit qt5-module sdk-sources | 30 | inherit qt5-module sdk-sources |
31 | 31 | ||
32 | SRC_URI = " \ | 32 | SRC_URI = " \ |
33 | git://codereview.qt-project.org/qt/tqtc-qtivi;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/qtivi \ | 33 | git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \ |
34 | " | 34 | " |
35 | 35 | ||
36 | SRCREV = "b850b82e70e9585097ceb2812002bb4a7ddba06f" | 36 | SRCREV = "b850b82e70e9585097ceb2812002bb4a7ddba06f" |