diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-01-18 12:03:15 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-01-19 07:18:35 +0000 |
commit | 29bf06b9b89c600c6de8a33c1e60b5b946e51a1e (patch) | |
tree | 6ba1ade5c4b52ce1affc1469a4e3ccfc37969373 | |
parent | a9d2dc2ab5ce8bef1dfd4c9844f215511048aa09 (diff) | |
download | meta-boot2qt-29bf06b9b89c600c6de8a33c1e60b5b946e51a1e.tar.gz |
ninja-native: add recipe from meta-qt5
ninja-native was removed from meta-qt5 and it was moved to meta-oe
(master and jethro). We are still using fido, so we need to add the
recipe here.
Change-Id: Ia77030d189b5c1112391d3e537feeea52fc0ab8d
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r-- | recipes/ninja/ninja-native_git.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ninja/ninja-native_git.bb b/recipes/ninja/ninja-native_git.bb new file mode 100644 index 0000000..e2deb6b --- /dev/null +++ b/recipes/ninja/ninja-native_git.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "Ninja is a small build system with a focus on speed." | ||
2 | LICENSE = "Apache-2" | ||
3 | |||
4 | inherit native | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" | ||
7 | |||
8 | PV = "1.5.3+gitr${SRCPV}" | ||
9 | SRCREV="3309498174411e02e7680ea8b470bb7d1d70bdb8" | ||
10 | SRCBRANCH="release" | ||
11 | |||
12 | SRC_URI = "git://github.com/martine/ninja.git;branch=${SRCBRANCH}" | ||
13 | |||
14 | S="${WORKDIR}/git" | ||
15 | |||
16 | do_compile() { | ||
17 | python ${S}/bootstrap.py | ||
18 | } | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${bindir} | ||
22 | install -m 0755 ${S}/ninja ${D}${bindir}/ninja | ||
23 | } | ||