diff options
author | Gatis Paeglis <gatis.paeglis@qt.io> | 2016-06-07 15:48:17 +0200 |
---|---|---|
committer | Gatis Paeglis <gatis.paeglis@qt.io> | 2016-06-08 10:17:44 +0000 |
commit | d395b7e22218b742f2e28b292f2c0a29a6ab630a (patch) | |
tree | 2a32ee6c32c7312afcf4981b3b2f8cced317bca0 | |
parent | 4226b6fa6410daa102b09d7ecf46f84ad745c21d (diff) | |
download | meta-boot2qt-d395b7e22218b742f2e28b292f2c0a29a6ab630a.tar.gz |
Add b2qt-ota recipe.
Change-Id: I002067b938fa19cb35fa62db700cde2cc9ad7922
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
4 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-ota.bb b/recipes-qt/b2qt-addons/b2qt-ota.bb new file mode 100644 index 0000000..9c5929c --- /dev/null +++ b/recipes-qt/b2qt-addons/b2qt-ota.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | ## This file is part of the Boot to Qt meta layer. | ||
2 | ## | ||
3 | ## $QT_BEGIN_LICENSE:GPL$ | ||
4 | ## Commercial License Usage | ||
5 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
6 | ## accordance with the commercial license agreement provided with the | ||
7 | ## Software or, alternatively, in accordance with the terms contained in | ||
8 | ## a written agreement between you and The Qt Company. For licensing terms | ||
9 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
10 | ## information use the contact form at https://www.qt.io/contact-us. | ||
11 | ## | ||
12 | ## GNU General Public License Usage | ||
13 | ## Alternatively, this file may be used under the terms of the GNU | ||
14 | ## General Public License version 3 or (at your option) any later version | ||
15 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
16 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
17 | ## included in the packaging of this file. Please review the following | ||
18 | ## information to ensure the GNU General Public License requirements will | ||
19 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
20 | ## | ||
21 | ## $QT_END_LICENSE$ | ||
22 | ## | ||
23 | ############################################################################ | ||
24 | |||
25 | DESCRIPTION = "Qt OTA Update module" | ||
26 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
27 | LIC_FILES_CHKSUM = "file://src/lib/qotaclient.h;md5=da66cc6e520f8151501c0f6c11480077;beginline=1;endline=28" | ||
28 | |||
29 | inherit qt5-module | ||
30 | |||
31 | SRC_URI = " \ | ||
32 | git://codereview.qt-project.org/tqtc-boot2qt/ota;branch=${BRANCH};protocol=ssh \ | ||
33 | " | ||
34 | |||
35 | SRCREV = "d8d81530692454e4e38f682f6a09049d27b8c1ad" | ||
36 | BRANCH = "master" | ||
37 | PV = "git${SRCPV}" | ||
38 | |||
39 | S = "${WORKDIR}/git" | ||
40 | |||
41 | DEPENDS = "qtbase qtdeclarative" | ||
42 | RDEPENDS_${PN} = "ostree" | ||
43 | |||
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb index afe7485..aee96d9 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb | |||
@@ -37,6 +37,7 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" | |||
37 | RDEPENDS_${PN} += " \ | 37 | RDEPENDS_${PN} += " \ |
38 | b2qt-appcontroller \ | 38 | b2qt-appcontroller \ |
39 | b2qt-utils \ | 39 | b2qt-utils \ |
40 | b2qt-ota \ | ||
40 | qtivi \ | 41 | qtivi \ |
41 | neptune-ui \ | 42 | neptune-ui \ |
42 | neptune-ui-apps \ | 43 | neptune-ui-apps \ |
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb index 9c2008d..ff2d206 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb | |||
@@ -37,6 +37,7 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" | |||
37 | RDEPENDS_${PN} += " \ | 37 | RDEPENDS_${PN} += " \ |
38 | b2qt-appcontroller \ | 38 | b2qt-appcontroller \ |
39 | b2qt-utils \ | 39 | b2qt-utils \ |
40 | b2qt-ota \ | ||
40 | b2qt-launcher \ | 41 | b2qt-launcher \ |
41 | b2qt-demos \ | 42 | b2qt-demos \ |
42 | ${@base_contains("DISTRO_FEATURES", "wayland", "democompositor", "", d)} \ | 43 | ${@base_contains("DISTRO_FEATURES", "wayland", "democompositor", "", d)} \ |
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb index cd1f2d8..5286ac5 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb | |||
@@ -68,6 +68,7 @@ RDEPENDS_${PN} += " \ | |||
68 | qtxmlpatterns-dev \ | 68 | qtxmlpatterns-dev \ |
69 | \ | 69 | \ |
70 | b2qt-utils-dev \ | 70 | b2qt-utils-dev \ |
71 | b2qt-ota-dev \ | ||
71 | qtcharts-dev \ | 72 | qtcharts-dev \ |
72 | qtdatavis3d-dev \ | 73 | qtdatavis3d-dev \ |
73 | qtvirtualkeyboard-dev \ | 74 | qtvirtualkeyboard-dev \ |