summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
commit51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32 (patch)
treeb57ff35bf91a67fc0d6c3eb7831ed82f5f575c47
parent61d552148d797866ed33a9cd5e56477873cf801d (diff)
parente3ef984ac6f5926d7a910eff33bafeb5da6c2ff0 (diff)
downloadmeta-boot2qt-51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32.tar.gz
Merge remote-tracking branch 'origin/fido' into dev
* origin/fido: automotive: update src uris after repos were opened colibri-vf: change partition alignment to 1M Make ABI selection more robust in configure-qtcreator.sh Conflicts: recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/automotive/qtivi_git.bb Change-Id: I86763619f24b40e9ac62a8c1ae84acf4ffeb4be7
-rw-r--r--classes/abi-arch.bbclass41
-rw-r--r--classes/populate_b2qt_qt5_sdk.bbclass4
-rw-r--r--conf/distro/include/colibri-vf.conf1
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb2
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--recipes-qt/automotive/qtivi_git.bb2
6 files changed, 47 insertions, 5 deletions
diff --git a/classes/abi-arch.bbclass b/classes/abi-arch.bbclass
new file mode 100644
index 0000000..826fed4
--- /dev/null
+++ b/classes/abi-arch.bbclass
@@ -0,0 +1,41 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# map target architecture to abi architectures used by Qt Creator
23valid_archs = "arm x86 itanium mips ppc sh"
24
25def map_abi_arch(a, d):
26 import re
27
28 valid_archs = d.getVar('valid_archs', True).split()
29
30 if re.match('i.86$', a): return 'x86'
31 elif re.match('x86.64$', a): return 'x86'
32 elif re.match('armeb$', a): return 'arm'
33 elif re.match('aarch64', a): return 'arm'
34 elif re.match('mips(el|64|64el)$', a): return 'mips'
35 elif re.match('p(pc|owerpc)(|64)', a): return 'ppc'
36 elif re.match('sh(3|4)$', a): return 'sh'
37 elif a in valid_archs: return a
38 else:
39 bb.error("cannot map '%s' to a abi architecture" % a)
40
41ABI = "${@map_abi_arch(d.getVar('TARGET_ARCH', True), d)}"
diff --git a/classes/populate_b2qt_qt5_sdk.bbclass b/classes/populate_b2qt_qt5_sdk.bbclass
index d6b2b10..ae88685 100644
--- a/classes/populate_b2qt_qt5_sdk.bbclass
+++ b/classes/populate_b2qt_qt5_sdk.bbclass
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22inherit populate_b2qt_sdk populate_sdk_qt5_base 22inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo
23 23
24SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" 24SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs"
25SDK_MKSPEC = "devices/linux-oe-generic-g++" 25SDK_MKSPEC = "devices/linux-oe-generic-g++"
@@ -65,7 +65,7 @@ create_qtcreator_configure_script () {
65 # add qtcreator configuration script 65 # add qtcreator configuration script
66 install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH} 66 install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH}
67 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 67 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
68 sed -i -e '/^ABI=/c\ABI="${ARCH}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 68 sed -i -e '/^ABI=/c\ABI="${ABI}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
69} 69}
70 70
71create_qtcreator_configure_script_mingw32 () { 71create_qtcreator_configure_script_mingw32 () {
diff --git a/conf/distro/include/colibri-vf.conf b/conf/distro/include/colibri-vf.conf
index 0d31f99..6512f2b 100644
--- a/conf/distro/include/colibri-vf.conf
+++ b/conf/distro/include/colibri-vf.conf
@@ -24,6 +24,7 @@ include conf/distro/include/toradex.inc
24DEPLOY_CONF_NAME = "Toradex Colibri VF" 24DEPLOY_CONF_NAME = "Toradex Colibri VF"
25 25
26IMAGE_FSTYPES += "ext3 sdcard" 26IMAGE_FSTYPES += "ext3 sdcard"
27IMAGE_ROOTFS_ALIGNMENT_colibri-vf = "1024"
27 28
28BOOTFS_CONTENT = "\ 29BOOTFS_CONTENT = "\
29 u-boot-${MACHINE}.imx:u-boot.imx \ 30 u-boot-${MACHINE}.imx:u-boot.imx \
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index 702ca90..5f8d9cf 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -26,7 +26,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c"
26inherit qt5-module sdk-sources systemd 26inherit qt5-module sdk-sources systemd
27 27
28SRC_URI = " \ 28SRC_URI = " \
29 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/neptune-ui \ 29 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh \
30 file://neptune.service \ 30 file://neptune.service \
31 " 31 "
32 32
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index 240fedc..db16275 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -26,7 +26,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
26inherit qmake5 sdk-sources 26inherit qmake5 sdk-sources
27 27
28SRC_URI = " \ 28SRC_URI = " \
29 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/qtapplicationmanager \ 29 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
30 " 30 "
31 31
32SRCREV = "97530155847257102fe0a159c681857fb9eb1194" 32SRCREV = "97530155847257102fe0a159c681857fb9eb1194"
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 9149c76..88990de 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -30,7 +30,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
30inherit qt5-module sdk-sources 30inherit qt5-module sdk-sources
31 31
32SRC_URI = " \ 32SRC_URI = " \
33 git://codereview.qt-project.org/qt/tqtc-qtivi;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/qtivi \ 33 git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \
34 " 34 "
35 35
36SRCREV = "b850b82e70e9585097ceb2812002bb4a7ddba06f" 36SRCREV = "b850b82e70e9585097ceb2812002bb4a7ddba06f"