diff options
author | David Schulz <david.schulz@theqtcompany.com> | 2015-07-16 11:52:06 +0300 |
---|---|---|
committer | David Schulz <david.schulz@theqtcompany.com> | 2016-01-14 13:23:52 +0000 |
commit | fec77245682bfd988a3fd1456488b4455acb272e (patch) | |
tree | b115e5dd26e7037ca22ce207ec8254ea72a21870 | |
parent | 6f58d7d2708fbdb3ce633e7234cd5f12cdb57c7d (diff) | |
download | meta-boot2qt-fec77245682bfd988a3fd1456488b4455acb272e.tar.gz |
Fix up toolchain packaging for Windows hosts
Change-Id: Idb7af9308e702b4ef5f26e6423cfa270f8c036e5
Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r-- | classes/populate_b2qt_sdk.bbclass | 46 | ||||
-rw-r--r-- | recipes-qt/meta/b2qt-sdk.inc | 2 | ||||
-rw-r--r-- | recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb | 3 |
3 files changed, 48 insertions, 3 deletions
diff --git a/classes/populate_b2qt_sdk.bbclass b/classes/populate_b2qt_sdk.bbclass new file mode 100644 index 0000000..54322b4 --- /dev/null +++ b/classes/populate_b2qt_sdk.bbclass | |||
@@ -0,0 +1,46 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | inherit populate_sdk | ||
24 | |||
25 | DEPENDS_sdkmingw32 += "gzip-native" | ||
26 | |||
27 | POPULATE_SDK_POST_HOST_COMMAND_append_sdkmingw32 = " replace_host_symlink;" | ||
28 | |||
29 | replace_host_symlink() { | ||
30 | for SOURCE in `find ${SDK_OUTPUT}/${SDKPATHNATIVE} -type l` | ||
31 | do | ||
32 | TARGET=`readlink -f "${SOURCE}"` | ||
33 | if [ -e ${TARGET} ]; then | ||
34 | rm "${SOURCE}" | ||
35 | cp -f "${TARGET}" "${SOURCE}" | ||
36 | fi | ||
37 | done | ||
38 | } | ||
39 | |||
40 | fakeroot tar_sdk_sdkmingw32() { | ||
41 | # Package it up | ||
42 | mkdir -p ${SDK_DEPLOY} | ||
43 | cd ${SDK_OUTPUT}/${SDKPATH} | ||
44 | zip -r ${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.zip sysroots | ||
45 | } | ||
46 | |||
diff --git a/recipes-qt/meta/b2qt-sdk.inc b/recipes-qt/meta/b2qt-sdk.inc index 9eddadc..87ceb96 100644 --- a/recipes-qt/meta/b2qt-sdk.inc +++ b/recipes-qt/meta/b2qt-sdk.inc | |||
@@ -23,7 +23,7 @@ | |||
23 | LICENSE = "QtEnterprise" | 23 | LICENSE = "QtEnterprise" |
24 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" | 24 | LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9" |
25 | 25 | ||
26 | inherit populate_sdk populate_sdk_qt5_base | 26 | inherit populate_b2qt_sdk populate_sdk_qt5_base |
27 | 27 | ||
28 | SRC_URI = " \ | 28 | SRC_URI = " \ |
29 | file://qmake.conf \ | 29 | file://qmake.conf \ |
diff --git a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb index 3f13aef..fab2c25 100644 --- a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb +++ b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb | |||
@@ -24,9 +24,8 @@ DESCRIPTION = "B2Qt on embedded Linux SDK toolchain" | |||
24 | PR = "r0" | 24 | PR = "r0" |
25 | LICENSE = "CLOSED" | 25 | LICENSE = "CLOSED" |
26 | 26 | ||
27 | inherit populate_sdk | 27 | inherit populate_b2qt_sdk |
28 | 28 | ||
29 | TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${MACHINE}" | 29 | TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${MACHINE}" |
30 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-toolchain-target" | 30 | TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-toolchain-target" |
31 | 31 | ||
32 | |||