diff options
author | Andy Nichols <andy.nichols@theqtcompany.com> | 2015-03-11 12:52:33 +0100 |
---|---|---|
committer | Andy Nichols <andy.nichols@theqtcompany.com> | 2015-05-12 14:39:58 +0300 |
commit | 58b688071999ee2f9a5a72d217351cfd97f45123 (patch) | |
tree | 2a83fc2e541768d6016f2320dbec38a5417453d2 | |
parent | 2b8c1028d8859d391a2c0edf08d044dfead7b3ff (diff) | |
download | meta-boot2qt-58b688071999ee2f9a5a72d217351cfd97f45123.tar.gz |
Add support for Toradex Colibri iMX6
Uses Colibri form factor instead of Apalis.
Change-Id: I7ba54323a82b151ce174f06477851523b283297b
Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
5 files changed, 87 insertions, 2 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index cb40b6b..c61e0c6 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -85,7 +85,7 @@ get_groups() { | |||
85 | all) | 85 | all) |
86 | PROJECT_GROUPS="all" | 86 | PROJECT_GROUPS="all" |
87 | ;; | 87 | ;; |
88 | apalis-imx6|colibri-vf) | 88 | apalis-imx6|colibri-imx6|colibri-vf) |
89 | PROJECT_GROUPS="toradex" | 89 | PROJECT_GROUPS="toradex" |
90 | ;; | 90 | ;; |
91 | imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x) | 91 | imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x) |
diff --git a/conf/distro/include/colibri-imx6.conf b/conf/distro/include/colibri-imx6.conf new file mode 100644 index 0000000..1171c5f --- /dev/null +++ b/conf/distro/include/colibri-imx6.conf | |||
@@ -0,0 +1,47 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | include conf/distro/include/toradex.inc | ||
24 | |||
25 | KERNEL_IMAGETYPE = "uImage" | ||
26 | |||
27 | BOOTFS_CONTENT = "\ | ||
28 | ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \ | ||
29 | ${KERNEL_IMAGETYPE}-${KERNEL_DEVICETREE}:${KERNEL_DEVICETREE} \ | ||
30 | u-boot-${MACHINE}.imx:u-boot.imx \ | ||
31 | " | ||
32 | BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy" | ||
33 | |||
34 | MACHINE_EXTRA_INSTALL = "\ | ||
35 | libgal-mx6 \ | ||
36 | libegl-mx6 \ | ||
37 | libgles2-mx6 \ | ||
38 | gst-fsl-plugin \ | ||
39 | " | ||
40 | |||
41 | MACHINE_EXTRA_INSTALL_SDK = " \ | ||
42 | libgal-mx6 \ | ||
43 | libegl-mx6 \ | ||
44 | libegl-mx6-dev \ | ||
45 | libgles2-mx6 \ | ||
46 | libgles2-mx6-dev \ | ||
47 | " | ||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch b/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch new file mode 100644 index 0000000..719a38d --- /dev/null +++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl/0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 7515eb259a380578540323be5d4913245e81c454 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@theqtcompany.com> | ||
3 | Date: Mon, 13 Apr 2015 12:54:17 +0200 | ||
4 | Subject: [PATCH] Colibri-iMX6: set 1280x720@16 for HDMI by default | ||
5 | |||
6 | --- | ||
7 | arch/arm/boot/dts/imx6qdl-colibri.dtsi | 7 +++---- | ||
8 | 1 file changed, 3 insertions(+), 4 deletions(-) | ||
9 | |||
10 | diff --git a/arch/arm/boot/dts/imx6qdl-colibri.dtsi b/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
11 | index e638266..dd8b21fc5 100644 | ||
12 | --- a/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
13 | +++ b/arch/arm/boot/dts/imx6qdl-colibri.dtsi | ||
14 | @@ -70,12 +70,11 @@ | ||
15 | compatible = "fsl,mxc_sdc_fb"; | ||
16 | disp_dev = "hdmi"; | ||
17 | interface_pix_fmt = "RGB24"; | ||
18 | - mode_str ="1920x1080M@60"; | ||
19 | -/* default_bpp = <16>;*/ | ||
20 | - default_bpp = <24>; | ||
21 | + mode_str ="1280x729M@60"; | ||
22 | + default_bpp = <16>; | ||
23 | int_clk = <0>; | ||
24 | late_init = <0>; | ||
25 | - status = "disabled"; | ||
26 | + status = "okay"; | ||
27 | }; | ||
28 | |||
29 | mxcfb2: fb@1 { | ||
30 | -- | ||
31 | 2.3.5 | ||
32 | |||
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend index 68cdfc2..5de3f19 100644 --- a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend +++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend | |||
@@ -26,6 +26,12 @@ SRC_URI += "\ | |||
26 | file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \ | 26 | file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \ |
27 | " | 27 | " |
28 | 28 | ||
29 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
30 | |||
31 | SRC_URI += " \ | ||
32 | file://0001-Colibri-iMX6-set-1280x720-16-for-HDMI-by-default.patch \ | ||
33 | " | ||
34 | |||
29 | # kernel image files are not needed in the image | 35 | # kernel image files are not needed in the image |
30 | RDEPENDS_kernel-base = "" | 36 | RDEPENDS_kernel-base = "" |
31 | 37 | ||
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index 3439d90..26c374d 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -49,7 +49,7 @@ BUILDDIRECTORY=${BUILDDIRECTORY:-build-${MACHINE}} | |||
49 | 49 | ||
50 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | 50 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then |
51 | case ${MACHINE} in | 51 | case ${MACHINE} in |
52 | apalis-imx6|colibri-vf) | 52 | apalis-imx6|colibri-imx6|colibri-vf) |
53 | LAYERSCONF="bblayers.conf.toradex.sample" | 53 | LAYERSCONF="bblayers.conf.toradex.sample" |
54 | ;; | 54 | ;; |
55 | imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x) | 55 | imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x) |