diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-01-25 15:20:23 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-01-26 14:27:15 +0000 |
commit | 6aca07601e166ab0654e4179c4d80b8e17b6cc0a (patch) | |
tree | 9392ff20f8444304df00ea9e660aaf185687b42a | |
parent | d98bd0735bbf4969154ed219d2827fd6e34c8c30 (diff) | |
download | meta-boot2qt-6aca07601e166ab0654e4179c4d80b8e17b6cc0a.tar.gz |
qbsp: fix replace tags
@TARGET@ was used twice for different things and other tags were used
with wrong content. Installer content now follows closer to the online
content.
Task-number: QTBUG-66010
Change-Id: I6a10f765fa582da2025134f268c6ee35b74ac8c6
Reviewed-by: Ilari Ängeslevä <ilari.angesleva@qt.io>
-rw-r--r-- | classes/qbsp.bbclass | 4 | ||||
-rw-r--r-- | files/qbsp/base_package.xml | 2 | ||||
-rw-r--r-- | files/qbsp/image_package.xml | 2 | ||||
-rw-r--r-- | files/qbsp/toolchain_installscript.qs | 17 | ||||
-rw-r--r-- | files/qbsp/toolchain_package.xml | 2 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | 2 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | 2 |
7 files changed, 16 insertions, 15 deletions
diff --git a/classes/qbsp.bbclass b/classes/qbsp.bbclass index 57aa7ca..8b8aa7f 100644 --- a/classes/qbsp.bbclass +++ b/classes/qbsp.bbclass | |||
@@ -57,7 +57,7 @@ QBSP_LICENSE_NAME ?= "" | |||
57 | QBSP_LICENSE_FILE_imx = "NXP-EULA" | 57 | QBSP_LICENSE_FILE_imx = "NXP-EULA" |
58 | QBSP_LICENSE_NAME_imx = "NXP Semiconductors Software License Agreement" | 58 | QBSP_LICENSE_NAME_imx = "NXP Semiconductors Software License Agreement" |
59 | 59 | ||
60 | VERSION_AUTO_INCREMENT = "-0-${DATETIME}" | 60 | VERSION_AUTO_INCREMENT = "-${DATETIME}" |
61 | VERSION_AUTO_INCREMENT[vardepsexclude] = "DATETIME" | 61 | VERSION_AUTO_INCREMENT[vardepsexclude] = "DATETIME" |
62 | 62 | ||
63 | DEPLOY_CONF_NAME ?= "${MACHINE}" | 63 | DEPLOY_CONF_NAME ?= "${MACHINE}" |
@@ -84,7 +84,7 @@ patch_installer_files() { | |||
84 | -e "s#@RELEASEDATE@#${RELEASEDATE}#" \ | 84 | -e "s#@RELEASEDATE@#${RELEASEDATE}#" \ |
85 | -e "s#@MACHINE@#${MACHINE}#" \ | 85 | -e "s#@MACHINE@#${MACHINE}#" \ |
86 | -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \ | 86 | -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \ |
87 | -e "s#@TARGET@#${TARGET_SYS}#" \ | 87 | -e "s#@TARGET_SYS@#${TARGET_SYS}#" \ |
88 | -e "s#@ABI@#${ABI}#" \ | 88 | -e "s#@ABI@#${ABI}#" \ |
89 | -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \ | 89 | -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \ |
90 | -e "s#@SDKPATH@#${SDKPATH}#" \ | 90 | -e "s#@SDKPATH@#${SDKPATH}#" \ |
diff --git a/files/qbsp/base_package.xml b/files/qbsp/base_package.xml index 80a02e8..5f16dfa 100644 --- a/files/qbsp/base_package.xml +++ b/files/qbsp/base_package.xml | |||
@@ -2,7 +2,7 @@ | |||
2 | <Package> | 2 | <Package> |
3 | <Version>@VERSION@</Version> | 3 | <Version>@VERSION@</Version> |
4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> | 4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> |
5 | <DisplayName>@NAME@</DisplayName> | 5 | <DisplayName>@TARGET@</DisplayName> |
6 | <Description>@NAME@ for @TARGET@</Description> | 6 | <Description>@NAME@ for @TARGET@</Description> |
7 | <Dependencies>@LICENSEDEPENDENCY@</Dependencies> | 7 | <Dependencies>@LICENSEDEPENDENCY@</Dependencies> |
8 | </Package> | 8 | </Package> |
diff --git a/files/qbsp/image_package.xml b/files/qbsp/image_package.xml index a3fe0cc..27e5f2e 100644 --- a/files/qbsp/image_package.xml +++ b/files/qbsp/image_package.xml | |||
@@ -2,7 +2,7 @@ | |||
2 | <Package> | 2 | <Package> |
3 | <Version>@VERSION@</Version> | 3 | <Version>@VERSION@</Version> |
4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> | 4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> |
5 | <DisplayName>@MACHINE@ Linux System</DisplayName> | 5 | <DisplayName>@TARGET@ Linux System</DisplayName> |
6 | <Description>System image for @TARGET@ hardware</Description> | 6 | <Description>System image for @TARGET@ hardware</Description> |
7 | <DownloadableArchives>image.7z</DownloadableArchives> | 7 | <DownloadableArchives>image.7z</DownloadableArchives> |
8 | </Package> | 8 | </Package> |
diff --git a/files/qbsp/toolchain_installscript.qs b/files/qbsp/toolchain_installscript.qs index 15e9570..4afab71 100644 --- a/files/qbsp/toolchain_installscript.qs +++ b/files/qbsp/toolchain_installscript.qs | |||
@@ -38,6 +38,7 @@ Component.prototype.createOperations = function() | |||
38 | var device = "@MACHINE@" | 38 | var device = "@MACHINE@" |
39 | var platform = "@NAME@" | 39 | var platform = "@NAME@" |
40 | var sysroot = "@SYSROOT@" | 40 | var sysroot = "@SYSROOT@" |
41 | var target_sys = "@TARGET_SYS@" | ||
41 | var target = "@TARGET@" | 42 | var target = "@TARGET@" |
42 | var abi = "@ABI@" | 43 | var abi = "@ABI@" |
43 | var installPath = "@INSTALLPATH@/toolchain" | 44 | var installPath = "@INSTALLPATH@/toolchain" |
@@ -71,8 +72,8 @@ Component.prototype.createOperations = function() | |||
71 | component.addOperation("Execute", | 72 | component.addOperation("Execute", |
72 | ["@SDKToolBinary@", "addTC", | 73 | ["@SDKToolBinary@", "addTC", |
73 | "--id", toolchainId + ".gcc", | 74 | "--id", toolchainId + ".gcc", |
74 | "--name", "GCC (Boot2Qt " + platform + ")", | 75 | "--name", "GCC (" + platform + " " + target + ")", |
75 | "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-gcc" + executableExt, | 76 | "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-gcc" + executableExt, |
76 | "--abi", abi, | 77 | "--abi", abi, |
77 | "--language", "1", | 78 | "--language", "1", |
78 | "UNDOEXECUTE", | 79 | "UNDOEXECUTE", |
@@ -81,8 +82,8 @@ Component.prototype.createOperations = function() | |||
81 | component.addOperation("Execute", | 82 | component.addOperation("Execute", |
82 | ["@SDKToolBinary@", "addTC", | 83 | ["@SDKToolBinary@", "addTC", |
83 | "--id", toolchainId + ".g++", | 84 | "--id", toolchainId + ".g++", |
84 | "--name", "G++ (Boot2Qt " + platform + ")", | 85 | "--name", "G++ (" + platform + " " + target + ")", |
85 | "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-g++" + executableExt, | 86 | "--path", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-g++" + executableExt, |
86 | "--abi", abi, | 87 | "--abi", abi, |
87 | "--language", "2", | 88 | "--language", "2", |
88 | "UNDOEXECUTE", | 89 | "UNDOEXECUTE", |
@@ -91,9 +92,9 @@ Component.prototype.createOperations = function() | |||
91 | component.addOperation("Execute", | 92 | component.addOperation("Execute", |
92 | ["@SDKToolBinary@", "addDebugger", | 93 | ["@SDKToolBinary@", "addDebugger", |
93 | "--id", debuggerId, | 94 | "--id", debuggerId, |
94 | "--name", "GDB (Boot2Qt " + platform + ")", | 95 | "--name", "GDB (" + platform + " " + target + ")", |
95 | "--engine", "1", | 96 | "--engine", "1", |
96 | "--binary", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target + "/" + target + "-gdb" + executableExt, | 97 | "--binary", path + "/sysroots/" + hostSysroot + "/usr/bin/" + target_sys + "/" + target_sys + "-gdb" + executableExt, |
97 | "--abis", abi, | 98 | "--abis", abi, |
98 | "UNDOEXECUTE", | 99 | "UNDOEXECUTE", |
99 | "@SDKToolBinary@", "rmDebugger", "--id", debuggerId]); | 100 | "@SDKToolBinary@", "rmDebugger", "--id", debuggerId]); |
@@ -101,7 +102,7 @@ Component.prototype.createOperations = function() | |||
101 | component.addOperation("Execute", | 102 | component.addOperation("Execute", |
102 | ["@SDKToolBinary@", "addQt", | 103 | ["@SDKToolBinary@", "addQt", |
103 | "--id", qtId, | 104 | "--id", qtId, |
104 | "--name", "Boot2Qt %{Qt:Version} " + platform, | 105 | "--name", platform + " " + target, |
105 | "--type", "Qdb.EmbeddedLinuxQt", | 106 | "--type", "Qdb.EmbeddedLinuxQt", |
106 | "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt, | 107 | "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt, |
107 | "UNDOEXECUTE", | 108 | "UNDOEXECUTE", |
@@ -110,7 +111,7 @@ Component.prototype.createOperations = function() | |||
110 | component.addOperation("Execute", | 111 | component.addOperation("Execute", |
111 | ["@SDKToolBinary@", "addKit", | 112 | ["@SDKToolBinary@", "addKit", |
112 | "--id", basecomponent, | 113 | "--id", basecomponent, |
113 | "--name", "Boot2Qt %{Qt:Version} " + platform, | 114 | "--name", platform + " " + target, |
114 | "--mkspec", "devices/linux-oe-generic-g++", | 115 | "--mkspec", "devices/linux-oe-generic-g++", |
115 | "--qt", qtId, | 116 | "--qt", qtId, |
116 | "--debuggerid", debuggerId, | 117 | "--debuggerid", debuggerId, |
diff --git a/files/qbsp/toolchain_package.xml b/files/qbsp/toolchain_package.xml index b578fc9..166e09b 100644 --- a/files/qbsp/toolchain_package.xml +++ b/files/qbsp/toolchain_package.xml | |||
@@ -2,7 +2,7 @@ | |||
2 | <Package> | 2 | <Package> |
3 | <Version>@VERSION@</Version> | 3 | <Version>@VERSION@</Version> |
4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> | 4 | <ReleaseDate>@RELEASEDATE@</ReleaseDate> |
5 | <DisplayName>@MACHINE@ Linux Toolchain</DisplayName> | 5 | <DisplayName>@TARGET@ Linux Toolchain</DisplayName> |
6 | <Description>Toolchain and system root for @TARGET@</Description> | 6 | <Description>Toolchain and system root for @TARGET@</Description> |
7 | <DownloadableArchives>toolchain.7z</DownloadableArchives> | 7 | <DownloadableArchives>toolchain.7z</DownloadableArchives> |
8 | <Dependencies>qt.tools.qtcreator</Dependencies> | 8 | <Dependencies>qt.tools.qtcreator</Dependencies> |
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb index a9da456..3752fc0 100644 --- a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | |||
@@ -40,7 +40,7 @@ inherit qbsp | |||
40 | 40 | ||
41 | PV := "${@d.getVar('PV', True)[0:5]}" | 41 | PV := "${@d.getVar('PV', True)[0:5]}" |
42 | 42 | ||
43 | QBSP_NAME = "Qt Automotive" | 43 | QBSP_NAME = "Automotive ${PV}" |
44 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" | 44 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" |
45 | QBSP_INSTALLER_COMPONENT = "automotive.10.yocto.${QBSP_MACHINE}" | 45 | QBSP_INSTALLER_COMPONENT = "automotive.10.yocto.${QBSP_MACHINE}" |
46 | QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" | 46 | QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}" |
diff --git a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb index d6def0f..1d0b018 100644 --- a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | |||
@@ -41,7 +41,7 @@ inherit qbsp | |||
41 | PV := "${@d.getVar('PV', True)[0:5]}" | 41 | PV := "${@d.getVar('PV', True)[0:5]}" |
42 | 42 | ||
43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" | 43 | VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}" |
44 | QBSP_NAME = "Boot to Qt" | 44 | QBSP_NAME = "Boot2Qt ${PV}" |
45 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" | 45 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" |
46 | QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" | 46 | QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" |
47 | QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" | 47 | QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}" |