diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-09-15 08:24:43 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-09-15 11:45:21 +0000 |
commit | 81831558b4dfdeb5030d6519f29d9ce122a434ce (patch) | |
tree | bd851a5b2f992ddded813f8cdcaf8bdf8e9a0bc7 | |
parent | 95440484a0fe59f19ae49edeaf32bcde5cdfc5bf (diff) | |
download | meta-boot2qt-81831558b4dfdeb5030d6519f29d9ce122a434ce.tar.gz |
sdk: fix host_build QT_ARCH
mkpecs/qconfig.pri defines QT_ARCH and QT_BUILDARCH separately
for host_build and target build and both of these were always
set to target architecture. This cause issues in the SDK, if
component tried to build host tools using these values, which
qtwebengine does.
Fixed now, so that the host_build variants are taken from the
nativesdk's mkspecs/qconfig.pri.
Task-number: QTBUG-63155
Change-Id: I44644c97d634dac6297e28cc851fc31f7eaf1f90
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | classes/populate_b2qt_qt5_sdk.bbclass | 9 | ||||
-rw-r--r-- | recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb | 1 |
2 files changed, 10 insertions, 0 deletions
diff --git a/classes/populate_b2qt_qt5_sdk.bbclass b/classes/populate_b2qt_qt5_sdk.bbclass index fd7b43c..453d94e 100644 --- a/classes/populate_b2qt_qt5_sdk.bbclass +++ b/classes/populate_b2qt_qt5_sdk.bbclass | |||
@@ -30,6 +30,7 @@ | |||
30 | inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo | 30 | inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo |
31 | 31 | ||
32 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" | 32 | SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs" |
33 | NATIVE_SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKPATHNATIVE}${libdir}/${QT_DIR_NAME}/mkspecs" | ||
33 | SDK_MKSPEC = "devices/linux-oe-generic-g++" | 34 | SDK_MKSPEC = "devices/linux-oe-generic-g++" |
34 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" | 35 | SDK_DEVICE_PRI = "${SDK_MKSPEC_DIR}/qdevice.pri" |
35 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" | 36 | SDK_DYNAMIC_FLAGS = "-O. -pipe -g" |
@@ -66,6 +67,14 @@ EOF | |||
66 | echo 'HostSpec = linux-g++' >> $qtconf | 67 | echo 'HostSpec = linux-g++' >> $qtconf |
67 | echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf | 68 | echo 'TargetSpec = devices/linux-oe-generic-g++' >> $qtconf |
68 | 69 | ||
70 | # Update correct host_build ARCH and ABI to mkspecs/qconfig.pri | ||
71 | QT_ARCH=$(grep QT_ARCH ${NATIVE_SDK_MKSPEC_DIR}/qconfig.pri | tail -1) | ||
72 | QT_BUILDABI=$(grep QT_BUILDABI ${NATIVE_SDK_MKSPEC_DIR}/qconfig.pri | tail -1) | ||
73 | |||
74 | sed -e "0,/QT_ARCH/s/^.*QT_ARCH.*/$QT_ARCH/" \ | ||
75 | -e "0,/QT_BUILDABI/s/^.*QT_BUILDABI.*/$QT_BUILDABI/" \ | ||
76 | -i ${SDK_MKSPEC_DIR}/qconfig.pri | ||
77 | |||
69 | create_qtcreator_configure_script | 78 | create_qtcreator_configure_script |
70 | 79 | ||
71 | # Link /etc/resolv.conf is broken in the toolchain sysroot, remove it | 80 | # Link /etc/resolv.conf is broken in the toolchain sysroot, remove it |
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb index a65435f..c3f07b8 100644 --- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb +++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb | |||
@@ -43,6 +43,7 @@ RDEPENDS_${PN} += "\ | |||
43 | nativesdk-packagegroup-b2qt-embedded-toolchain-host \ | 43 | nativesdk-packagegroup-b2qt-embedded-toolchain-host \ |
44 | nativesdk-qttools-tools \ | 44 | nativesdk-qttools-tools \ |
45 | nativesdk-qtbase-tools \ | 45 | nativesdk-qtbase-tools \ |
46 | nativesdk-qtbase-tools-dev \ | ||
46 | nativesdk-qtbase-tools-staticdev \ | 47 | nativesdk-qtbase-tools-staticdev \ |
47 | nativesdk-qtdeclarative-tools \ | 48 | nativesdk-qtdeclarative-tools \ |
48 | nativesdk-qtdeclarative-staticdev \ | 49 | nativesdk-qtdeclarative-staticdev \ |