diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-11-15 15:49:52 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-11-16 14:31:53 +0000 |
commit | 0af8477aaa48831eff9669466413266e8a26f98e (patch) | |
tree | a8a8b6dc8d853a5bf66fe2172440acbda7b12223 | |
parent | 6b82741249f9dff473dc9993ffaf9b13b5978ce2 (diff) | |
download | meta-boot2qt-0af8477aaa48831eff9669466413266e8a26f98e.tar.gz |
qbsp: update installer-framework
Use latest release from publicly available server.
Search files for QBSP_IMAGE_CONTENT from alternative locations.
Task-number: QTBUG-64522
Change-Id: I64fd9f28640db996d908dc74b48cf0f462d74b52
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | classes/qbsp-image.bbclass | 9 | ||||
-rw-r--r-- | recipes-qt/qt5-addons/installer-framework_3.0.1.bb (renamed from recipes-qt/qt5-addons/installer-framework_2.0.3.bb) | 10 |
2 files changed, 14 insertions, 5 deletions
diff --git a/classes/qbsp-image.bbclass b/classes/qbsp-image.bbclass index b8da767..71d1d45 100644 --- a/classes/qbsp-image.bbclass +++ b/classes/qbsp-image.bbclass | |||
@@ -42,7 +42,14 @@ fakeroot do_qbsp_image () { | |||
42 | src=`echo $item | awk -F':' '{ print $1 }'` | 42 | src=`echo $item | awk -F':' '{ print $1 }'` |
43 | dst=`echo $item | awk -F':' '{ print $2 }'` | 43 | dst=`echo $item | awk -F':' '{ print $2 }'` |
44 | 44 | ||
45 | install -D -m 0755 ${IMGDEPLOYDIR}/$src ${S}/qbsp/$dst | 45 | if [ -e "${IMGDEPLOYDIR}/$src" ]; then |
46 | install -D -m 0755 ${IMGDEPLOYDIR}/$src ${S}/qbsp/$dst | ||
47 | elif [ -e "${DEPLOY_DIR_IMAGE}/$src" ]; then | ||
48 | install -D -m 0755 ${DEPLOY_DIR_IMAGE}/$src ${S}/qbsp/$dst | ||
49 | else | ||
50 | echo "Could not copy file $src" | ||
51 | exit 1 | ||
52 | fi | ||
46 | done | 53 | done |
47 | 54 | ||
48 | cd ${S}/qbsp | 55 | cd ${S}/qbsp |
diff --git a/recipes-qt/qt5-addons/installer-framework_2.0.3.bb b/recipes-qt/qt5-addons/installer-framework_3.0.1.bb index 0ea0ec4..5bc09c0 100644 --- a/recipes-qt/qt5-addons/installer-framework_2.0.3.bb +++ b/recipes-qt/qt5-addons/installer-framework_3.0.1.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -33,10 +33,12 @@ LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | |||
33 | 33 | ||
34 | inherit bin_package native | 34 | inherit bin_package native |
35 | 35 | ||
36 | SRC_URI = "http://ci-files02-hki.intra.qt.io/packages/jenkins/opensource/ifw/installer-framework/installer-framework-build-stripped-linux-x64.7z" | 36 | do_unpack[depends] += "p7zip-native:do_populate_sysroot" |
37 | 37 | ||
38 | SRC_URI[md5sum] = "08beb5450c3938fcfd1b380f6aaec75d" | 38 | SRC_URI = "http://download.qt.io/development_releases/installer-framework/${PV}/installer-framework-build-stripped-${PV}-linux-x64.7z" |
39 | SRC_URI[sha256sum] = "91bfef896db58f28e4c2c6db437b958101a59e87aa880c38b6ddc40ebe6c38e6" | 39 | |
40 | SRC_URI[md5sum] = "68b7c1f761ca0dba18f1d165d66005d6" | ||
41 | SRC_URI[sha256sum] = "c2eb769351025e0c7df2882116390fffaf958368f873a2abab99e37caee0a498" | ||
40 | 42 | ||
41 | S = "${WORKDIR}/ifw-pkg" | 43 | S = "${WORKDIR}/ifw-pkg" |
42 | 44 | ||