diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-01-19 11:10:35 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-01-23 11:09:49 +0000 |
commit | b6695b047a17ed878f94501b7c326322be2f77bf (patch) | |
tree | d09e00bf07277147e33f169a955d850a19c602f8 | |
parent | d075186a68fc5fb55944e47dc9359064cac131be (diff) | |
download | meta-boot2qt-b6695b047a17ed878f94501b7c326322be2f77bf.tar.gz |
multiscreen-demo: update revision and fix startup
Update to latest revision. Don't use the provided start.sh script
as it's hardcoded for NVIDIA HW.
Task-number: AUTOSUITE-182
Change-Id: I1a7498da31ae49bec34426bee3af8517b7333fb4
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
3 files changed, 33 insertions, 6 deletions
diff --git a/recipes-qt/automotive/multiscreen-demo/automotivedemo.service b/recipes-qt/automotive/multiscreen-demo/automotivedemo.service new file mode 100644 index 0000000..af23213 --- /dev/null +++ b/recipes-qt/automotive/multiscreen-demo/automotivedemo.service | |||
@@ -0,0 +1,12 @@ | |||
1 | [Unit] | ||
2 | Description=AutomotiveDemo | ||
3 | After=dbus.service dbus-session.service systemd-user-sessions.service | ||
4 | Conflicts=neptune.service | ||
5 | |||
6 | [Service] | ||
7 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml | ||
8 | Restart=on-failure | ||
9 | WorkingDirectory=/opt/automotivedemo | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service b/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service new file mode 100644 index 0000000..1025cc1 --- /dev/null +++ b/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=AutomotiveDemo | ||
3 | After=dbus.service dbus-session.service systemd-user-sessions.service | ||
4 | Conflicts=neptune.service | ||
5 | |||
6 | [Service] | ||
7 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml | ||
8 | Restart=on-failure | ||
9 | WorkingDirectory=/opt/automotivedemo | ||
10 | Environment=QT_QPA_EGLFS_KMS_CONFIG=kms_config.json | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target | ||
diff --git a/recipes-qt/automotive/multiscreen-demo_git.bb b/recipes-qt/automotive/multiscreen-demo_git.bb index 0c9a2bb..7ce28b0 100644 --- a/recipes-qt/automotive/multiscreen-demo_git.bb +++ b/recipes-qt/automotive/multiscreen-demo_git.bb | |||
@@ -37,13 +37,15 @@ require recipes-qt/qt5/qt5-git.inc | |||
37 | QT_GIT = "git://code.qt.io/qt-apps" | 37 | QT_GIT = "git://code.qt.io/qt-apps" |
38 | QT_MODULE_BRANCH = "master" | 38 | QT_MODULE_BRANCH = "master" |
39 | 39 | ||
40 | SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets" | 40 | SRC_URI += "\ |
41 | git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets \ | ||
42 | file://automotivedemo.service \ | ||
43 | " | ||
41 | 44 | ||
42 | SRCREV_multiscreen = "f4cd6b9667b4649b4ef8b4bb645850b05aceebde" | 45 | SRCREV_multiscreen-demo = "e7126b85bacab4571da6d8b5ba8517f3bb0abd47" |
43 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" | 46 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" |
44 | 47 | ||
45 | SRCREV_FORMAT = "multiscreen_assets" | 48 | SRCREV_FORMAT = "multiscreen-demo_assets" |
46 | SRCREV = "${SRCREV_multiscreen}" | ||
47 | 49 | ||
48 | DEPENDS = "qtbase qtdeclarative qt3d" | 50 | DEPENDS = "qtbase qtdeclarative qt3d" |
49 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard" | 51 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard" |
@@ -51,10 +53,10 @@ RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard" | |||
51 | EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt" | 53 | EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt" |
52 | 54 | ||
53 | do_install_append() { | 55 | do_install_append() { |
54 | install -m 0755 ${S}/start.sh ${D}/opt/automotivedemo/ | 56 | rm ${D}/opt/automotivedemo/start.sh |
55 | 57 | ||
56 | install -d ${D}${systemd_system_unitdir} | 58 | install -d ${D}${systemd_system_unitdir} |
57 | install -m 0644 ${S}/scripts/automotivedemo.service ${D}${systemd_system_unitdir}/ | 59 | install -m 0644 ${WORKDIR}/automotivedemo.service ${D}${systemd_system_unitdir}/ |
58 | } | 60 | } |
59 | 61 | ||
60 | FILES_${PN} += "\ | 62 | FILES_${PN} += "\ |