diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-12-18 15:59:51 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-12-19 10:04:35 +0000 |
commit | d42593edfb649b07f426db6c82972eb1a5615058 (patch) | |
tree | 1d14e86ac651c32aeffb97cc6c5f4382b3d71cb0 | |
parent | 9fd509397d955ab32fa37d85cd42d8ac3d007ad7 (diff) | |
download | meta-boot2qt-d42593edfb649b07f426db6c82972eb1a5615058.tar.gz |
qtivi: enable ivigenerator for toolchain
Fix yocto build issues with nativesdk-qtivi and include
the ivigenerator to the toolchain.
ivigenerator is disabled for mingw build since it is using
the prebuild python binaries and doesn't work with virtualenv.
Task-number: AUTOSUITE-176
Change-Id: I4765652919649f4aafeb723127b0e75194325f92
Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 5 | ||||
-rw-r--r-- | recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb | 1 |
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index de12d54..f422b15 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -68,6 +68,9 @@ PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EX | |||
68 | 68 | ||
69 | PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" | 69 | PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" |
70 | PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" | 70 | PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" |
71 | PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only" | ||
72 | |||
73 | ALLOW_EMPTY_${PN}-tools = "1" | ||
71 | 74 | ||
72 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}" | 75 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}" |
73 | 76 | ||
@@ -90,3 +93,5 @@ do_install_prepend() { | |||
90 | BBCLASSEXTEND += "native nativesdk" | 93 | BBCLASSEXTEND += "native nativesdk" |
91 | 94 | ||
92 | INSANE_SKIP_${PN}_class-native = "already-stripped" | 95 | INSANE_SKIP_${PN}_class-native = "already-stripped" |
96 | INSANE_SKIP_${PN}_class-nativesdk = "already-stripped" | ||
97 | INSANE_SKIP_${PN}-tools_class-nativesdk = "staticdev" | ||
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb index acae372..1ba6d97 100644 --- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb +++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb | |||
@@ -36,4 +36,5 @@ inherit nativesdk packagegroup qtquickcompiler | |||
36 | RDEPENDS_${PN} += "\ | 36 | RDEPENDS_${PN} += "\ |
37 | nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \ | 37 | nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host \ |
38 | nativesdk-qtapplicationmanager-tools \ | 38 | nativesdk-qtapplicationmanager-tools \ |
39 | nativesdk-qtivi-tools \ | ||
39 | " | 40 | " |