diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-10-13 07:23:53 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-10-31 10:40:31 +0000 |
commit | 64b4b0cf3b062319c2d922576239e579c58c4151 (patch) | |
tree | b15df0d7e9dc179e090cabdb21ad373557d4c3e6 | |
parent | 05704da105a46e5b9f4523e715a4d3c7f754a535 (diff) | |
download | meta-boot2qt-64b4b0cf3b062319c2d922576239e579c58c4151.tar.gz |
hunspell: refactor recipe to hunspell-dicts
More recent hunspell (1.6.1) is available from meta-openembedded.
Use that instead, leaving here a new recipe that only installs
updated libreoffice 5.4.2 branch arabic & english dictionaries.
Change-Id: I9d1acbed47e00771145682eda08dbbf6c532adbf
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/qt5/qtvirtualkeyboard_git.bbappend | 1 | ||||
-rw-r--r-- | recipes/hunspell/hunspell-dicts.bb (renamed from recipes/hunspell/hunspell_1.3.2.bb) | 40 |
2 files changed, 20 insertions, 21 deletions
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend index 59fb06b..b7368ff 100644 --- a/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend +++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend | |||
@@ -30,3 +30,4 @@ | |||
30 | inherit qtquickcompiler | 30 | inherit qtquickcompiler |
31 | 31 | ||
32 | PACKAGECONFIG = "lipi-toolkit lang-all hunspell" | 32 | PACKAGECONFIG = "lipi-toolkit lang-all hunspell" |
33 | RDEPENDS_${PN} += "hunspell-dicts" | ||
diff --git a/recipes/hunspell/hunspell_1.3.2.bb b/recipes/hunspell/hunspell-dicts.bb index e47c9c1..92fd300 100644 --- a/recipes/hunspell/hunspell_1.3.2.bb +++ b/recipes/hunspell/hunspell-dicts.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -27,33 +27,31 @@ | |||
27 | ## | 27 | ## |
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | DESCRIPTION = "Hunspell" | 30 | DESCRIPTION = "Hunspell Dictionaries" |
31 | LICENSE = "LGPLv2" | ||
32 | LIC_FILES_CHKSUM = "file://${WORKDIR}/hunspell-${PV}/COPYING;md5=ed3a37b3ba6d6be3e08ab45987cf1b88" | ||
33 | 31 | ||
34 | SRC_URI = "http://downloads.sourceforge.net/hunspell/hunspell-${PV}.tar.gz;name=hunspell \ | 32 | LICENSE = "GPL-2.0 & (GPL-2.0|LGPL-2.1|MPL-1.1)" |
35 | git://github.com/libreoffice/dictionaries.git;branch=libreoffice-4-3-2;name=dictionaries \ | 33 | LIC_FILES_CHKSUM = " \ |
36 | " | 34 | file://en/license.txt;md5=686e6cb566fd6382c9fcc7a557bf4544 \ |
35 | file://ar/COPYING.txt;md5=ccafd10563b9ffba693011bf470062c6 \ | ||
36 | " | ||
37 | 37 | ||
38 | SRC_URI[hunspell.md5sum] = "3121aaf3e13e5d88dfff13fb4a5f1ab8" | 38 | SRC_URI = "git://github.com/libreoffice/dictionaries.git;branch=libreoffice-5-4-2" |
39 | SRC_URI[hunspell.sha256sum] = "b4edd4a4ee944cb9f485b35473e46b729ed768e9d24da8e78e4c4c6ca56addbd" | ||
40 | # using branch libreoffice-4.3.2 for dictionaries | ||
41 | SRCREV_dictionaries = "aa497b3c345133a1dc180dfb95dd1b3677b92afa" | ||
42 | 39 | ||
43 | PR = "r0" | 40 | S = "${WORKDIR}/git" |
44 | 41 | ||
45 | inherit autotools gettext | 42 | inherit bin_package |
46 | 43 | ||
47 | PACKAGES += "${PN}-dicts" | 44 | # using branch libreoffice-5.4.2 for dictionaries |
48 | RRECOMMENDS_${PN} += "${PN}-dicts" | 45 | SRCREV = "28016713cf482d2ac466d03e007ce91ddb8b76aa" |
49 | FILES_${PN}-dicts = "${datadir}/hunspell" | ||
50 | 46 | ||
51 | do_install_append() { | 47 | FILES_${PN} = "${datadir}/hunspell" |
48 | |||
49 | do_install() { | ||
52 | install -m 0755 -d ${D}${datadir}/hunspell | 50 | install -m 0755 -d ${D}${datadir}/hunspell |
53 | 51 | ||
54 | install -m 0755 ${WORKDIR}/git/ar/ar.dic ${D}${datadir}/hunspell/ar_EG.dic | 52 | install -m 0755 ${S}/ar/ar.dic ${D}${datadir}/hunspell/ar_EG.dic |
55 | install -m 0755 ${WORKDIR}/git/ar/ar.aff ${D}${datadir}/hunspell/ar_EG.aff | 53 | install -m 0755 ${S}/ar/ar.aff ${D}${datadir}/hunspell/ar_EG.aff |
56 | 54 | ||
57 | install -m 0755 ${WORKDIR}/git/en/en_GB.dic ${D}${datadir}/hunspell | 55 | install -m 0755 ${S}/en/en_GB.dic ${D}${datadir}/hunspell |
58 | install -m 0755 ${WORKDIR}/git/en/en_GB.aff ${D}${datadir}/hunspell | 56 | install -m 0755 ${S}/en/en_GB.aff ${D}${datadir}/hunspell |
59 | } | 57 | } |