diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-11-29 16:21:31 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-11-29 17:30:23 +0000 |
commit | 2b55502aad500d70256a6e92bec4d0e1258df482 (patch) | |
tree | b211740f015dc80bfa8b8f47fd743145a7f7ce09 | |
parent | 95fea5050884c2138bd72bc540f53df48bc14da2 (diff) | |
download | meta-boot2qt-2b55502aad500d70256a6e92bec4d0e1258df482.tar.gz |
prebuild-python: get complete python modules package
The prebuild package used by QtCreator did not contain all the necessary
python modules needed by gdb. Get complete package from python.org.
Also make sure those are located by both python.exe and gdb.
We still need the original package to provide all the development files
not included in the embeddable zip file.
Task-number: QTBUG-64855
Change-Id: I109eea70390560e76a668996dfff5bf03424765b
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | recipes/gdb/gdb-cross-canadian_7.%.bbappend | 1 | ||||
-rw-r--r-- | recipes/python/nativesdk-prebuild-python.inc | 6 | ||||
-rw-r--r-- | recipes/python/nativesdk-prebuild-python_i686.bb | 7 | ||||
-rw-r--r-- | recipes/python/nativesdk-prebuild-python_x86_64.bb | 7 |
4 files changed, 14 insertions, 7 deletions
diff --git a/recipes/gdb/gdb-cross-canadian_7.%.bbappend b/recipes/gdb/gdb-cross-canadian_7.%.bbappend index a47bca7..4e55e66 100644 --- a/recipes/gdb/gdb-cross-canadian_7.%.bbappend +++ b/recipes/gdb/gdb-cross-canadian_7.%.bbappend | |||
@@ -52,4 +52,5 @@ EOF | |||
52 | 52 | ||
53 | do_install_append_sdkmingw32() { | 53 | do_install_append_sdkmingw32() { |
54 | ln -s ../python35.dll ${D}${bindir}/ | 54 | ln -s ../python35.dll ${D}${bindir}/ |
55 | ln -s ../python35.zip ${D}${bindir}/ | ||
55 | } | 56 | } |
diff --git a/recipes/python/nativesdk-prebuild-python.inc b/recipes/python/nativesdk-prebuild-python.inc index 71e8e72..3d8c083 100644 --- a/recipes/python/nativesdk-prebuild-python.inc +++ b/recipes/python/nativesdk-prebuild-python.inc | |||
@@ -33,8 +33,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4b8a9367e6bb2acb6f26dc08654f6ee5" | |||
33 | 33 | ||
34 | do_unpack[depends] += "p7zip-native:do_populate_sysroot" | 34 | do_unpack[depends] += "p7zip-native:do_populate_sysroot" |
35 | 35 | ||
36 | DEPENDS = "unzip-native" | ||
37 | |||
38 | inherit bin_package nativesdk python3-dir | 36 | inherit bin_package nativesdk python3-dir |
39 | 37 | ||
40 | PV = "3.5.2" | 38 | PV = "3.5.2" |
@@ -51,7 +49,5 @@ do_install() { | |||
51 | install -d ${D}${bindir} | 49 | install -d ${D}${bindir} |
52 | install -m 0644 ${S}/python.exe ${D}${bindir} | 50 | install -m 0644 ${S}/python.exe ${D}${bindir} |
53 | install -m 0644 ${S}/python35.dll ${D}${bindir} | 51 | install -m 0644 ${S}/python35.dll ${D}${bindir} |
54 | 52 | install -m 0644 ${S}/python35.zip ${D}${bindir} | |
55 | install -d ${D}${libdir}/${PYTHON_DIR} | ||
56 | unzip ${S}/python35.zip -d ${D}${libdir}/${PYTHON_DIR} | ||
57 | } | 53 | } |
diff --git a/recipes/python/nativesdk-prebuild-python_i686.bb b/recipes/python/nativesdk-prebuild-python_i686.bb index cf7204a..2ff4f76 100644 --- a/recipes/python/nativesdk-prebuild-python_i686.bb +++ b/recipes/python/nativesdk-prebuild-python_i686.bb | |||
@@ -31,7 +31,12 @@ require nativesdk-prebuild-python.inc | |||
31 | 31 | ||
32 | COMPATIBLE_HOST = "i686.*-mingw.*" | 32 | COMPATIBLE_HOST = "i686.*-mingw.*" |
33 | 33 | ||
34 | SRC_URI = "http://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z" | 34 | SRC_URI = "\ |
35 | https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \ | ||
36 | https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \ | ||
37 | " | ||
35 | 38 | ||
36 | SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f" | 39 | SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f" |
37 | SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2" | 40 | SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2" |
41 | SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca" | ||
42 | SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954" | ||
diff --git a/recipes/python/nativesdk-prebuild-python_x86_64.bb b/recipes/python/nativesdk-prebuild-python_x86_64.bb index f0cc4ca..8e69fbd 100644 --- a/recipes/python/nativesdk-prebuild-python_x86_64.bb +++ b/recipes/python/nativesdk-prebuild-python_x86_64.bb | |||
@@ -31,7 +31,12 @@ require nativesdk-prebuild-python.inc | |||
31 | 31 | ||
32 | COMPATIBLE_HOST = "x86_64.*-mingw.*" | 32 | COMPATIBLE_HOST = "x86_64.*-mingw.*" |
33 | 33 | ||
34 | SRC_URI = "http://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z" | 34 | SRC_URI = "\ |
35 | https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \ | ||
36 | https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \ | ||
37 | " | ||
35 | 38 | ||
36 | SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f" | 39 | SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f" |
37 | SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124" | 40 | SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124" |
41 | SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e" | ||
42 | SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066" | ||