summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-05 15:50:21 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-07 11:11:30 +0000
commit2ccaa489dc5a3e07dcca9d8cc44404436791aaf2 (patch)
treee4f54647c2b3850707d013df564ad9a5d8c69dc2
parenta2d95eae6ae6b637288ff962d8a653ca6850c687 (diff)
downloadmeta-boot2qt-2ccaa489dc5a3e07dcca9d8cc44404436791aaf2.tar.gz
ttf-opensans: fetch files from git repo
Use git repo for the files, so there's no warnings about missing checksums. Change-Id: If37c144a9b41b7a1b8d8b389091897124b7e3d8e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes/fonts/ttf-opensans.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
index a4af90e..1d581ac 100644
--- a/recipes/fonts/ttf-opensans.bb
+++ b/recipes/fonts/ttf-opensans.bb
@@ -31,20 +31,20 @@ SUMMARY = "Open Sans Fonts"
31SECTION = "fonts" 31SECTION = "fonts"
32HOMEPAGE = "https://fonts.google.com" 32HOMEPAGE = "https://fonts.google.com"
33LICENSE = "Apache-2.0" 33LICENSE = "Apache-2.0"
34LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" 34LIC_FILES_CHKSUM = "file://apache/opensans/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
35 35
36INHIBIT_DEFAULT_DEPS = "1" 36INHIBIT_DEFAULT_DEPS = "1"
37do_unpack[depends] += "unzip-native:do_populate_sysroot"
38 37
39inherit allarch fontcache 38inherit allarch fontcache
40 39
41SRC_URI = "https://fonts.google.com/download?family=Open%20Sans;downloadfilename=Open_Sans.zip" 40SRC_URI = "git://github.com/google/fonts"
42# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check 41SRCREV = "beaec0837bd21524b57ecb435158f9011fc03999"
43BB_STRICT_CHECKSUM = "" 42
43S = "${WORKDIR}/git"
44 44
45do_install() { 45do_install() {
46 install -m 0755 -d ${D}${datadir}/fonts/truetype/opensans 46 install -m 0755 -d ${D}${datadir}/fonts/truetype/opensans
47 install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans 47 install -m 0644 apache/opensans/*.ttf ${D}${datadir}/fonts/truetype/opensans
48} 48}
49 49
50PACKAGES = "${PN}" 50PACKAGES = "${PN}"