summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Olausson <tobias.olausson@pelagicore.com>2017-12-19 18:33:57 +0100
committerTobias Olausson <tobias.olausson@pelagicore.com>2017-12-20 12:34:07 +0000
commit6c17d88c4f276e25d29609223a251bf3e7551ee9 (patch)
treecc20c331d84b665e900ccdad691d6f6f5410fcde
parentc9de8c44d5c982adbbcb43445c8e7cfd0738976d (diff)
downloadmeta-boot2qt-6c17d88c4f276e25d29609223a251bf3e7551ee9.tar.gz
connman: choose correct patch for connman version
For building with rocko as the upstream, the connman version (and with that the systemd service file) has been updated. We should select the correct patch for the version of connman we're building. Change-Id: I3e620e383c25d32c2c2e054092cbca81538f4b8a Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> Reviewed-by: Gordan Markus <gordan.markus@pelagicore.com>
-rw-r--r--recipes/connman/connman_%.bbappend2
-rw-r--r--recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch (renamed from recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch)0
-rw-r--r--recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch11
3 files changed, 12 insertions, 1 deletions
diff --git a/recipes/connman/connman_%.bbappend b/recipes/connman/connman_%.bbappend
index 0b03755..fda246a 100644
--- a/recipes/connman/connman_%.bbappend
+++ b/recipes/connman/connman_%.bbappend
@@ -21,4 +21,4 @@
21 21
22FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 22FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
23 23
24SRC_URI += "file://0001-disable-connman-when-booting-over-nfs.patch" 24SRC_URI += "file://0001-disable-connman-when-booting-over-nfs-${PV}.patch"
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch
index f893746..f893746 100644
--- a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
+++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch
new file mode 100644
index 0000000..8b46666
--- /dev/null
+++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch
@@ -0,0 +1,11 @@
1--- a/src/connman.service.in
2+++ b/src/connman.service.in
3@@ -7,6 +7,7 @@
4 Before=network.target multi-user.target shutdown.target
5 Wants=network.target
6 Conflicts=systemd-resolved.service
7+ConditionKernelCommandLine=!root=/dev/nfs
8
9 [Service]
10 Type=dbus
11