diff options
author | Tobias Olausson <tobias.olausson@pelagicore.com> | 2018-01-16 15:19:27 +0100 |
---|---|---|
committer | Tobias Olausson <tobias.olausson@pelagicore.com> | 2018-01-22 08:59:31 +0000 |
commit | 8513b63910eb9046c79ab3fb3df02a4e665f05b5 (patch) | |
tree | 1afb8a3ad008af12cb68b06f5617a5e6fcbc1312 | |
parent | fba9740e28ef332a7cc7c535ea57b244b3127b2d (diff) | |
download | meta-boot2qt-8513b63910eb9046c79ab3fb3df02a4e665f05b5.tar.gz |
neptune-ui: bump srcrev, install fonts system-wide
When building on rocko, the fonts are not picked up unless installed
system-wide. The SRCREV bump fixes an issue where neptune would crash
with an EGLFS error about mixing OpenGL windows.
Change-Id: Ie905b581d9e97845ea508730541228cf34291796
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/automotive/neptune-ui/neptune.service | 2 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 19 |
2 files changed, 15 insertions, 6 deletions
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service index ef73324..16b6a1f 100644 --- a/recipes-qt/automotive/neptune-ui/neptune.service +++ b/recipes-qt/automotive/neptune-ui/neptune.service | |||
@@ -5,7 +5,7 @@ After=dbus.service dbus-session.service systemd-user-sessions.service | |||
5 | [Service] | 5 | [Service] |
6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml | 6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml |
7 | Restart=on-failure | 7 | Restart=on-failure |
8 | WorkingDirectory=/opt/neptune-ui | 8 | WorkingDirectory=/usr/neptune-ui |
9 | 9 | ||
10 | [Install] | 10 | [Install] |
11 | WantedBy=multi-user.target | 11 | WantedBy=multi-user.target |
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index f13bbfb..c1d2e31 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -29,7 +29,10 @@ | |||
29 | 29 | ||
30 | DESCRIPTION = "Neptune IVI UI" | 30 | DESCRIPTION = "Neptune IVI UI" |
31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82" | 32 | LIC_FILES_CHKSUM = "\ |
33 | file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82 \ | ||
34 | file://imports/assets/fonts/OFL.txt;md5=a729250f3548d9d2deab9bfeb8a7ad51 \ | ||
35 | " | ||
33 | 36 | ||
34 | inherit qt5-module systemd | 37 | inherit qt5-module systemd |
35 | require recipes-qt/qt5/qt5-git.inc | 38 | require recipes-qt/qt5/qt5-git.inc |
@@ -41,7 +44,7 @@ SRC_URI += " \ | |||
41 | file://neptune.service \ | 44 | file://neptune.service \ |
42 | " | 45 | " |
43 | 46 | ||
44 | SRCREV = "2cf65ed117e8e4494b1ab66b35e3dc9a70234659" | 47 | SRCREV = "24f9e00960ccbb3da1ab41899fee38864efe265f" |
45 | 48 | ||
46 | DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager" | 49 | DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager" |
47 | RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \ | 50 | RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \ |
@@ -51,14 +54,20 @@ RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \ | |||
51 | do_install_append() { | 54 | do_install_append() { |
52 | install -m 0755 -d ${D}${systemd_unitdir}/system | 55 | install -m 0755 -d ${D}${systemd_unitdir}/system |
53 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ | 56 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ |
57 | |||
58 | # Move the fonts to the system-wide font location | ||
59 | install -m 0755 -d ${D}${datadir}/fonts/ttf/ | ||
60 | mv ${D}/usr/neptune-ui/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/ | ||
61 | rm -rf ${D}/usr/neptune-ui/imports/assets/fonts/ | ||
54 | } | 62 | } |
55 | 63 | ||
56 | PACKAGES =+ "${PN}-apps" | 64 | PACKAGES =+ "${PN}-apps" |
57 | RRECOMMENDS_${PN} += "${PN}-apps" | 65 | RRECOMMENDS_${PN} += "${PN}-apps" |
58 | 66 | ||
59 | FILES_${PN}-apps += "/opt/neptune/apps" | 67 | FILES_${PN}-apps += "/usr/neptune-ui/apps" |
60 | FILES_${PN} += "\ | 68 | FILES_${PN} += "\ |
61 | /opt/neptune \ | 69 | /usr/neptune-ui \ |
62 | " | 70 | ${datadir}/fonts/ttf \ |
71 | " | ||
63 | 72 | ||
64 | SYSTEMD_SERVICE_${PN} = "neptune.service" | 73 | SYSTEMD_SERVICE_${PN} = "neptune.service" |