summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:16:05 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:07:28 +0000
commitc14277b8cbe66729ae1dbdad857fcf61259e76db (patch)
treedc89d7e86258ed67ea3277f5f24b0c9a85388d97
parentf044d0ae2c46de9178b7120ce724fad634b33878 (diff)
downloadmeta-boot2qt-c14277b8cbe66729ae1dbdad857fcf61259e76db.tar.gz
Remove ifupdown recipes
ifupdown is no longer used in the images. Change-Id: I6a5abee6735fb10d6344d16af11a819bbaa5ff62 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes/init-ifupdown/init-ifupdown/beagleboard/interfaces33
-rw-r--r--recipes/init-ifupdown/init-ifupdown/emulator/interfaces33
-rwxr-xr-xrecipes/init-ifupdown/init-ifupdown/fixed_mac_address7
-rw-r--r--recipes/init-ifupdown/init-ifupdown/interfaces32
-rw-r--r--recipes/init-ifupdown/init-ifupdown/nitrogen6x/interfaces31
-rw-r--r--recipes/init-ifupdown/init-ifupdown_1.0.bbappend37
6 files changed, 0 insertions, 173 deletions
diff --git a/recipes/init-ifupdown/init-ifupdown/beagleboard/interfaces b/recipes/init-ifupdown/init-ifupdown/beagleboard/interfaces
deleted file mode 100644
index e315b94..0000000
--- a/recipes/init-ifupdown/init-ifupdown/beagleboard/interfaces
+++ /dev/null
@@ -1,33 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19 hostname `/bin/hostname`
20# hwaddress ether 00:00:00:00:00:00
21iface eth1 inet dhcp
22
23# Ethernet/RNDIS gadget (g_ether)
24# ... or on host side, usbnet and random hwaddr
25iface usb0 inet static
26 address 192.168.7.2
27 netmask 255.255.255.0
28 network 192.168.7.0
29 gateway 192.168.7.1
30
31# Bluetooth networking
32iface bnep0 inet dhcp
33
diff --git a/recipes/init-ifupdown/init-ifupdown/emulator/interfaces b/recipes/init-ifupdown/init-ifupdown/emulator/interfaces
deleted file mode 100644
index 06adafb..0000000
--- a/recipes/init-ifupdown/init-ifupdown/emulator/interfaces
+++ /dev/null
@@ -1,33 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19auto eth1
20iface eth1 inet dhcp
21 hostname `/bin/hostname`
22
23# Ethernet/RNDIS gadget (g_ether)
24# ... or on host side, usbnet and random hwaddr
25iface usb0 inet static
26 address 192.168.7.2
27 netmask 255.255.255.0
28 network 192.168.7.0
29 gateway 192.168.7.1
30
31# Bluetooth networking
32iface bnep0 inet dhcp
33
diff --git a/recipes/init-ifupdown/init-ifupdown/fixed_mac_address b/recipes/init-ifupdown/init-ifupdown/fixed_mac_address
deleted file mode 100755
index 020257e..0000000
--- a/recipes/init-ifupdown/init-ifupdown/fixed_mac_address
+++ /dev/null
@@ -1,7 +0,0 @@
1#!/bin/sh
2
3if [ ! -e /etc/network/interfaces.fixed ]; then
4 HWADDRESS=$(cat /sys/class/net/eth0/address)
5 sed -i -e 's,^#\(.*\)00:00:00:00:00:00,\1'$HWADDRESS',' /etc/network/interfaces
6 touch /etc/network/interfaces.fixed
7fi
diff --git a/recipes/init-ifupdown/init-ifupdown/interfaces b/recipes/init-ifupdown/init-ifupdown/interfaces
deleted file mode 100644
index 5c1ec07..0000000
--- a/recipes/init-ifupdown/init-ifupdown/interfaces
+++ /dev/null
@@ -1,32 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19 hostname `/bin/hostname`
20iface eth1 inet dhcp
21
22# Ethernet/RNDIS gadget (g_ether)
23# ... or on host side, usbnet and random hwaddr
24iface usb0 inet static
25 address 192.168.7.2
26 netmask 255.255.255.0
27 network 192.168.7.0
28 gateway 192.168.7.1
29
30# Bluetooth networking
31iface bnep0 inet dhcp
32
diff --git a/recipes/init-ifupdown/init-ifupdown/nitrogen6x/interfaces b/recipes/init-ifupdown/init-ifupdown/nitrogen6x/interfaces
deleted file mode 100644
index 93ba671..0000000
--- a/recipes/init-ifupdown/init-ifupdown/nitrogen6x/interfaces
+++ /dev/null
@@ -1,31 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver nl80211
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19 hostname `/bin/hostname`
20
21# Ethernet/RNDIS gadget (g_ether)
22# ... or on host side, usbnet and random hwaddr
23iface usb0 inet static
24 address 192.168.7.2
25 netmask 255.255.255.0
26 network 192.168.7.0
27 gateway 192.168.7.1
28
29# Bluetooth networking
30iface bnep0 inet dhcp
31
diff --git a/recipes/init-ifupdown/init-ifupdown_1.0.bbappend b/recipes/init-ifupdown/init-ifupdown_1.0.bbappend
deleted file mode 100644
index 430999a..0000000
--- a/recipes/init-ifupdown/init-ifupdown_1.0.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI_append_beagleboard = " file://fixed_mac_address"
33
34do_install_append_beagleboard() {
35 install -d ${D}${sysconfdir}/init.d
36 install -m 0755 ${WORKDIR}/fixed_mac_address ${D}${sysconfdir}/network/if-pre-up.d/
37}