diff options
author | Sami Nurmenniemi <sami.nurmenniemi@qt.io> | 2018-05-31 14:43:01 +0300 |
---|---|---|
committer | Sami Nurmenniemi <sami.nurmenniemi@qt.io> | 2018-06-04 10:42:59 +0000 |
commit | c6b58b604465b531c3d188f4a251ef18fed3e656 (patch) | |
tree | ab517643a88e4ee6a7b141e0902d7fa82e49df45 | |
parent | f891a965c82f8e0dafb60222ec36d06dcfe1eb1e (diff) | |
download | meta-boot2qt-c6b58b604465b531c3d188f4a251ef18fed3e656.tar.gz |
Add gcc-sanitizer libraries ("address" and "undefined behavior")
Change-Id: Ia916859abd601a7a0215acfadb71b4fe1d91358f
Reviewed-by: Kari Oikarinen <kari.oikarinen@qt.io>
Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
3 files changed, 35 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb index 7644f6f..4a5fa39 100644 --- a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb +++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb | |||
@@ -38,6 +38,7 @@ RDEPENDS_${PN} = "\ | |||
38 | binutils \ | 38 | binutils \ |
39 | binutils-symlinks \ | 39 | binutils-symlinks \ |
40 | connman-client \ | 40 | connman-client \ |
41 | gcc-sanitizers \ | ||
41 | htop \ | 42 | htop \ |
42 | i2c-tools \ | 43 | i2c-tools \ |
43 | iproute2 \ | 44 | iproute2 \ |
diff --git a/meta-boot2qt-distro/recipes-devtools/gcc/gcc-sanitizers_%.bbappend b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-sanitizers_%.bbappend new file mode 100644 index 0000000..bbbffe3 --- /dev/null +++ b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-sanitizers_%.bbappend | |||
@@ -0,0 +1,33 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # aarch64 is compatible since GCC 5.1. See poky/master commit | ||
31 | # b46caed47b0f74520cd9280bbe3e3676d9a19046 | ||
32 | RRECOMMENDS_${PN}_append_aarch64 = " liblsan libtsan" | ||
33 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|arm|aarch64).*-linux' | ||
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb index 83b075b..0fa57e1 100644 --- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb +++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb | |||
@@ -40,6 +40,7 @@ MACHINE_EXTRA_INSTALL_SDK ?= "" | |||
40 | RDEPENDS_${PN} += " \ | 40 | RDEPENDS_${PN} += " \ |
41 | ${MACHINE_EXTRA_INSTALL_SDK} \ | 41 | ${MACHINE_EXTRA_INSTALL_SDK} \ |
42 | packagegroup-core-standalone-sdk-target \ | 42 | packagegroup-core-standalone-sdk-target \ |
43 | gcc-sanitizers \ | ||
43 | \ | 44 | \ |
44 | qt3d-dev \ | 45 | qt3d-dev \ |
45 | qtbase-dev \ | 46 | qtbase-dev \ |