summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-25 17:44:48 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-26 09:39:37 +0000
commit34fb23f1b49233cd0a20f33d93cf7b681cd60068 (patch)
tree2fc812a65b23539a292fe6cec4c196d3065cf4c0
parent4353110f4f2406d2d55f7a9d4db4cf50942de975 (diff)
downloadmeta-boot2qt-34fb23f1b49233cd0a20f33d93cf7b681cd60068.tar.gz
Tibidabo: enable systemd dependencies in kernel
Change-Id: I604a67e73543ff1852156bf190cd4d245fe81f90 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb38
1 files changed, 29 insertions, 9 deletions
diff --git a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
index 8a2fd54..69adc4f 100644
--- a/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
+++ b/meta-architech-extras/recipes/linux/linux-imx_3.0.35.bb
@@ -24,15 +24,35 @@ SRC_URI += "file://drm-vivante-Add-00-sufix-in-returned-bus-Id.patch \
24RDEPENDS_kernel-base = "" 24RDEPENDS_kernel-base = ""
25 25
26do_configure_prepend() { 26do_configure_prepend() {
27 # FunctionFS for adb 27
28 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig 28cat <<EOF >> ${WORKDIR}/defconfig
29 29
30 # Enable USB serial support 30# FunctionFS for adb
31 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig 31CONFIG_USB_FUNCTIONFS=m
32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig 32
33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig 33# Enable USB serial support
34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig 34CONFIG_USB_SERIAL=m
35 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig 35CONFIG_USB_SERIAL_GENERIC=y
36CONFIG_USB_SERIAL_FTDI_SIO=m
37CONFIG_USB_SERIAL_PL2303=m
38CONFIG_USB_ACM=m
39
40# Control group support
41CONFIG_CGROUPS=y
42
43# Open by fhandle syscalls
44CONFIG_FHANDLE=y
45CONFIG_EXPORTFS=y
46
47# Namespaces support
48CONFIG_NAMESPACES=y
49CONFIG_UTS_NS=y
50CONFIG_IPC_NS=y
51CONFIG_USER_NS=y
52CONFIG_PID_NS=y
53CONFIG_NET_NS=y
54
55EOF
36} 56}
37 57
38# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors 58# bbappend in meta-tibidabo still tries to use PRINC, set to -1 to prevent errors