summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-09 11:28:49 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-09 10:23:16 +0000
commit4fa8b5e34074744518de1659e63617bec8411f47 (patch)
tree7bfd6b672eee65d288e35d6e725ed5a7825ad7f3
parent2bd715056f84d866ec52e015c3658c0e2ac509be (diff)
downloadmeta-boot2qt-4fa8b5e34074744518de1659e63617bec8411f47.tar.gz
b2qt-demos: update to new revision
QtWebBrowser now builds application as well as qml plugin, but for qtlauncher we only need the plugin. Also all the needed files from tqtc-qtwebrowser are in the plugin, we can remove the directory. Task-number: QTEE-1083 Change-Id: Ia135490a4d95ef3428fb54b84ce5c77588e344ef Reviewed-by: Kimmo Ollila <kimmo.ollila@theqtcompany.com>
-rw-r--r--recipes-qt/b2qt-addons/b2qt-demos.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-demos.bb b/recipes-qt/b2qt-addons/b2qt-demos.bb
index 2075077..ca7b8ee 100644
--- a/recipes-qt/b2qt-addons/b2qt-demos.bb
+++ b/recipes-qt/b2qt-addons/b2qt-demos.bb
@@ -39,7 +39,7 @@ PV = "5.6+git${SRCPV}"
39BRANCH = "5.6" 39BRANCH = "5.6"
40BROWSER_BRANCH = "dev" 40BROWSER_BRANCH = "dev"
41QT_BRANCH = "5.6" 41QT_BRANCH = "5.6"
42SRCREV_demos = "7076d480edb69cc7d42594acbce00f3a563ed94c" 42SRCREV_demos = "cdaf26d23204a0a745885ab0db886388618d50db"
43SRCREV_qtcanvas3d = "5a17c4ca0552c9f4e6b5646f0cee2b21a55c3d18" 43SRCREV_qtcanvas3d = "5a17c4ca0552c9f4e6b5646f0cee2b21a55c3d18"
44SRCREV_qtquickcontrols = "fc9c57cf8b66bafbcaa6957bb22293047aa3d9df" 44SRCREV_qtquickcontrols = "fc9c57cf8b66bafbcaa6957bb22293047aa3d9df"
45SRCREV_qtwebbrowser = "c86bb8a400f79be205025598310926df5d01c7bc" 45SRCREV_qtwebbrowser = "c86bb8a400f79be205025598310926df5d01c7bc"
@@ -59,14 +59,14 @@ do_install_append() {
59 # we only need plugins from the demos 59 # we only need plugins from the demos
60 rm -rf ${D}/data/user/camera 60 rm -rf ${D}/data/user/camera
61 rm -rf ${D}/data/user/sensorexplorer 61 rm -rf ${D}/data/user/sensorexplorer
62 rm -rf ${D}/data/user/qtwebbrowser
62 63
63 # we need all qml and content files 64 # we need all qml and content files
64 cp -r ${S}/* ${D}/data/user/qt/ 65 cp -r ${S}/* ${D}/data/user/qt/
65 66
66 # but none of the source files 67 # but none of the source files
67 find ${D}/data/user/qt/ \( -name '*.cpp' -or -name '*.h' -or -name '*.pro' \) -delete 68 find ${D}/data/user/qt/ \( -name '*.cpp' -or -name '*.h' -or -name '*.pro' \) -delete
68 rm -rf ${D}/data/user/qt/qtwebbrowser/tqtc-qtwebbrowser/.git 69 rm -rf ${D}/data/user/qt/qtwebbrowser/tqtc-qtwebbrowser
69 rm -rf ${D}/data/user/qt/qtwebbrowser/tqtc-qtwebbrowser/mockups
70 70
71 if [ -d ${WORKDIR}/git/images ]; then 71 if [ -d ${WORKDIR}/git/images ]; then
72 install -d 0755 ${D}/data/images 72 install -d 0755 ${D}/data/images