diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-04-28 12:03:11 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-04-28 12:09:43 +0300 |
commit | 1037ce1006ad2111c07e9a319aaf2525fb9dea92 (patch) | |
tree | 354ccf01c1357cef639e12aca29038f53129146e | |
parent | f51a8b342279c6f4bcfa77a82ca3cf7783bc1537 (diff) | |
parent | 88a28e12ca2fabb0fc47a96b4076bf10a0673c5b (diff) | |
download | meta-boot2qt-1037ce1006ad2111c07e9a319aaf2525fb9dea92.tar.gz |
Merge remote-tracking branch 'origin/dev' into morty
* origin/dev:
deviceutilities: update to newer version
qt5: update submodules
fsl: update freescale meta layers & related .bbappend entries
sdk: use python3 for toolchain
qtivi: update to version that compiles with Qt 5.9
warp7: add kernel configs to right file
Add support for i.MX7S WaRP
Update and re-enable QtQuickCompiler
use newer meta-qt5
Merge remote-tracking branch 'origin/krogoth' into dev
qt5: use newer meta-qt5
poky: update morty branch
neptune-ui: update revision
qtbase: disable eglfs device integration plugin usage in emulator
neptune-ui: depends on qttools-native
Multiscreen-demo: update revision
neptune-ui: rdepends on dbus-session
qt5: use newer meta-qt5
Revert "qtglesstream: update to newer version"
multiscreen-demo: update revision
qtivi: Update to the latest version
neptune-ui: Update to the latest version
neptune: update to latest version
toradex: add missing USB kernel config for colibri vf
Change-Id: I34414fac9a5eedeb028bcd06988ca23c2eea5549
25 files changed, 114 insertions, 96 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env index e90188a..d72d28c 100755 --- a/b2qt-init-build-env +++ b/b2qt-init-build-env | |||
@@ -109,7 +109,7 @@ get_groups() { | |||
109 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) | 109 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
110 | PROJECT_GROUPS="fsl" | 110 | PROJECT_GROUPS="fsl" |
111 | ;; | 111 | ;; |
112 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) | 112 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd|imx7s-warp) |
113 | PROJECT_GROUPS="fsl" | 113 | PROJECT_GROUPS="fsl" |
114 | ;; | 114 | ;; |
115 | smarc-samx6i) | 115 | smarc-samx6i) |
diff --git a/conf/distro/include/imx7s-warp.conf b/conf/distro/include/imx7s-warp.conf new file mode 100644 index 0000000..fdd7f17 --- /dev/null +++ b/conf/distro/include/imx7s-warp.conf | |||
@@ -0,0 +1,37 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | include conf/distro/include/fsl.inc | ||
31 | |||
32 | DEPLOY_CONF_NAME = "i.MX7S WaRP" | ||
33 | |||
34 | PREFERRED_PROVIDER_virtual/egl = "opengldummy" | ||
35 | PREFERRED_PROVIDER_virtual/libgles2 = "opengldummy" | ||
36 | |||
37 | DISTRO_FEATURES_remove = "webengine wayland" | ||
diff --git a/conf/local.conf.sample b/conf/local.conf.sample index 81fd5c7..f98c43b 100644 --- a/conf/local.conf.sample +++ b/conf/local.conf.sample | |||
@@ -283,7 +283,6 @@ INHERIT += "internal-build" | |||
283 | 283 | ||
284 | # Enables use of QtQuickCompiler if you have access to the gerrit project | 284 | # Enables use of QtQuickCompiler if you have access to the gerrit project |
285 | #ENABLE_QTQUICKCOMPILER = "1" | 285 | #ENABLE_QTQUICKCOMPILER = "1" |
286 | DISABLE_QTQUICKCOMPILER = "1" | ||
287 | 286 | ||
288 | ACCEPT_FSL_EULA = "1" | 287 | ACCEPT_FSL_EULA = "1" |
289 | LICENSE_FLAGS_WHITELIST = "commercial" | 288 | LICENSE_FLAGS_WHITELIST = "commercial" |
diff --git a/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend index 4c472db..068b9fa 100644 --- a/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend +++ b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend | |||
@@ -29,4 +29,4 @@ | |||
29 | 29 | ||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}:" | 30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}:" |
31 | 31 | ||
32 | COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|wandboard-dual|wandboard-quad)" | 32 | COMPATIBLE_MACHINE = "(cubox-i|nitrogen6x|nitrogen6x-lite|wandboard|imx6sl-warp)" |
diff --git a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend index c4e0158..9a50c92 100644 --- a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend | |||
@@ -35,12 +35,7 @@ do_preconfigure_prepend() { | |||
35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | 35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig |
36 | 36 | ||
37 | # Enable USB serial support | 37 | # Enable USB serial support |
38 | echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig | ||
39 | echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig | ||
40 | echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig | ||
41 | echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig | 38 | echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig |
42 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
43 | 39 | ||
44 | echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig | 40 | echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig |
45 | echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig | ||
46 | } | 41 | } |
diff --git a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend index c4e0158..208ec74 100644 --- a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend | |||
@@ -35,11 +35,7 @@ do_preconfigure_prepend() { | |||
35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | 35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig |
36 | 36 | ||
37 | # Enable USB serial support | 37 | # Enable USB serial support |
38 | echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig | ||
39 | echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig | ||
40 | echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig | ||
41 | echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig | 38 | echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig |
42 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
43 | 39 | ||
44 | echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig | 40 | echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig |
45 | echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig | 41 | echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig |
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend index f8fac0d..58c64de 100644 --- a/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend | |||
@@ -33,5 +33,4 @@ RDEPENDS_kernel-base = "" | |||
33 | do_preconfigure_prepend () { | 33 | do_preconfigure_prepend () { |
34 | # FunctionFS for adb | 34 | # FunctionFS for adb |
35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | 35 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig |
36 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
37 | } | 36 | } |
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend index 5a92f25..431005b 100644 --- a/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend +++ b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend | |||
@@ -32,6 +32,5 @@ RDEPENDS_kernel-base = "kernel-image kernel-devicetree" | |||
32 | do_preconfigure_prepend () { | 32 | do_preconfigure_prepend () { |
33 | # FunctionFS for adb | 33 | # FunctionFS for adb |
34 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig | 34 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig |
35 | echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig | ||
36 | echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig | 35 | echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig |
37 | } | 36 | } |
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend new file mode 100644 index 0000000..5efcce0 --- /dev/null +++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend | |||
@@ -0,0 +1,34 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_configure_prepend() { | ||
31 | echo "CONFIG_NAMESPACES=y" >> ${B}/.config | ||
32 | echo "CONFIG_FHANDLE=y" >> ${B}/.config | ||
33 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config | ||
34 | } | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch deleted file mode 100644 index d1f5616..0000000 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 33a5a73cd846c0bbf6a507aa4e658c74815eb1d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Rainer Keller <Rainer.Keller@qt.io> | ||
3 | Date: Wed, 4 May 2016 12:49:40 +0200 | ||
4 | Subject: [PATCH] Add recovery support | ||
5 | |||
6 | --- | ||
7 | include/configs/nitrogen6x.h | 7 +++++++ | ||
8 | 1 file changed, 7 insertions(+) | ||
9 | |||
10 | diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h | ||
11 | index bbc613d..9c939e6 100644 | ||
12 | --- a/include/configs/nitrogen6x.h | ||
13 | +++ b/include/configs/nitrogen6x.h | ||
14 | @@ -232,6 +232,11 @@ | ||
15 | "clearenv=if sf probe || sf probe || sf probe 1 ; then " \ | ||
16 | "sf erase 0xc0000 0x2000 && " \ | ||
17 | "echo restored environment to factory default ; fi\0" \ | ||
18 | + "recovery_boot=setenv recovery true ; dtype=mmc ; setenv bootpart 3 ; " \ | ||
19 | + "for disk in 0 1 ; do " \ | ||
20 | + "${dtype} dev ${disk} ; " \ | ||
21 | + "load ${dtype} ${disk}:${bootpart} 10008000 /6x_bootscript && source 10008000 ; " \ | ||
22 | + "done\0" \ | ||
23 | "bootcmd=for dtype in ${bootdevs}" \ | ||
24 | "; do " \ | ||
25 | "if itest.s \"xusb\" == \"x${dtype}\" ; then " \ | ||
26 | @@ -245,6 +250,8 @@ | ||
27 | "&& source 10008000 ; " \ | ||
28 | "done ; " \ | ||
29 | "done; " \ | ||
30 | + "echo Startup failed, running recovery ; " \ | ||
31 | + "run recovery_boot ; " \ | ||
32 | "setenv stdout serial,vga ; " \ | ||
33 | "echo ; echo 6x_bootscript not found ; " \ | ||
34 | "echo ; echo serial console at 115200, 8N1 ; echo ; " \ | ||
35 | -- | ||
36 | 2.7.3 | ||
37 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch new file mode 100644 index 0000000..9eda199 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | From 59d272d9df5337bb4bd62a96fc16c8e280c49344 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mikko Gronoff <mikko.gronoff@qt.io> | ||
3 | Date: Sun, 23 Apr 2017 21:47:01 +0300 | ||
4 | Subject: [PATCH] set CMA reserved size to 384MB | ||
5 | |||
6 | Increased from 256MB (the default) to 384MB. Without this, HW-accelerated | ||
7 | video decoding cannot work for high resolution videos. | ||
8 | --- | ||
9 | include/configs/nitrogen6x.h | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h | ||
13 | index 646c505..ddbb4c5 100644 | ||
14 | --- a/include/configs/nitrogen6x.h | ||
15 | +++ b/include/configs/nitrogen6x.h | ||
16 | @@ -28,6 +28,7 @@ | ||
17 | #define CONFIG_USB_MAX_CONTROLLER_COUNT 2 | ||
18 | #define CONFIG_VIDEO | ||
19 | #define BD_I2C_MASK 7 | ||
20 | +#define BD_CMA "384M" | ||
21 | |||
22 | #if defined(CONFIG_SABRELITE) | ||
23 | #define CONFIG_ENV_IS_IN_MMC | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend index 5f0d155..013e54b 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend | |||
@@ -30,5 +30,5 @@ | |||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ | 32 | file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \ |
33 | file://0002-Add-recovery-support.patch \ | 33 | file://0002-set-CMA-reserved-size-to-384MB.patch \ |
34 | " | 34 | " |
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch deleted file mode 100644 index d648340..0000000 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 3bb661da09e2a57ef452d388d69b8d01044136f1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 13 Jan 2016 09:26:33 +0200 | ||
4 | Subject: [PATCH] set CMA reserved size to 384MB | ||
5 | |||
6 | Increased from 256MB (the default) to 384MB. Without this, HW-accelerated | ||
7 | video decoding cannot work for high resolution videos. | ||
8 | --- | ||
9 | board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
13 | index 86242b5..da4ea05 100644 | ||
14 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
15 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
16 | @@ -92,7 +92,7 @@ if itest.s "x" == "x${cmd_xxx_present}" ; then | ||
17 | echo "!!!!!!!!!!!!!!!!" | ||
18 | fi | ||
19 | |||
20 | -setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M consoleblank=0 rootwait fixrtc" | ||
21 | +setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M cma=384M consoleblank=0 rootwait fixrtc" | ||
22 | |||
23 | |||
24 | bpart=2 | ||
25 | -- | ||
26 | 1.9.1 | ||
27 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend index a01780a..dafcf84 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | |||
@@ -29,6 +29,5 @@ | |||
29 | 29 | ||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-set-CMA-reserved-size-to-384MB.patch \ | ||
33 | file://0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch \ | 32 | file://0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch \ |
34 | " | 33 | " |
diff --git a/recipes-qt/automotive/multiscreen-demo_git.bb b/recipes-qt/automotive/multiscreen-demo_git.bb index 1997bd5..0c9a2bb 100644 --- a/recipes-qt/automotive/multiscreen-demo_git.bb +++ b/recipes-qt/automotive/multiscreen-demo_git.bb | |||
@@ -39,7 +39,7 @@ QT_MODULE_BRANCH = "master" | |||
39 | 39 | ||
40 | SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets" | 40 | SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets" |
41 | 41 | ||
42 | SRCREV_multiscreen = "77ecd7d03aeea3bb7d10ac8ef448920da11ae306" | 42 | SRCREV_multiscreen = "f4cd6b9667b4649b4ef8b4bb645850b05aceebde" |
43 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" | 43 | SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264" |
44 | 44 | ||
45 | SRCREV_FORMAT = "multiscreen_assets" | 45 | SRCREV_FORMAT = "multiscreen_assets" |
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service index e9f3793..7793d0b 100644 --- a/recipes-qt/automotive/neptune-ui/neptune.service +++ b/recipes-qt/automotive/neptune-ui/neptune.service | |||
@@ -3,7 +3,7 @@ Description=Neptune | |||
3 | After=dbus.service dbus-session.service systemd-user-sessions.service | 3 | After=dbus.service dbus-session.service systemd-user-sessions.service |
4 | 4 | ||
5 | [Service] | 5 | [Service] |
6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml --dbus session -c am-config.yaml Main.qml | 6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml Main.qml |
7 | Restart=on-failure | 7 | Restart=on-failure |
8 | WorkingDirectory=/opt/neptune | 8 | WorkingDirectory=/opt/neptune |
9 | 9 | ||
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index ceceec8..ba82524 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -41,10 +41,10 @@ SRC_URI += " \ | |||
41 | file://neptune.service \ | 41 | file://neptune.service \ |
42 | " | 42 | " |
43 | 43 | ||
44 | SRCREV = "504d9720ed7ef921af7e5f1ebf709662baac6555" | 44 | SRCREV = "1770881783025b04ff5b4c7da7810d1648485b92" |
45 | 45 | ||
46 | DEPENDS = "qtbase qtdeclarative" | 46 | DEPENDS = "qtbase qtdeclarative qttools-native" |
47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ | 47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard dbus \ |
48 | qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ | 48 | qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ |
49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" | 49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" |
50 | 50 | ||
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index e3dd3fd..b471a89 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -44,6 +44,6 @@ PACKAGECONFIG[geniviextras-only] = "CONFIG+=geniviextras-only" | |||
44 | 44 | ||
45 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" | 45 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" |
46 | 46 | ||
47 | SRCREV = "a15c13d6255d23ce90997913b7c1347fef396fa8" | 47 | SRCREV = "40e8ba1c8dd89474c4d890a3e050890d0cd9654e" |
48 | 48 | ||
49 | DEPENDS = "qtbase qtdeclarative qtmultimedia" | 49 | DEPENDS = "qtbase qtdeclarative qtmultimedia" |
diff --git a/recipes-qt/qt5-addons/qtglesstream.bb b/recipes-qt/qt5-addons/qtglesstream.bb index 9ed6991..57eae88 100644 --- a/recipes-qt/qt5-addons/qtglesstream.bb +++ b/recipes-qt/qt5-addons/qtglesstream.bb | |||
@@ -38,7 +38,7 @@ SRC_URI = " \ | |||
38 | " | 38 | " |
39 | 39 | ||
40 | PV = "1.0.0" | 40 | PV = "1.0.0" |
41 | SRCREV = "2a58387d9ca27ba528d5d2ab5db6c9e5a2f8a1de" | 41 | SRCREV = "c11bf065f7630b7800dda157e4bc1aeba7a533d2" |
42 | BRANCH = "dev" | 42 | BRANCH = "dev" |
43 | 43 | ||
44 | S = "${WORKDIR}/git" | 44 | S = "${WORKDIR}/git" |
diff --git a/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri b/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri index 9f6fdc3..43e1685 100644 --- a/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri +++ b/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri | |||
@@ -3,3 +3,4 @@ QMAKE_LIBS_OPENGL_ES2 = -lQtGlesStreamClient | |||
3 | 3 | ||
4 | QMAKE_PLATFORM += boot2qt | 4 | QMAKE_PLATFORM += boot2qt |
5 | QT_QPA_DEFAULT_PLATFORM = eglfs | 5 | QT_QPA_DEFAULT_PLATFORM = eglfs |
6 | EGLFS_DEVICE_INTEGRATION = none | ||
diff --git a/recipes-qt/qt5/qtdeviceutilities.bb b/recipes-qt/qt5/qtdeviceutilities.bb index 1c91236..e5d7cb8 100644 --- a/recipes-qt/qt5/qtdeviceutilities.bb +++ b/recipes-qt/qt5/qtdeviceutilities.bb | |||
@@ -43,6 +43,6 @@ SRC_URI = " \ | |||
43 | git://codereview.qt-project.org/qt/qtdeviceutilities;${QT_MODULE_BRANCH_PARAM};protocol=http \ | 43 | git://codereview.qt-project.org/qt/qtdeviceutilities;${QT_MODULE_BRANCH_PARAM};protocol=http \ |
44 | " | 44 | " |
45 | 45 | ||
46 | SRCREV = "4f54d9b10ebdd296accfa5526d7c941a03249a50" | 46 | SRCREV = "314de829065a3fa411b8fed90ff1289b000e229b" |
47 | 47 | ||
48 | DEPENDS = "qtbase qtdeclarative qtconnectivity" | 48 | DEPENDS = "qtbase qtdeclarative qtconnectivity" |
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb index 63f0f6a..23fbaf8 100644 --- a/recipes-qt/qt5/qtquickcompiler_git.bb +++ b/recipes-qt/qt5/qtquickcompiler_git.bb | |||
@@ -37,7 +37,7 @@ SRC_URI = " \ | |||
37 | git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \ | 37 | git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \ |
38 | " | 38 | " |
39 | 39 | ||
40 | SRCREV = "8df367f3a7356337dba25666c52e73e3b0480df3" | 40 | SRCREV = "86d362f4ed6baeab0dfc6d892f18458a65ec7361" |
41 | 41 | ||
42 | S = "${WORKDIR}/git" | 42 | S = "${WORKDIR}/git" |
43 | 43 | ||
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb index cc25bd4..9f43fff 100644 --- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb +++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb | |||
@@ -47,8 +47,8 @@ RDEPENDS_${PN} = "\ | |||
47 | " | 47 | " |
48 | 48 | ||
49 | RDEPENDS_${PN}_append_linux = "\ | 49 | RDEPENDS_${PN}_append_linux = "\ |
50 | nativesdk-python-modules \ | 50 | nativesdk-python3-modules \ |
51 | nativesdk-python-misc \ | 51 | nativesdk-python3-misc \ |
52 | nativesdk-perl-modules \ | 52 | nativesdk-perl-modules \ |
53 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland-dev", "", d)} \ | 53 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland-dev", "", d)} \ |
54 | " | 54 | " |
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 27d5714..1050fb9 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -16,7 +16,7 @@ | |||
16 | 16 | ||
17 | <project name="poky" | 17 | <project name="poky" |
18 | remote="yocto" | 18 | remote="yocto" |
19 | revision="6a1f33cc40bfac33cf030fe41e1a8efd1e5fad6f" | 19 | revision="b0f3c0fb99d15b5914ac876b62ff16b3e11d0b80" |
20 | path="sources/poky"/> | 20 | path="sources/poky"/> |
21 | <project name="meta-openembedded" | 21 | <project name="meta-openembedded" |
22 | remote="oe-mirror" | 22 | remote="oe-mirror" |
@@ -24,7 +24,7 @@ | |||
24 | path="sources/meta-openembedded"/> | 24 | path="sources/meta-openembedded"/> |
25 | <project name="meta-qt5" | 25 | <project name="meta-qt5" |
26 | remote="qtyocto" | 26 | remote="qtyocto" |
27 | revision="9b12e74031f12c6ced4d69ee0a0780113501ee18" | 27 | revision="95f123a60a97428237164f96672b0c11c539efed" |
28 | path="sources/meta-qt5"/> | 28 | path="sources/meta-qt5"/> |
29 | <project name="meta-mingw" | 29 | <project name="meta-mingw" |
30 | remote="qtyocto" | 30 | remote="qtyocto" |
@@ -33,7 +33,7 @@ | |||
33 | 33 | ||
34 | <project name="meta-freescale" | 34 | <project name="meta-freescale" |
35 | remote="freescale" | 35 | remote="freescale" |
36 | revision="ec54f623eee97b75b7ad87503477316495c7fc26" | 36 | revision="fc804d29ee85d58e9bb66f7319e749b53e192457" |
37 | path="sources/meta-freescale" | 37 | path="sources/meta-freescale" |
38 | groups="notdefault,external,fsl,ti,smx6"/> | 38 | groups="notdefault,external,fsl,ti,smx6"/> |
39 | <project name="meta-ti" | 39 | <project name="meta-ti" |
@@ -48,7 +48,7 @@ | |||
48 | groups="notdefault,external,rpi"/> | 48 | groups="notdefault,external,rpi"/> |
49 | <project name="meta-freescale-3rdparty" | 49 | <project name="meta-freescale-3rdparty" |
50 | remote="freescale" | 50 | remote="freescale" |
51 | revision="065228815a7ca5201df1ed4c030b152054a5eda3" | 51 | revision="a78b17c24e66567f272ad47f9d6300e6b1b90c29" |
52 | path="sources/meta-freescale-3rdparty" | 52 | path="sources/meta-freescale-3rdparty" |
53 | groups="notdefault,external,fsl,smx6"/> | 53 | groups="notdefault,external,fsl,smx6"/> |
54 | <project name="meta-intel" | 54 | <project name="meta-intel" |
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index a556e4f..f29832d 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -59,7 +59,7 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | |||
59 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) | 59 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
60 | LAYERSCONF="bblayers.conf.fsl.sample" | 60 | LAYERSCONF="bblayers.conf.fsl.sample" |
61 | ;; | 61 | ;; |
62 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd) | 62 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd|imx7s-warp) |
63 | LAYERSCONF="bblayers.conf.fsl.sample" | 63 | LAYERSCONF="bblayers.conf.fsl.sample" |
64 | ;; | 64 | ;; |
65 | smarc-samx6i) | 65 | smarc-samx6i) |