diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-05-02 10:18:27 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-05-02 09:29:52 +0000 |
commit | 126c788b1a9d5b71ee876fb12b41ba594a75321b (patch) | |
tree | 0ff21e5f39bf78a454e516b719219855e9c9fc71 | |
parent | 1037ce1006ad2111c07e9a319aaf2525fb9dea92 (diff) | |
download | meta-boot2qt-126c788b1a9d5b71ee876fb12b41ba594a75321b.tar.gz |
qbsp: use correct image path
.. and make sure that component name does not contain a dash,
since that's not supported by IFW.
Change-Id: Ie611b4557c18b22ff56b9f1407376e59d7c71b0d
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | classes/qbsp.bbclass | 4 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | 3 | ||||
-rw-r--r-- | recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | 3 |
3 files changed, 6 insertions, 4 deletions
diff --git a/classes/qbsp.bbclass b/classes/qbsp.bbclass index 2dd42d0..fd6d14c 100644 --- a/classes/qbsp.bbclass +++ b/classes/qbsp.bbclass | |||
@@ -48,7 +48,7 @@ do_qbsp[depends] += "\ | |||
48 | " | 48 | " |
49 | 49 | ||
50 | QBSP_VERSION ?= "${PV}${VERSION_AUTO_INCREMENT}" | 50 | QBSP_VERSION ?= "${PV}${VERSION_AUTO_INCREMENT}" |
51 | QBSP_INSTALLER_COMPONENT ?= "${MACHINE}" | 51 | QBSP_INSTALLER_COMPONENT ?= "${@d.getVar('MACHINE', True).replace('-','')}" |
52 | QBSP_INSTALL_PATH ?= "/Extras/${MACHINE}" | 52 | QBSP_INSTALL_PATH ?= "/Extras/${MACHINE}" |
53 | 53 | ||
54 | QBSP_LICENSE_FILE ?= "" | 54 | QBSP_LICENSE_FILE ?= "" |
@@ -122,7 +122,7 @@ prepare_qbsp() { | |||
122 | patch_installer_files ${COMPONENT_PATH}/meta | 122 | patch_installer_files ${COMPONENT_PATH}/meta |
123 | 123 | ||
124 | mkdir -p ${B}/images/${QBSP_INSTALL_PATH}/images | 124 | mkdir -p ${B}/images/${QBSP_INSTALL_PATH}/images |
125 | 7zr x ${IMGDEPLOYDIR}/${IMAGE_PACKAGE} -o${B}/images/${QBSP_INSTALL_PATH}/images/ | 125 | 7zr x ${DEPLOY_DIR_IMAGE}/${IMAGE_PACKAGE} -o${B}/images/${QBSP_INSTALL_PATH}/images/ |
126 | 126 | ||
127 | cd ${B}/images | 127 | cd ${B}/images |
128 | 7zr a ${COMPONENT_PATH}/data/image.7z * | 128 | 7zr a ${COMPONENT_PATH}/data/image.7z * |
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb index ebd12c5..3f86016 100644 --- a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb | |||
@@ -40,7 +40,8 @@ inherit qbsp | |||
40 | 40 | ||
41 | PV = "1.1" | 41 | PV = "1.1" |
42 | 42 | ||
43 | QBSP_INSTALLER_COMPONENT = "qt.automotive.10.yocto.${MACHINE}" | 43 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" |
44 | QBSP_INSTALLER_COMPONENT = "qt.automotive.10.yocto.${QBSP_MACHINE}" | ||
44 | QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Automotive/${MACHINE}" | 45 | QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Automotive/${MACHINE}" |
45 | 46 | ||
46 | QBSP_SDK_TASK = "meta-toolchain-b2qt-automotive-qt5-sdk" | 47 | QBSP_SDK_TASK = "meta-toolchain-b2qt-automotive-qt5-sdk" |
diff --git a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb index 56da506..6fe8bf1 100644 --- a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb +++ b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb | |||
@@ -41,7 +41,8 @@ inherit qbsp | |||
41 | PV := "${@d.getVar('PV', True)[0:5]}" | 41 | PV := "${@d.getVar('PV', True)[0:5]}" |
42 | 42 | ||
43 | VERSION_SHORT = "${@d.getVar('QT_MODULE_BRANCH', True).replace('.','')}" | 43 | VERSION_SHORT = "${@d.getVar('QT_MODULE_BRANCH', True).replace('.','')}" |
44 | QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${MACHINE}" | 44 | QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}" |
45 | QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}" | ||
45 | QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Boot2Qt/${MACHINE}" | 46 | QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Boot2Qt/${MACHINE}" |
46 | 47 | ||
47 | QBSP_SDK_TASK = "meta-toolchain-b2qt-embedded-qt5-sdk" | 48 | QBSP_SDK_TASK = "meta-toolchain-b2qt-embedded-qt5-sdk" |