summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-08-29 16:42:02 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-08-30 05:29:11 +0000
commit21caf9ba0ffc1371c261a1a9c0e930a0ee2c277d (patch)
tree89f718201a4a799054542eea9dc493a0144394a3
parenta7999b69d3f3ee33d184494486c75e89e104bab0 (diff)
downloadmeta-boot2qt-21caf9ba0ffc1371c261a1a9c0e930a0ee2c277d.tar.gz
sdk: don't add qtwayland-scanner to mingw toolchain
There are number of wayland dependencies that will not compile for mingw toolchain. Task-number: QTBUG-62800 Change-Id: I2ffda4eb00831f21a27202d0a901cdb9719fe7f7 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
index 036410c..a65435f 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host.bb
@@ -33,6 +33,12 @@ PR = "r0"
33 33
34inherit nativesdk packagegroup qtquickcompiler 34inherit nativesdk packagegroup qtquickcompiler
35 35
36python __anonymous() {
37 overrides = d.getVar("OVERRIDES", True).split(":")
38 if "mingw32" not in overrides:
39 d.appendVar("OVERRIDES", ":linux")
40}
41
36RDEPENDS_${PN} += "\ 42RDEPENDS_${PN} += "\
37 nativesdk-packagegroup-b2qt-embedded-toolchain-host \ 43 nativesdk-packagegroup-b2qt-embedded-toolchain-host \
38 nativesdk-qttools-tools \ 44 nativesdk-qttools-tools \
@@ -42,5 +48,8 @@ RDEPENDS_${PN} += "\
42 nativesdk-qtdeclarative-staticdev \ 48 nativesdk-qtdeclarative-staticdev \
43 nativesdk-qt3d-tools \ 49 nativesdk-qt3d-tools \
44 nativesdk-qtscxml-tools \ 50 nativesdk-qtscxml-tools \
51 "
52
53RDEPENDS_${PN}_append_linux = "\
45 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-qtwayland-tools', '', d)} \ 54 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-qtwayland-tools', '', d)} \
46 " 55 "