diff options
author | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-05-22 12:40:13 +0300 |
---|---|---|
committer | Mikko Gronoff <mikko.gronoff@qt.io> | 2017-06-05 12:33:08 +0000 |
commit | 49af1e5e2a6fcd6f0d8722c411fe7a1a3847a424 (patch) | |
tree | 99ec7077a6661ea2f1b494f2a3a770217c9833e1 | |
parent | f140740aa76dbdbeed2c9e0f64f02d47123fb502 (diff) | |
download | meta-boot2qt-49af1e5e2a6fcd6f0d8722c411fe7a1a3847a424.tar.gz |
adbd: remove component
QDB replaced ADB in 5.9. Remove obsoleted adbd from image
and the recipe from meta layer.
Change-Id: I26c6ed7a51886e8e52bc77be6edcbe5933be3068
Reviewed-by: Kari Oikarinen <kari.oikarinen@qt.io>
-rw-r--r-- | conf/distro/include/beagleboard.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/beaglebone.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/nitrogen6x.conf | 2 | ||||
-rw-r--r-- | recipes-qt/b2qt-addons/qdbd/qdbd.service | 2 | ||||
-rw-r--r-- | recipes/adbd/adbd.bb | 87 | ||||
-rw-r--r-- | recipes/adbd/files/Makefile.adbd | 34 | ||||
-rwxr-xr-x | recipes/adbd/files/adb-init | 40 | ||||
-rw-r--r-- | recipes/adbd/files/adbd.patch | 265 | ||||
-rw-r--r-- | recipes/adbd/files/adbd.service | 12 | ||||
-rw-r--r-- | recipes/adbd/files/defaults | 4 | ||||
-rw-r--r-- | recipes/adbd/files/emulator/defaults | 4 | ||||
-rw-r--r-- | recipes/adbd/files/imx53qsb/defaults | 4 | ||||
-rw-r--r-- | recipes/adbd/files/intel-corei7-64/defaults | 4 | ||||
-rw-r--r-- | recipes/adbd/files/nvidia-logan/adb-init | 46 | ||||
-rw-r--r-- | recipes/adbd/files/nvidia-logan/defaults | 4 | ||||
-rw-r--r-- | recipes/adbd/files/raspberrypi/defaults | 4 | ||||
-rw-r--r-- | recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb | 1 |
17 files changed, 0 insertions, 517 deletions
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf index fa446d2..d9b92f0 100644 --- a/conf/distro/include/beagleboard.conf +++ b/conf/distro/include/beagleboard.conf | |||
@@ -32,5 +32,3 @@ include conf/distro/include/ti.inc | |||
32 | DEPLOY_CONF_NAME = "BeagleBoard" | 32 | DEPLOY_CONF_NAME = "BeagleBoard" |
33 | 33 | ||
34 | DISTRO_FEATURES_remove = "webengine opengl" | 34 | DISTRO_FEATURES_remove = "webengine opengl" |
35 | |||
36 | ADB_PRODUCTID = "0x9018" | ||
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf index 6f12d90..aa4e570 100644 --- a/conf/distro/include/beaglebone.conf +++ b/conf/distro/include/beaglebone.conf | |||
@@ -32,5 +32,3 @@ include conf/distro/include/ti.inc | |||
32 | DEPLOY_CONF_NAME = "BeagleBone Black" | 32 | DEPLOY_CONF_NAME = "BeagleBone Black" |
33 | 33 | ||
34 | DISTRO_FEATURES_remove = "webengine" | 34 | DISTRO_FEATURES_remove = "webengine" |
35 | |||
36 | ADB_PRODUCTID = "0xD002" | ||
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index e59faca..389ac03 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -85,5 +85,3 @@ KERNEL_DEVICETREE += "\ | |||
85 | MACHINE_EXTRA_INSTALL += "\ | 85 | MACHINE_EXTRA_INSTALL += "\ |
86 | bcm4330-nvram-config \ | 86 | bcm4330-nvram-config \ |
87 | " | 87 | " |
88 | |||
89 | ADB_PRODUCTID = "0x0d02" | ||
diff --git a/recipes-qt/b2qt-addons/qdbd/qdbd.service b/recipes-qt/b2qt-addons/qdbd/qdbd.service index 6c1b8e8..be8e701 100644 --- a/recipes-qt/b2qt-addons/qdbd/qdbd.service +++ b/recipes-qt/b2qt-addons/qdbd/qdbd.service | |||
@@ -1,8 +1,6 @@ | |||
1 | [Unit] | 1 | [Unit] |
2 | Description=Qt Debug Bridge Daemon | 2 | Description=Qt Debug Bridge Daemon |
3 | After=basic.target | 3 | After=basic.target |
4 | Before=adbd.service | ||
5 | Conflicts=adbd.service | ||
6 | 4 | ||
7 | [Service] | 5 | [Service] |
8 | Type=forking | 6 | Type=forking |
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb deleted file mode 100644 index 7bada5d..0000000 --- a/recipes/adbd/adbd.bb +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Android Debug Bridge Daemon" | ||
31 | HOMEPAGE = "http://developer.android.com/tools/help/adb.html" | ||
32 | SECTION = "devel" | ||
33 | LICENSE = "Apache-2.0" | ||
34 | LIC_FILES_CHKSUM = "file://adb/NOTICE;md5=2ddb23e63b1f9c3c46aaa4195f819a6d" | ||
35 | |||
36 | PV = "android-5.0.1_r1" | ||
37 | PR = "r0" | ||
38 | SRCREV = "${PV}" | ||
39 | |||
40 | RRECOMMENDS_${PN} += "kernel-module-g-ffs" | ||
41 | DEPENDS = "openssl libcap" | ||
42 | |||
43 | SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https;branch=lollipop-release;name=core \ | ||
44 | file://adbd.patch \ | ||
45 | file://Makefile.adbd \ | ||
46 | file://adb-init \ | ||
47 | file://defaults \ | ||
48 | file://adbd.service \ | ||
49 | " | ||
50 | |||
51 | S = "${WORKDIR}/git" | ||
52 | |||
53 | FILES_${PN} += "${bindir}/adbd" | ||
54 | |||
55 | do_configure() { | ||
56 | if [ -n "${ADB_PRODUCTID}" ]; then | ||
57 | sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | do_compile() { | ||
62 | make -f ${WORKDIR}/Makefile.adbd -C adb | ||
63 | } | ||
64 | |||
65 | do_install() { | ||
66 | install -m 0755 -d ${D}${bindir}/ | ||
67 | install -m 0755 ${WORKDIR}/git/adb/adbd ${D}${bindir}/ | ||
68 | install -m 0755 ${WORKDIR}/adb-init ${D}${bindir}/ | ||
69 | |||
70 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
71 | ln -s ${bindir}/adb-init ${D}${sysconfdir}/init.d/ | ||
72 | |||
73 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
74 | install -m 0644 ${WORKDIR}/adbd.service ${D}${systemd_unitdir}/system/ | ||
75 | |||
76 | install -m 0755 -d ${D}${sysconfdir}/default | ||
77 | install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd | ||
78 | } | ||
79 | |||
80 | INITSCRIPT_NAME = "adb-init" | ||
81 | INITSCRIPT_PARAMS = "defaults 96" | ||
82 | |||
83 | SYSTEMD_SERVICE_${PN} = "adbd.service" | ||
84 | # qdbd is started by default instead of adbd | ||
85 | SYSTEMD_AUTO_ENABLE = "disable" | ||
86 | |||
87 | inherit update-rc.d systemd | ||
diff --git a/recipes/adbd/files/Makefile.adbd b/recipes/adbd/files/Makefile.adbd deleted file mode 100644 index 753d2d7..0000000 --- a/recipes/adbd/files/Makefile.adbd +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | LOCAL_SRC_FILES := \ | ||
2 | adb.c \ | ||
3 | fdevent.c \ | ||
4 | transport.c \ | ||
5 | transport_local.c \ | ||
6 | transport_usb.c \ | ||
7 | adb_auth_client.c \ | ||
8 | sockets.c \ | ||
9 | services.c \ | ||
10 | file_sync_service.c \ | ||
11 | jdwp_service.c \ | ||
12 | framebuffer_service.c \ | ||
13 | remount_service.c \ | ||
14 | usb_linux_client.c | ||
15 | |||
16 | LOCAL_OBJ_FILES=$(LOCAL_SRC_FILES:%.c=%.o) | ||
17 | |||
18 | LIBCUTILS_SRC_FILES := \ | ||
19 | ../libcutils/socket_inaddr_any_server.c \ | ||
20 | ../libcutils/socket_local_client.c \ | ||
21 | ../libcutils/socket_local_server.c \ | ||
22 | ../libcutils/socket_loopback_client.c \ | ||
23 | ../libcutils/socket_loopback_server.c | ||
24 | |||
25 | LIBCUTILS_OBJ_FILES=$(LIBCUTILS_SRC_FILES:%.c=%.o) | ||
26 | |||
27 | adbd: $(LOCAL_OBJ_FILES) $(LIBCUTILS_OBJ_FILES) | ||
28 | $(CC) $(LDFLAGS) $^ -o $@ -lcrypto -Wl,--as-needed -ldl -lpthread -lresolv | ||
29 | |||
30 | ../libcutils/%.o: ../libcutils/%.c | ||
31 | $(CC) -O2 -g -DADB_HOST=1 -Wall -Wno-unused-parameter -D_XOPEN_SOURCE -D_GNU_SOURCE -c $^ -o $@ -I../include/ -DHAVE_TERMIO_H -DHAVE_FORKEXEC | ||
32 | |||
33 | %.o: %.c | ||
34 | $(CC) -O2 -g -DADB_QEMU=0 -DADB_HOST=0 -Wall -Wno-unused-parameter -D_XOPEN_SOURCE -D_GNU_SOURCE -c $^ -o $@ -isystem . -I../include/ -DHAVE_TERMIO_H -DHAVE_FORKEXEC | ||
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init deleted file mode 100755 index 5f47fd0..0000000 --- a/recipes/adbd/files/adb-init +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | DAEMON=/usr/bin/adbd | ||
4 | |||
5 | . /etc/default/adbd | ||
6 | |||
7 | if [ -e /var/run/dbus/session_bus_address ]; then | ||
8 | . /var/run/dbus/session_bus_address | ||
9 | fi | ||
10 | |||
11 | case "$1" in | ||
12 | start) | ||
13 | if [ "$USE_ETHERNET" = "no" ]; then | ||
14 | modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL:0:32} | ||
15 | mkdir -p /dev/usb-ffs | ||
16 | chmod 770 /dev/usb-ffs | ||
17 | mkdir -p /dev/usb-ffs/adb | ||
18 | chmod 770 /dev/usb-ffs/adb | ||
19 | mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0 | ||
20 | fi | ||
21 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
22 | ;; | ||
23 | stop) | ||
24 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
25 | if [ "$USE_ETHERNET" = "no" ]; then | ||
26 | sleep 1 | ||
27 | umount /dev/usb-ffs/adb | ||
28 | rmmod g_ffs | ||
29 | fi | ||
30 | ;; | ||
31 | restart) | ||
32 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
33 | sleep 1 | ||
34 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
35 | ;; | ||
36 | *) | ||
37 | echo "Usage: $0 {start|stop|restart}" | ||
38 | exit 1 | ||
39 | esac | ||
40 | exit 0 | ||
diff --git a/recipes/adbd/files/adbd.patch b/recipes/adbd/files/adbd.patch deleted file mode 100644 index 479a049..0000000 --- a/recipes/adbd/files/adbd.patch +++ /dev/null | |||
@@ -1,265 +0,0 @@ | |||
1 | diff --git a/adb/adb.c b/adb/adb.c | ||
2 | index 10a1e0d..99fca49 100644 | ||
3 | --- a/adb/adb.c | ||
4 | +++ b/adb/adb.c | ||
5 | @@ -35,12 +35,10 @@ | ||
6 | |||
7 | #if !ADB_HOST | ||
8 | #include <cutils/properties.h> | ||
9 | -#include <private/android_filesystem_config.h> | ||
10 | #include <sys/capability.h> | ||
11 | #include <sys/mount.h> | ||
12 | #include <sys/prctl.h> | ||
13 | #include <getopt.h> | ||
14 | -#include <selinux/selinux.h> | ||
15 | #else | ||
16 | #include "usb_vendors.h" | ||
17 | #endif | ||
18 | @@ -147,7 +145,7 @@ void adb_trace_init(void) | ||
19 | } | ||
20 | } | ||
21 | |||
22 | -#if !ADB_HOST | ||
23 | +#if !ADB_HOST && ADB_QEMU | ||
24 | /* | ||
25 | * Implements ADB tracing inside the emulator. | ||
26 | */ | ||
27 | @@ -288,6 +286,22 @@ static void send_close(unsigned local, unsigned remote, atransport *t) | ||
28 | send_packet(p, t); | ||
29 | } | ||
30 | |||
31 | +int property_set(const char *key, const char *value) | ||
32 | +{ | ||
33 | + return 0; | ||
34 | +} | ||
35 | + | ||
36 | +int property_get(const char *key, char *value, const char *fallback) | ||
37 | +{ | ||
38 | + if (fallback) { | ||
39 | + strncpy(value, fallback, PROPERTY_VALUE_MAX-1); | ||
40 | + return strlen(fallback); | ||
41 | + } else { | ||
42 | + value[0] = 0; | ||
43 | + return 0; | ||
44 | + } | ||
45 | +} | ||
46 | + | ||
47 | static size_t fill_connect_data(char *buf, size_t bufsize) | ||
48 | { | ||
49 | #if ADB_HOST | ||
50 | @@ -1344,50 +1358,11 @@ int adb_main(int is_daemon, int server_port) | ||
51 | " unchanged.\n"); | ||
52 | } | ||
53 | |||
54 | - /* add extra groups: | ||
55 | - ** AID_ADB to access the USB driver | ||
56 | - ** AID_LOG to read system logs (adb logcat) | ||
57 | - ** AID_INPUT to diagnose input issues (getevent) | ||
58 | - ** AID_INET to diagnose network issues (netcfg, ping) | ||
59 | - ** AID_GRAPHICS to access the frame buffer | ||
60 | - ** AID_NET_BT and AID_NET_BT_ADMIN to diagnose bluetooth (hcidump) | ||
61 | - ** AID_SDCARD_R to allow reading from the SD card | ||
62 | - ** AID_SDCARD_RW to allow writing to the SD card | ||
63 | - ** AID_NET_BW_STATS to read out qtaguid statistics | ||
64 | - */ | ||
65 | - gid_t groups[] = { AID_ADB, AID_LOG, AID_INPUT, AID_INET, AID_GRAPHICS, | ||
66 | - AID_NET_BT, AID_NET_BT_ADMIN, AID_SDCARD_R, AID_SDCARD_RW, | ||
67 | - AID_NET_BW_STATS }; | ||
68 | - if (setgroups(sizeof(groups)/sizeof(groups[0]), groups) != 0) { | ||
69 | - exit(1); | ||
70 | - } | ||
71 | - | ||
72 | - /* don't listen on a port (default 5037) if running in secure mode */ | ||
73 | - /* don't run as root if we are running in secure mode */ | ||
74 | - if (should_drop_privileges()) { | ||
75 | - drop_capabilities_bounding_set_if_needed(); | ||
76 | |||
77 | - /* then switch user and group to "shell" */ | ||
78 | - if (setgid(AID_SHELL) != 0) { | ||
79 | - exit(1); | ||
80 | - } | ||
81 | - if (setuid(AID_SHELL) != 0) { | ||
82 | - exit(1); | ||
83 | - } | ||
84 | - | ||
85 | - D("Local port disabled\n"); | ||
86 | - } else { | ||
87 | - char local_name[30]; | ||
88 | - if ((root_seclabel != NULL) && (is_selinux_enabled() > 0)) { | ||
89 | - // b/12587913: fix setcon to allow const pointers | ||
90 | - if (setcon((char *)root_seclabel) < 0) { | ||
91 | - exit(1); | ||
92 | - } | ||
93 | - } | ||
94 | - build_local_name(local_name, sizeof(local_name), server_port); | ||
95 | - if(install_listener(local_name, "*smartsocket*", NULL, 0)) { | ||
96 | - exit(1); | ||
97 | - } | ||
98 | + char local_name[30]; | ||
99 | + build_local_name(local_name, sizeof(local_name), server_port); | ||
100 | + if(install_listener(local_name, "*smartsocket*", NULL, 0)) { | ||
101 | + exit(1); | ||
102 | } | ||
103 | |||
104 | int usb = 0; | ||
105 | @@ -1408,10 +1383,9 @@ int adb_main(int is_daemon, int server_port) | ||
106 | printf("using port=%d\n", port); | ||
107 | // listen on TCP port specified by service.adb.tcp.port property | ||
108 | local_init(port); | ||
109 | - } else if (!usb) { | ||
110 | - // listen on default port | ||
111 | - local_init(DEFAULT_ADB_LOCAL_TRANSPORT_PORT); | ||
112 | } | ||
113 | + // listen on default port | ||
114 | + local_init(DEFAULT_ADB_LOCAL_TRANSPORT_PORT); | ||
115 | |||
116 | D("adb_main(): pre init_jdwp()\n"); | ||
117 | init_jdwp(); | ||
118 | @@ -1695,7 +1669,6 @@ int main(int argc, char **argv) | ||
119 | #else | ||
120 | /* If adbd runs inside the emulator this will enable adb tracing via | ||
121 | * adb-debug qemud service in the emulator. */ | ||
122 | - adb_qemu_trace_init(); | ||
123 | while(1) { | ||
124 | int c; | ||
125 | int option_index = 0; | ||
126 | diff --git a/adb/adb_trace.h b/adb/adb_trace.h | ||
127 | index 8a5d9f8..01c4c06 100644 | ||
128 | --- a/adb/adb_trace.h | ||
129 | +++ b/adb/adb_trace.h | ||
130 | @@ -22,7 +22,7 @@ | ||
131 | #endif | ||
132 | |||
133 | /* define ADB_TRACE to 1 to enable tracing support, or 0 to disable it */ | ||
134 | -#define ADB_TRACE 1 | ||
135 | +#define ADB_TRACE 0 | ||
136 | |||
137 | /* IMPORTANT: if you change the following list, don't | ||
138 | * forget to update the corresponding 'tags' table in | ||
139 | diff --git a/adb/file_sync_service.c b/adb/file_sync_service.c | ||
140 | index 7933858..3cbd0cd 100644 | ||
141 | --- a/adb/file_sync_service.c | ||
142 | +++ b/adb/file_sync_service.c | ||
143 | @@ -26,7 +26,6 @@ | ||
144 | |||
145 | #include <errno.h> | ||
146 | #include <private/android_filesystem_config.h> | ||
147 | -#include <selinux/android.h> | ||
148 | #include "sysdeps.h" | ||
149 | |||
150 | #define TRACE_TAG TRACE_SYNC | ||
151 | @@ -73,7 +72,6 @@ static int mkdirs(char *name) | ||
152 | *x = '/'; | ||
153 | return ret; | ||
154 | } | ||
155 | - selinux_android_restorecon(name, 0); | ||
156 | } | ||
157 | *x++ = '/'; | ||
158 | } | ||
159 | @@ -251,7 +249,6 @@ static int handle_send_file(int s, char *path, uid_t uid, | ||
160 | if(fd >= 0) { | ||
161 | struct utimbuf u; | ||
162 | adb_close(fd); | ||
163 | - selinux_android_restorecon(path, 0); | ||
164 | u.actime = timestamp; | ||
165 | u.modtime = timestamp; | ||
166 | utime(path, &u); | ||
167 | diff --git a/adb/remount_service.c b/adb/remount_service.c | ||
168 | index 72d15a1..df64799 100644 | ||
169 | --- a/adb/remount_service.c | ||
170 | +++ b/adb/remount_service.c | ||
171 | @@ -28,7 +28,7 @@ | ||
172 | #include "adb.h" | ||
173 | |||
174 | |||
175 | -static int system_ro = 1; | ||
176 | +static int system_ro = 0; | ||
177 | static int vendor_ro = 1; | ||
178 | |||
179 | /* Returns the device used to mount a directory in /proc/mounts */ | ||
180 | @@ -84,7 +84,7 @@ static int remount(const char* dir, int* dir_ro) | ||
181 | int fd; | ||
182 | int OFF = 0; | ||
183 | |||
184 | - if (dir_ro == 0) { | ||
185 | + if (*dir_ro == 0) { | ||
186 | return 0; | ||
187 | } | ||
188 | |||
189 | @@ -132,7 +132,6 @@ void remount_service(int fd, void *cookie) | ||
190 | else { | ||
191 | write_string(fd, "remount failed\n"); | ||
192 | } | ||
193 | - | ||
194 | adb_close(fd); | ||
195 | } | ||
196 | |||
197 | diff --git a/adb/services.c b/adb/services.c | ||
198 | index e61371a..8d4e2b5 100644 | ||
199 | --- a/adb/services.c | ||
200 | +++ b/adb/services.c | ||
201 | @@ -34,7 +34,7 @@ | ||
202 | # include <sys/ioctl.h> | ||
203 | # endif | ||
204 | #else | ||
205 | -# include <cutils/android_reboot.h> | ||
206 | +# include <sys/reboot.h> | ||
207 | # include <cutils/properties.h> | ||
208 | #endif | ||
209 | |||
210 | @@ -127,7 +127,7 @@ void reboot_service(int fd, void *arg) | ||
211 | goto cleanup; | ||
212 | } | ||
213 | |||
214 | - ret = property_set(ANDROID_RB_PROPERTY, property_val); | ||
215 | + ret = reboot(RB_AUTOBOOT); | ||
216 | if (ret < 0) { | ||
217 | snprintf(buf, sizeof(buf), "reboot failed: %d\n", ret); | ||
218 | writex(fd, buf, strlen(buf)); | ||
219 | @@ -302,7 +302,7 @@ static int create_subproc_raw(const char *cmd, const char *arg0, const char *arg | ||
220 | #if ADB_HOST | ||
221 | #define SHELL_COMMAND "/bin/sh" | ||
222 | #else | ||
223 | -#define SHELL_COMMAND "/system/bin/sh" | ||
224 | +#define SHELL_COMMAND "/bin/sh" | ||
225 | #endif | ||
226 | |||
227 | #if !ADB_HOST | ||
228 | diff --git a/adb/transport_local.c b/adb/transport_local.c | ||
229 | index 948cc15..d6d0a3a 100644 | ||
230 | --- a/adb/transport_local.c | ||
231 | +++ b/adb/transport_local.c | ||
232 | @@ -189,7 +189,7 @@ static void *server_socket_thread(void * arg) | ||
233 | } | ||
234 | |||
235 | /* This is relevant only for ADB daemon running inside the emulator. */ | ||
236 | -#if !ADB_HOST | ||
237 | +#if !ADB_HOST && ADB_QEMU | ||
238 | /* | ||
239 | * Redefine open and write for qemu_pipe.h that contains inlined references | ||
240 | * to those routines. We will redifine them back after qemu_pipe.h inclusion. | ||
241 | @@ -307,7 +307,7 @@ void local_init(int port) | ||
242 | if(HOST) { | ||
243 | func = client_socket_thread; | ||
244 | } else { | ||
245 | -#if ADB_HOST | ||
246 | +#if ADB_HOST || !ADB_QEMU | ||
247 | func = server_socket_thread; | ||
248 | #else | ||
249 | /* For the adbd daemon in the system image we need to distinguish | ||
250 | diff --git a/include/cutils/properties.h b/include/cutils/properties.h | ||
251 | index 798db8b..c86f312 100644 | ||
252 | --- a/include/cutils/properties.h | ||
253 | +++ b/include/cutils/properties.h | ||
254 | @@ -19,8 +19,9 @@ | ||
255 | |||
256 | #include <sys/cdefs.h> | ||
257 | #include <stddef.h> | ||
258 | -#include <sys/system_properties.h> | ||
259 | -#include <stdint.h> | ||
260 | + | ||
261 | +#define PROP_NAME_MAX 32 | ||
262 | +#define PROP_VALUE_MAX 92 | ||
263 | |||
264 | #ifdef __cplusplus | ||
265 | extern "C" { | ||
diff --git a/recipes/adbd/files/adbd.service b/recipes/adbd/files/adbd.service deleted file mode 100644 index d5005cf..0000000 --- a/recipes/adbd/files/adbd.service +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=ADB Server Daemon | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | ExecStart=/usr/bin/adb-init start | ||
8 | ExecStop=/usr/bin/adb-init stop | ||
9 | Environment=HOME=/home/root | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/recipes/adbd/files/defaults b/recipes/adbd/files/defaults deleted file mode 100644 index d2a3cc0..0000000 --- a/recipes/adbd/files/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=no | ||
diff --git a/recipes/adbd/files/emulator/defaults b/recipes/adbd/files/emulator/defaults deleted file mode 100644 index 0fbba4c..0000000 --- a/recipes/adbd/files/emulator/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=yes | ||
diff --git a/recipes/adbd/files/imx53qsb/defaults b/recipes/adbd/files/imx53qsb/defaults deleted file mode 100644 index 0fbba4c..0000000 --- a/recipes/adbd/files/imx53qsb/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=yes | ||
diff --git a/recipes/adbd/files/intel-corei7-64/defaults b/recipes/adbd/files/intel-corei7-64/defaults deleted file mode 100644 index 0fbba4c..0000000 --- a/recipes/adbd/files/intel-corei7-64/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=yes | ||
diff --git a/recipes/adbd/files/nvidia-logan/adb-init b/recipes/adbd/files/nvidia-logan/adb-init deleted file mode 100644 index 1be08c8..0000000 --- a/recipes/adbd/files/nvidia-logan/adb-init +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | DAEMON=/usr/bin/adbd | ||
4 | |||
5 | . /etc/default/adbd | ||
6 | |||
7 | case "$1" in | ||
8 | start) | ||
9 | if [ "$USE_ETHERNET" = "no" ]; then | ||
10 | echo 0 > /sys/class/android_usb/android0/enable | ||
11 | sleep 1 | ||
12 | echo ${SERIAL} > /sys/class/android_usb/android0/iSerial | ||
13 | echo ${VENDOR} > /sys/class/android_usb/android0/idVendor | ||
14 | echo ${PRODUCT} > /sys/class/android_usb/android0/idProduct | ||
15 | echo ffs > /sys/class/android_usb/android0/functions | ||
16 | echo adb >/sys/class/android_usb/android0/f_ffs/aliases | ||
17 | echo 1 > /sys/class/android_usb/android0/enable | ||
18 | |||
19 | if [ ! -d "/dev/usb-ffs" ]; then | ||
20 | mkdir /dev/usb-ffs | ||
21 | mkdir /dev/usb-ffs/adb | ||
22 | fi | ||
23 | mount -t functionfs adb /dev/usb-ffs/adb -o uid=2000,gid=2000 | ||
24 | fi | ||
25 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
26 | ;; | ||
27 | stop) | ||
28 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
29 | if [ "$USE_ETHERNET" = "no" ]; then | ||
30 | sleep 1 | ||
31 | if mount | grep /dev/usb-ffs/adb > /dev/null; then | ||
32 | umount /dev/usb-ffs/adb | ||
33 | fi | ||
34 | fi | ||
35 | ;; | ||
36 | restart) | ||
37 | start-stop-daemon --stop --quiet --exec $DAEMON | ||
38 | sleep 1 | ||
39 | start-stop-daemon --start --quiet --exec $DAEMON & | ||
40 | ;; | ||
41 | *) | ||
42 | echo "Usage: $0 {start|stop|restart}" | ||
43 | exit 1 | ||
44 | esac | ||
45 | exit 0 | ||
46 | |||
diff --git a/recipes/adbd/files/nvidia-logan/defaults b/recipes/adbd/files/nvidia-logan/defaults deleted file mode 100644 index 93bba63..0000000 --- a/recipes/adbd/files/nvidia-logan/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0955 | ||
2 | PRODUCT=7940 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth1/address) | ||
4 | USE_ETHERNET=no | ||
diff --git a/recipes/adbd/files/raspberrypi/defaults b/recipes/adbd/files/raspberrypi/defaults deleted file mode 100644 index 0fbba4c..0000000 --- a/recipes/adbd/files/raspberrypi/defaults +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | VENDOR=0x18d1 | ||
2 | PRODUCT=0x0000 | ||
3 | SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address) | ||
4 | USE_ETHERNET=yes | ||
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb index c6361c7..e8936e4 100644 --- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb +++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb | |||
@@ -34,7 +34,6 @@ PR = "r0" | |||
34 | inherit packagegroup | 34 | inherit packagegroup |
35 | 35 | ||
36 | RDEPENDS_${PN} = "\ | 36 | RDEPENDS_${PN} = "\ |
37 | adbd \ | ||
38 | alsa-utils-amixer \ | 37 | alsa-utils-amixer \ |
39 | binutils \ | 38 | binutils \ |
40 | binutils-symlinks \ | 39 | binutils-symlinks \ |