diff options
author | Dominik Holland <dominik.holland@pelagicore.com> | 2017-07-06 10:30:41 +0200 |
---|---|---|
committer | Dominik Holland <dominik.holland@pelagicore.com> | 2017-07-20 08:46:07 +0000 |
commit | 8c13aef478448114a8fe0ac112e26b59d7ad03d4 (patch) | |
tree | 941df382c0206de40720760017bd5a4dedd322fb | |
parent | ab097355d593244bf0b5ea5a62ee7b04d1a0a5a3 (diff) | |
download | meta-boot2qt-8c13aef478448114a8fe0ac112e26b59d7ad03d4.tar.gz |
qtivi: Use the latest version from 'dev'
This also introduces fetching the qface submodule
and the new default PACKAGECONFIG for the ivigenerator.
For the ivigenerator new native and nativesdk packages
are needed, which have a dependency towards python3 and
python3-virtualenv
Task-number: QTAUTO-472
Change-Id: I4e86168f4249c53c521c60cc2e1d44e91e968f4d
Reviewed-by: Gordan Markus <gordan.markus@pelagicore.com>
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 40 |
1 files changed, 35 insertions, 5 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index 103933f..3dbf07e 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -35,18 +35,48 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | |||
35 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ | 35 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ |
36 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" | 36 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" |
37 | 37 | ||
38 | DEPENDS = "qtbase qtdeclarative qtmultimedia" | 38 | DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native" |
39 | 39 | DEPENDS_class-native = "qtbase" | |
40 | SRCREV = "40e8ba1c8dd89474c4d890a3e050890d0cd9654e" | 40 | DEPENDS_class-nativesdk = "qtbase" |
41 | 41 | ||
42 | inherit qt5-module | 42 | inherit qt5-module |
43 | inherit python3native | ||
43 | require recipes-qt/qt5/qt5-git.inc | 44 | require recipes-qt/qt5/qt5-git.inc |
44 | 45 | ||
45 | PACKAGECONFIG ?= "taglib dlt" | 46 | QT_MODULE_BRANCH_QFACE = "upstream/develop" |
47 | |||
48 | SRC_URI += " \ | ||
49 | ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \ | ||
50 | " | ||
51 | |||
52 | SRCREV_qtivi = "3205b6e8f57273096ae60d8f6fcdbe597c350393" | ||
53 | SRCREV_qface = "b1d96d85a7c43ac74335b9a1a99a68507047f5bc" | ||
54 | SRCREV = "${SRCREV_qtivi}" | ||
55 | SRCREV_FORMAT = "qtivi_qface" | ||
56 | |||
57 | PACKAGECONFIG ?= "taglib dlt ivigenerator" | ||
46 | PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" | 58 | PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" |
47 | PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" | 59 | PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" |
48 | PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" | 60 | PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" |
61 | # For cross-compiling tell qtivi to use the system-ivigenerator, which is installed by the native recipe" | ||
62 | PACKAGECONFIG[ivigenerator] = "QMAKE_EXTRA_ARGS+=-system-ivigenerator" | ||
63 | PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python3 python3-virtualenv" | ||
64 | PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only" | ||
65 | |||
66 | PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" | ||
67 | PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" | ||
68 | |||
69 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}" | ||
49 | 70 | ||
50 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" | 71 | do_compile_prepend() { |
72 | # Otherwise pip might cache or reuse something from our home folder | ||
73 | export HOME="${STAGING_DATADIR_NATIVE}" | ||
74 | # This is needed as otherwise the virtualenv tries to use the libs from the host | ||
75 | export LD_LIBRARY_PATH="${STAGING_LIBDIR_NATIVE}" | ||
76 | # Let qtivi use the python3-native binaries | ||
77 | export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native" | ||
78 | } | ||
51 | 79 | ||
80 | BBCLASSEXTEND += "native nativesdk" | ||
52 | 81 | ||
82 | INSANE_SKIP_${PN}_class-native = "already-stripped" | ||