summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-25 16:16:13 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-25 16:16:59 +0300
commit0765ab46150bfa6a930487e25ecb0eed365d90f1 (patch)
tree6ad4a5b5b24828ffdf6897f3f90197cd281624c5
parent38f883909812a8ca6815431295c8a0fa4e92489d (diff)
parent960945859db570e237c022b2c3269cec3902c876 (diff)
downloadmeta-boot2qt-0765ab46150bfa6a930487e25ecb0eed365d90f1.tar.gz
Merge remote-tracking branch 'origin/jethro' into dev
* origin/jethro: Update meta layers Reuse qt5-git.inc in automotive recipes ota: update recipe Correctly update qtquickcompiler SHA1 Reuse qt5-git.inc to define git repo location Remove automotive recipes Update Qt5 submodules Handle qtquickcompiler in update-qt5-modules.sh script qtwebbrowser: update source uri Correctly use QtQuickCompiler when available gammaray: update revision to match gammaray plugin in QtC 4.1 Fix adb to toradex-imx6 image Change git protocol from ssh to http Update qtdeclarative module Update boot2qt-demos version Change-Id: I1665b538bcd12a0dffb6403a6d387eebb100c762
-rw-r--r--classes/internal-build.bbclass1
-rw-r--r--classes/qtquickcompiler.bbclass20
-rw-r--r--conf/local.conf.sample3
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend (renamed from conf/distro/b2qt-auto.conf)10
-rw-r--r--recipes-qt/automotive/gammaray_git.bb2
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb12
-rw-r--r--recipes-qt/automotive/qmllive-target_git.bb43
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb10
-rw-r--r--recipes-qt/automotive/qtivi_git.bb10
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb11
-rw-r--r--recipes-qt/b2qt-addons/b2qt-demos.bb6
-rw-r--r--recipes-qt/b2qt-addons/b2qt-launcher.bb10
-rw-r--r--recipes-qt/b2qt-addons/democompositor_git.bb7
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb2
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb1
-rw-r--r--recipes-qt/qt5/qtotaupdate.bb (renamed from recipes-qt/b2qt-addons/b2qt-ota.bb)22
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb (renamed from recipes-qt/qt5-addons/qtquickcompiler_git.bb)0
-rw-r--r--recipes/os-release/os-release.bbappend47
-rw-r--r--scripts/manifest.xml4
-rwxr-xr-xscripts/update-qt5-modules.sh3
22 files changed, 99 insertions, 127 deletions
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass
index 3b7f422..ecee863 100644
--- a/classes/internal-build.bbclass
+++ b/classes/internal-build.bbclass
@@ -34,6 +34,7 @@ python enable_internal_build () {
34 except: 34 except:
35 return 35 return
36 36
37 e.data.setVar('ENABLE_QTQUICKCOMPILER', "1")
37 e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH") 38 e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH")
38 e.data.setVar('PREMIRRORS', "\ 39 e.data.setVar('PREMIRRORS', "\
39 ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \ 40 ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass
index 8dbaf49..3564ad1 100644
--- a/classes/qtquickcompiler.bbclass
+++ b/classes/qtquickcompiler.bbclass
@@ -28,18 +28,18 @@
28############################################################################ 28############################################################################
29 29
30python __anonymous() { 30python __anonymous() {
31 provider = "qtquickcompiler" 31 provider = ""
32 sdk_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk"
33 pn = d.getVar("PN", True)
32 34
33 sdk_path = d.getVar('QT_SDK_PATH', True) or "" 35 if d.getVar('ENABLE_QTQUICKCOMPILER', True) == "1":
34 if len(sdk_path) != 0: 36 provider = "qtquickcompiler"
35 qtquickcompiler_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk" 37 elif os.path.isdir(sdk_path):
36 if not os.path.isdir(qtquickcompiler_path): 38 provider = "qtquickcompiler-sdk"
37 bb.note("QtQuickCompiler not available") 39 else:
38 return 40 bb.note("qtquickcompiler not enabled for %s" % pn)
39 else: 41 return
40 provider = "qtquickcompiler-sdk"
41 42
42 pn = d.getVar("PN", True)
43 if "toolchain-host" in pn: 43 if "toolchain-host" in pn:
44 d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider) 44 d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider)
45 if "toolchain-target" in pn: 45 if "toolchain-target" in pn:
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index 9a1eb66..6851361 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -281,6 +281,9 @@ INHERIT += "rm_work"
281INHERIT += "image-buildinfo" 281INHERIT += "image-buildinfo"
282INHERIT += "internal-build" 282INHERIT += "internal-build"
283 283
284# Enables use of QtQuickCompiler if you have access to the gerrit project
285#ENABLE_QTQUICKCOMPILER = "1"
286
284ACCEPT_FSL_EULA = "1" 287ACCEPT_FSL_EULA = "1"
285LICENSE_FLAGS_WHITELIST = "commercial" 288LICENSE_FLAGS_WHITELIST = "commercial"
286 289
diff --git a/conf/distro/b2qt-auto.conf b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
index 2744cad..b696b19 100644
--- a/conf/distro/b2qt-auto.conf
+++ b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
@@ -27,7 +27,11 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30include conf/distro/b2qt.conf 30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = ""
31 32
32PREFERRED_VERSION_qtwayland = "5.6%" 33do_configure_prepend () {
33PREFERRED_VERSION_qtwayland-native = "5.6%" 34 # FunctionFS for adb
35 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
37}
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
index 06fe24a..0456023 100644
--- a/recipes-qt/automotive/gammaray_git.bb
+++ b/recipes-qt/automotive/gammaray_git.bb
@@ -9,7 +9,7 @@ inherit cmake_qt5
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" 9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10 10
11BRANCH = "master" 11BRANCH = "master"
12SRCREV = "4e8ff158816f07ced45a2cc71cf4176b7c0656d2" 12SRCREV = "6262eaeaee74109f9c1bd85de99c9b039d8938f5"
13PV = "master+git${SRCPV}" 13PV = "master+git${SRCPV}"
14 14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d" 15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d"
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index 70f213b..66703c6 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -31,17 +31,17 @@ DESCRIPTION = "Neptune IVI UI"
31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" 31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c"
33 33
34inherit qt5-module sdk-sources systemd 34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-neptune-ui"
37 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \ 38QT_MODULE_BRANCH = "master"
39
40SRC_URI += " \
38 file://neptune.service \ 41 file://neptune.service \
39 " 42 "
40 43
41SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814" 44SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814"
42BRANCH = "master"
43
44S = "${WORKDIR}/git"
45 45
46DEPENDS = "qtbase qtdeclarative" 46DEPENDS = "qtbase qtdeclarative"
47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ 47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb
index efcac4d..7819941 100644
--- a/recipes-qt/automotive/qmllive-target_git.bb
+++ b/recipes-qt/automotive/qmllive-target_git.bb
@@ -1,19 +1,48 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
1DESCRIPTION = "QML Live target runtime" 30DESCRIPTION = "QML Live target runtime"
2 31
3LICENSE = "GPL-3.0" 32LICENSE = "GPL-3.0"
4LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" 33LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
5 34
6inherit qmake5 sdk-sources 35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc
7 37
8FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 38QT_MODULE = "qt-apps-qmllive"
39QT_MODULE_BRANCH = "master"
9 40
10SRC_URI = " \ 41SRC_URI += " \
11 git://codereview.qt-project.org/qt-apps/qmllive.git;branch=${BRANCH};protocol=ssh;name=tools \
12 file://qmllive-target.patch \ 42 file://qmllive-target.patch \
13" 43 "
14 44
15BRANCH = "master" 45SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
16SRCREV_tools="d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
17 46
18S = "${WORKDIR}/git/src/runtime" 47S = "${WORKDIR}/git/src/runtime"
19 48
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index fd128bd..028df78 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -31,21 +31,15 @@ DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35 35require recipes-qt/qt5/qt5-git.inc
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
38 "
39 36
40SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76" 37SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76"
41BRANCH = "5.7"
42 38
43DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
44 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
45RDEPENDS_${PN} = "libcrypto" 41RDEPENDS_${PN} = "libcrypto"
46 42
47S = "${WORKDIR}/git"
48
49EXTRA_QMAKEVARS_PRE += "\ 43EXTRA_QMAKEVARS_PRE += "\
50 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ 44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
51 -config enable-dummydata \ 45 -config enable-dummydata \
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index b50defc..0c50457 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -35,15 +35,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ 35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" 36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02"
37 37
38inherit qt5-module sdk-sources 38inherit qt5-module
39 39require recipes-qt/qt5/qt5-git.inc
40SRC_URI = " \
41 git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \
42 "
43 40
44SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a" 41SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a"
45BRANCH = "5.7"
46
47S = "${WORKDIR}/git"
48 42
49DEPENDS = "qtbase qtdeclarative" 43DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
index 3034760..b06446e 100644
--- a/recipes-qt/automotive/qtwebbrowser_git.bb
+++ b/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -31,16 +31,13 @@ DESCRIPTION = "Qt Web Browser"
31LICENSE = "GPL-3.0" 31LICENSE = "GPL-3.0"
32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6" 32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-qtwebbrowser"
37 git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=http;sdk-uri=5.7/Src/qtwebbrowser \ 38QT_MODULE_BRANCH = "dev"
38 "
39 39
40SRCREV = "023733af5523a5ad84359926224fa106001215f4" 40SRCREV = "023733af5523a5ad84359926224fa106001215f4"
41BRANCH = "dev"
42
43S = "${WORKDIR}/git"
44 41
45DEPENDS = "qtbase qtdeclarative qtwebengine" 42DEPENDS = "qtbase qtdeclarative qtwebengine"
46 43
diff --git a/recipes-qt/b2qt-addons/b2qt-demos.bb b/recipes-qt/b2qt-addons/b2qt-demos.bb
index bd0b9f7..eec5bc4 100644
--- a/recipes-qt/b2qt-addons/b2qt-demos.bb
+++ b/recipes-qt/b2qt-addons/b2qt-demos.bb
@@ -31,13 +31,13 @@ DESCRIPTION = "Boot to Qt Demos"
31LICENSE = "BSD | The-Qt-Company-DCLA-2.1" 31LICENSE = "BSD | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" 32LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35 35
36SRC_URI = " \ 36SRC_URI = " \
37 git://codereview.qt-project.org/qt-apps/boot2qt-demos.git;branch=${BRANCH};protocol=http;name=demos \ 37 ${QT_GIT}/qt-apps-boot2qt-demos.git;branch=${BRANCH};name=demos \
38 ${QT_GIT}/qtcanvas3d.git;branch=${QT_BRANCH};name=qtcanvas3d;destsuffix=qtcanvas3d \ 38 ${QT_GIT}/qtcanvas3d.git;branch=${QT_BRANCH};name=qtcanvas3d;destsuffix=qtcanvas3d \
39 ${QT_GIT}/qtquickcontrols.git;branch=${QT_BRANCH};name=qtquickcontrols;destsuffix=qtquickcontrols \ 39 ${QT_GIT}/qtquickcontrols.git;branch=${QT_BRANCH};name=qtquickcontrols;destsuffix=qtquickcontrols \
40 git://codereview.qt-project.org/qt-apps/qtwebbrowser.git;branch=${BROWSER_BRANCH};protocol=http;name=qtwebbrowser;destsuffix=git/basicsuite/qtwebbrowser/tqtc-qtwebbrowser;sdk-uri=5.7/Boot2Qt/sources/b2qt-demos/basicsuite/qtwebbrowser/tqtc-qtwebbrowser \ 40 ${QT_GIT}/qt-apps-qtwebbrowser.git;branch=${BROWSER_BRANCH};name=qtwebbrowser;destsuffix=git/basicsuite/qtwebbrowser/tqtc-qtwebbrowser \
41 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt_video_720p.webm;name=video1 \ 41 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt_video_720p.webm;name=video1 \
42 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \ 42 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \
43 " 43 "
diff --git a/recipes-qt/b2qt-addons/b2qt-launcher.bb b/recipes-qt/b2qt-addons/b2qt-launcher.bb
index d5ff015..e131b2a 100644
--- a/recipes-qt/b2qt-addons/b2qt-launcher.bb
+++ b/recipes-qt/b2qt-addons/b2qt-launcher.bb
@@ -32,19 +32,17 @@ LICENSE = "(BSD & GPL-3.0) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
33 33
34inherit qmake5 34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-boot2qt-launcher"
37 git://codereview.qt-project.org/qt-apps/boot2qt-launcher;branch=${BRANCH};protocol=http \ 38
39SRC_URI += " \
38 file://b2qt-startup.sh \ 40 file://b2qt-startup.sh \
39 file://qtlauncher.service \ 41 file://qtlauncher.service \
40 file://b2qt.service \ 42 file://b2qt.service \
41 " 43 "
42 44
43SRCREV = "7ff96b74f8721dbaf50722561770815a4530b6a0" 45SRCREV = "7ff96b74f8721dbaf50722561770815a4530b6a0"
44BRANCH = "5.7"
45PV = "5.7+git${SRCPV}"
46
47S = "${WORKDIR}/git"
48 46
49DEPENDS = "qtbase qtdeclarative \ 47DEPENDS = "qtbase qtdeclarative \
50 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" 48 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
diff --git a/recipes-qt/b2qt-addons/democompositor_git.bb b/recipes-qt/b2qt-addons/democompositor_git.bb
index a12e83b..d63df0e 100644
--- a/recipes-qt/b2qt-addons/democompositor_git.bb
+++ b/recipes-qt/b2qt-addons/democompositor_git.bb
@@ -32,14 +32,11 @@ LICENSE = "BSD | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://main.cpp;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49" 32LIC_FILES_CHKSUM = "file://main.cpp;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49"
33 33
34inherit qmake5 34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-boot2qt-demos"
37 git://codereview.qt-project.org/qt-apps/boot2qt-demos.git;branch=${BRANCH};protocol=http \
38 "
39 38
40SRCREV = "a6d8f7ce79fb5c17e706f25daf4dda4d97b5323e" 39SRCREV = "a6d8f7ce79fb5c17e706f25daf4dda4d97b5323e"
41BRANCH = "5.7"
42PV = "5.7+git${SRCPV}"
43 40
44S = "${WORKDIR}/git/wayland/democompositor/" 41S = "${WORKDIR}/git/wayland/democompositor/"
45 42
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index 5ec66b4..25a567d 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -37,7 +37,6 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37RDEPENDS_${PN} += " \ 37RDEPENDS_${PN} += " \
38 b2qt-appcontroller \ 38 b2qt-appcontroller \
39 b2qt-utils \ 39 b2qt-utils \
40 b2qt-ota \
41 qtivi \ 40 qtivi \
42 neptune-ui \ 41 neptune-ui \
43 neptune-ui-apps \ 42 neptune-ui-apps \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
index ff2d206..9c2008d 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -37,7 +37,6 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37RDEPENDS_${PN} += " \ 37RDEPENDS_${PN} += " \
38 b2qt-appcontroller \ 38 b2qt-appcontroller \
39 b2qt-utils \ 39 b2qt-utils \
40 b2qt-ota \
41 b2qt-launcher \ 40 b2qt-launcher \
42 b2qt-demos \ 41 b2qt-demos \
43 ${@base_contains("DISTRO_FEATURES", "wayland", "democompositor", "", d)} \ 42 ${@base_contains("DISTRO_FEATURES", "wayland", "democompositor", "", d)} \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 5286ac5..652c931 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -53,6 +53,7 @@ RDEPENDS_${PN} += " \
53 qtimageformats-dev \ 53 qtimageformats-dev \
54 qtlocation-dev \ 54 qtlocation-dev \
55 qtmultimedia-dev \ 55 qtmultimedia-dev \
56 qtotaupdate-dev \
56 qtquickcontrols-dev \ 57 qtquickcontrols-dev \
57 qtquickcontrols2-dev \ 58 qtquickcontrols2-dev \
58 qtsensors-dev \ 59 qtsensors-dev \
@@ -68,7 +69,6 @@ RDEPENDS_${PN} += " \
68 qtxmlpatterns-dev \ 69 qtxmlpatterns-dev \
69 \ 70 \
70 b2qt-utils-dev \ 71 b2qt-utils-dev \
71 b2qt-ota-dev \
72 qtcharts-dev \ 72 qtcharts-dev \
73 qtdatavis3d-dev \ 73 qtdatavis3d-dev \
74 qtvirtualkeyboard-dev \ 74 qtvirtualkeyboard-dev \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index 06de528..8138b3e 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -48,6 +48,7 @@ RDEPENDS_${PN} += " \
48 qtimageformats \ 48 qtimageformats \
49 qtlocation \ 49 qtlocation \
50 qtmultimedia \ 50 qtmultimedia \
51 qtotaupdate \
51 qtquickcontrols \ 52 qtquickcontrols \
52 qtquickcontrols2 \ 53 qtquickcontrols2 \
53 qtsensors \ 54 qtsensors \
diff --git a/recipes-qt/b2qt-addons/b2qt-ota.bb b/recipes-qt/qt5/qtotaupdate.bb
index 5b00b48..9cafd8c 100644
--- a/recipes-qt/b2qt-addons/b2qt-ota.bb
+++ b/recipes-qt/qt5/qtotaupdate.bb
@@ -1,3 +1,8 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
1## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
2## 7##
3## $QT_BEGIN_LICENSE:GPL$ 8## $QT_BEGIN_LICENSE:GPL$
@@ -23,20 +28,15 @@
23############################################################################ 28############################################################################
24 29
25DESCRIPTION = "Qt OTA Update module" 30DESCRIPTION = "Qt OTA Update module"
26LICENSE = "The-Qt-Company-DCLA-2.1" 31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
27LIC_FILES_CHKSUM = "file://src/lib/qotaclient.h;md5=da66cc6e520f8151501c0f6c11480077;beginline=1;endline=28" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
28 33
29inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc
30 36
31SRC_URI = " \ 37QT_GIT = "git://github.com/qt"
32 git://codereview.qt-project.org/qt/qtotaupdate;branch=${BRANCH};protocol=http \ 38QT_MODULE_BRANCH = "master"
33 "
34 39
35SRCREV = "d8d81530692454e4e38f682f6a09049d27b8c1ad" 40SRCREV = "f48ab751dd43906d5b9492e3f124b94f189b9971"
36BRANCH = "master"
37PV = "git${SRCPV}"
38
39S = "${WORKDIR}/git"
40 41
41DEPENDS = "qtbase qtdeclarative ostree" 42DEPENDS = "qtbase qtdeclarative ostree"
42
diff --git a/recipes-qt/qt5-addons/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
index 564fc3d..564fc3d 100644
--- a/recipes-qt/qt5-addons/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
diff --git a/recipes/os-release/os-release.bbappend b/recipes/os-release/os-release.bbappend
deleted file mode 100644
index a225573..0000000
--- a/recipes/os-release/os-release.bbappend
+++ /dev/null
@@ -1,47 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# Reported upstream https://bugzilla.yoctoproject.org/show_bug.cgi?id=9144
31python do_fix_quotes () {
32 with open(d.expand('${B}/os-release'), 'w') as f:
33 for field in d.getVar('OS_RELEASE_FIELDS', True).split():
34 value = d.getVar(field, True)
35 if value:
36 f.write('{0}="{1}"\n'.format(field, value))
37}
38
39do_verify_if_fixed_by_upstream () {
40 pretty_name_first_char=$(cat ${B}/os-release | grep "^PRETTY_NAME" | cut -f 2 -d '=' | cut -c1)
41 if [ "${pretty_name_first_char}" = "\"" ]] ; then
42 bbwarn "Issue appears to be fixed by upstream, remove this workaround."
43 fi
44}
45
46addtask do_verify_if_fixed_by_upstream after do_compile before do_install
47addtask do_fix_quotes after do_verify_if_fixed_by_upstream before do_install
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 9d6effc..3354dd2 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -17,11 +17,11 @@
17 17
18 <project name="poky" 18 <project name="poky"
19 remote="yocto" 19 remote="yocto"
20 revision="b1f23d1254682866236bfaeb843c0d8aa332efc2" 20 revision="40376446904ae3529be41737fed9a0b650ed167d"
21 path="sources/poky"/> 21 path="sources/poky"/>
22 <project name="meta-openembedded" 22 <project name="meta-openembedded"
23 remote="oe-mirror" 23 remote="oe-mirror"
24 revision="dc5634968b270dde250690609f0015f881db81f2" 24 revision="8ab04afbffb4bc5184cfe0655049de6f44269990"
25 path="sources/meta-openembedded"/> 25 path="sources/meta-openembedded"/>
26 <project name="meta-qt5" 26 <project name="meta-qt5"
27 remote="qtyocto" 27 remote="qtyocto"
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index c9e3949..d4087c3 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -47,6 +47,9 @@ for S in $SHA1S; do
47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then 47 elif [ "${PROJECT}" = "qtwebengine/src/3rdparty" ]; then
48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb* 48 sed -i -e "/^SRCREV_chromium/s/\".*\"/\"${SHA1}\"/" qtwebengine_git.bb*
49 echo "qtwebengine (chromium) -> ${SHA1}" 49 echo "qtwebengine (chromium) -> ${SHA1}"
50 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ]; then
51 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb*
52 echo "qtquickcompiler -> ${SHA1}"
50 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then 53 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then
51 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* 54 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb*
52 echo "${PROJECT} -> ${SHA1}" 55 echo "${PROJECT} -> ${SHA1}"