diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-04-09 10:43:18 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-04-17 06:22:27 +0000 |
commit | 1677194dcca9e0c3e351cba686206497f06e527d (patch) | |
tree | f2d9eac7b93d1e715ffa9bd38d71c3bdb2eaf18b | |
parent | 18c087f0a9c6788eeb62998044ee15641097dbf4 (diff) | |
download | meta-boot2qt-1677194dcca9e0c3e351cba686206497f06e527d.tar.gz |
tegra: update to L4T 28.2
Task-number: QTBUG-67257
Change-Id: I1c47ac72d4c4105e11d81b96f987f59bd07b7e10
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | meta-boot2qt-distro/conf/distro/include/jetson.inc | 5 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/drm/libdrm_%.bbappend | 15 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend | 2 | ||||
-rw-r--r-- | scripts/manifest.xml | 2 |
4 files changed, 23 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/jetson.inc b/meta-boot2qt-distro/conf/distro/include/jetson.inc index 98c71f4..bb1859c 100644 --- a/meta-boot2qt-distro/conf/distro/include/jetson.inc +++ b/meta-boot2qt-distro/conf/distro/include/jetson.inc | |||
@@ -42,3 +42,8 @@ QBSP_IMAGE_CONTENT = "\ | |||
42 | ${IMAGE_LINK_NAME}.img \ | 42 | ${IMAGE_LINK_NAME}.img \ |
43 | ${IMAGE_LINK_NAME}.conf \ | 43 | ${IMAGE_LINK_NAME}.conf \ |
44 | " | 44 | " |
45 | |||
46 | BBMASK += "\ | ||
47 | meta-tegra/recipes-graphics/drm \ | ||
48 | meta-tegra/external/openembedded-layer/recipes-support/opencv \ | ||
49 | " | ||
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend new file mode 100644 index 0000000..bf4cc08 --- /dev/null +++ b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend | |||
@@ -0,0 +1,15 @@ | |||
1 | inherit update-alternatives | ||
2 | |||
3 | do_install_append() { | ||
4 | mv ${D}${libdir}/libdrm.so.2.4.0 ${D}${libdir}/libdrm-freedesktop.so.2.4.0 | ||
5 | rm ${D}${libdir}/libdrm.so | ||
6 | rm ${D}${libdir}/libdrm.so.2 | ||
7 | ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so | ||
8 | ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so.2 | ||
9 | } | ||
10 | |||
11 | ALTERNATIVE_${PN} = "libdrm.so.2.4.0 libdrm.so.2" | ||
12 | ALTERNATIVE_LINK_NAME[libdrm.so.2.4.0] = "${libdir}/libdrm.so.2.4.0" | ||
13 | ALTERNATIVE_LINK_NAME[libdrm.so.2] = "${libdir}/libdrm.so.2" | ||
14 | ALTERNATIVE_TARGET = "${libdir}/libdrm-freedesktop.so.2.4.0" | ||
15 | ALTERNATIVE_PRIORITY = "20" | ||
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend index db152a3..d3c4803 100644 --- a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend +++ b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend | |||
@@ -31,3 +31,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
31 | SRC_URI += "\ | 31 | SRC_URI += "\ |
32 | file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \ | 32 | file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \ |
33 | " | 33 | " |
34 | |||
35 | require recipes-kernel/linux/linux-dtb.inc | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 86c1dd7..83cf64c 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -60,7 +60,7 @@ | |||
60 | groups="notdefault,external,intel"/> | 60 | groups="notdefault,external,intel"/> |
61 | <project name="meta-tegra" | 61 | <project name="meta-tegra" |
62 | remote="madisongh" | 62 | remote="madisongh" |
63 | revision="34ddb90840f9bb895cd5d275922d153e35620fa3" | 63 | revision="4aea5e3785dc400e31981467f475b54e652dbd67" |
64 | path="sources/meta-tegra" | 64 | path="sources/meta-tegra" |
65 | groups="notdefault,external,jetson"/> | 65 | groups="notdefault,external,jetson"/> |
66 | <project name="meta-renesas" | 66 | <project name="meta-renesas" |